[PATCH] gnu: hostapd: Add ACS and full dynamic vpn support

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexey Abramov
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal

Debbugs page

Alexey Abramov wrote 2 years ago
(address . guix-patches@gnu.org)
20230414064641.8484-1-levenson@mmer.org
* gnu/packages/admin.scm (hostapd): ACS (Automatic Channel Selection)
will allow hostapd to pick the channel automatically. Full dynamic
vlan support enables hostapd to automatically create bridge and VLAN
interfaces if necessary (enables vlan_tagged_interface option).
---
gnu/packages/admin.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c974a1d926..7cb8cf4da0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2317,7 +2318,9 @@ (define-public hostapd
(display "CONFIG_LIBNL32=y
CONFIG_IEEE80211R=y
CONFIG_IEEE80211N=y
- CONFIG_IEEE80211AC=y\n" port)
+ CONFIG_IEEE80211AC=y
+ CONFIG_FULL_DYNAMIC_VLAN=y
+ CONFIG_ACS=y\n" port)
(close-port port))))
(add-after 'unpack 'patch-pkg-config
(lambda _
--
2.39.2
Alexey Abramov wrote 2 years ago
[PATCH v2] gnu: hostapd: Add ACS and full dynamic vlan support
(address . 62826@debbugs.gnu.org)
20230414065051.9330-1-levenson@mmer.org
* gnu/packages/admin.scm (hostapd): ACS (Automatic Channel Selection)
will allow hostapd to pick the channel automatically. Full dynamic
vlan support enables hostapd to automatically create bridge and VLAN
interfaces if necessary (enables vlan_tagged_interface option).
---
gnu/packages/admin.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c974a1d926..7cb8cf4da0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2317,7 +2318,9 @@ (define-public hostapd
(display "CONFIG_LIBNL32=y
CONFIG_IEEE80211R=y
CONFIG_IEEE80211N=y
- CONFIG_IEEE80211AC=y\n" port)
+ CONFIG_IEEE80211AC=y
+ CONFIG_FULL_DYNAMIC_VLAN=y
+ CONFIG_ACS=y\n" port)
(close-port port))))
(add-after 'unpack 'patch-pkg-config
(lambda _
--
2.39.2
Ludovic Courtès wrote 2 years ago
Re: bug#62826: [PATCH] gnu: hostapd: Add ACS and full dynamic vpn support
(name . Alexey Abramov)(address . levenson@mmer.org)(address . 62826-done@debbugs.gnu.org)
878re1la1y.fsf_-_@gnu.org
Hi,

Alexey Abramov <levenson@mmer.org> skribis:

Toggle quote (5 lines)
> * gnu/packages/admin.scm (hostapd): ACS (Automatic Channel Selection)
> will allow hostapd to pick the channel automatically. Full dynamic
> vlan support enables hostapd to automatically create bridge and VLAN
> interfaces if necessary (enables vlan_tagged_interface option).

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62826@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62826
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help