Alexey Abramov wrote 2 years ago
(address . guix-patches@gnu.org)
* gnu/packages/admin.scm (hostapd): ACS (Automatic Channel Selection)
will allow hostapd to pick the channel automatically. Full dynamic
vlan support enables hostapd to automatically create bridge and VLAN
interfaces if necessary (enables vlan_tagged_interface option).
---
gnu/packages/admin.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c974a1d926..7cb8cf4da0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2023 Juliana Sims <jtsims@protonmail.com>
;;; Copyright © 2023 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2317,7 +2318,9 @@ (define-public hostapd
(display "CONFIG_LIBNL32=y
CONFIG_IEEE80211R=y
CONFIG_IEEE80211N=y
- CONFIG_IEEE80211AC=y\n" port)
+ CONFIG_IEEE80211AC=y
+ CONFIG_FULL_DYNAMIC_VLAN=y
+ CONFIG_ACS=y\n" port)
(close-port port))))
(add-after 'unpack 'patch-pkg-config
(lambda _
--
2.39.2