[PATCH] gnu: Add libfyaml.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexey Abramov
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal

Debbugs page

Alexey Abramov wrote 2 years ago
(address . guix-patches@gnu.org)
20230414064251.7432-1-levenson@mmer.org
* gnu/packages/serialization.scm (libfyaml): New variable.
---
gnu/packages/serialization.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3f0a550920..30ab7b0a6a 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -426,6 +427,34 @@ (define-public libcyaml
(home-page "https://github.com/tlsa/libcyaml")
(license license:isc)))
+(define-public libfyaml
+ (package
+ (name "libfyaml")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pantoniou/libfyaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002g0grddfi5y42lq06zj8266rf7h27wq76sr598ad5pxllx3y3g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ pkg-config))
+ (home-page "https://github.com/pantoniou/libfyaml")
+ (synopsis "A fancy 1.2 YAML and JSON parser/writer.")
+ (description
+ "Fully feature complete YAML parser and emitter, supporting the latest YAML spec
+and passing the full YAML testsuite. It is designed to be very efficient, avoiding
+copies of data, and has no artificial limits like the 1024 character limit for
+implicit keys.")
+ (license license:expat)))
+
(define-public yaml-cpp
(package
(name "yaml-cpp")
--
2.39.2
Alexey Abramov wrote 2 years ago
[PATCH v2] gnu: Add libfyaml.
(address . 62824@debbugs.gnu.org)
20230414070149.11334-1-levenson@mmer.org
* gnu/packages/serialization.scm (libfyaml): New variable.
---
gnu/packages/serialization.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3f0a550920..87f377879d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -426,6 +427,34 @@ (define-public libcyaml
(home-page "https://github.com/tlsa/libcyaml")
(license license:isc)))
+(define-public libfyaml
+ (package
+ (name "libfyaml")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pantoniou/libfyaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002g0grddfi5y42lq06zj8266rf7h27wq76sr598ad5pxllx3y3g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ pkg-config))
+ (home-page "https://github.com/pantoniou/libfyaml")
+ (synopsis "A fancy 1.2 YAML and JSON parser/writer")
+ (description
+ "Fully feature complete YAML parser and emitter, supporting the latest YAML spec
+and passing the full YAML testsuite. It is designed to be very efficient, avoiding
+copies of data, and has no artificial limits like the 1024 character limit for
+implicit keys.")
+ (license license:expat)))
+
(define-public yaml-cpp
(package
(name "yaml-cpp")
--
2.39.2
Alexey Abramov wrote 2 years ago
Re: bug#62824: [PATCH] gnu: Add libfyaml.
(name . bug#62824)(address . 62824@debbugs.gnu.org)
877cuflzbp.fsf@delta.lan
Hi,

Sorry for the noise. in v2 I removed a dot at the end of the synopsis.

--
Alexey
Alexey Abramov wrote 2 years ago
[PATCH v3] gnu: Add libfyaml.
(address . 62824@debbugs.gnu.org)
20230415061331.28846-1-levenson@mmer.org
* gnu/packages/serialization.scm (libfyaml): New variable.
---
gnu/packages/serialization.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3f0a550920..677615a53d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -426,6 +427,33 @@ (define-public libcyaml
(home-page "https://github.com/tlsa/libcyaml")
(license license:isc)))
+(define-public libfyaml
+ (package
+ (name "libfyaml")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pantoniou/libfyaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002g0grddfi5y42lq06zj8266rf7h27wq76sr598ad5pxllx3y3g"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf
+ automake
+ libtool
+ pkg-config))
+ (home-page "https://github.com/pantoniou/libfyaml")
+ (synopsis "YAML version 1.2 and JSON parser/writer")
+ (description "Fully feature complete YAML parser and emitter, supporting the
+latest YAML spec and passing the full YAML testsuite. It is designed to be very
+efficient, avoiding copies of data, and has no artificial limits like the 1024
+character limit for implicit keys.")
+ (license license:expat)))
+
(define-public yaml-cpp
(package
(name "yaml-cpp")
--
2.39.2
Nicolas Goaziou wrote 2 years ago
(name . Alexey Abramov via Guix-patches via)(address . guix-patches@gnu.org)(name . Alexey Abramov)(address . levenson@mmer.org)(address . 62824-done@debbugs.gnu.org)
87r0rxvbod.fsf@nicolasgoaziou.fr
Hello,

Alexey Abramov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/serialization.scm (libfyaml): New variable.

Thank you. I slightly reworded the description so it would consist of
full sentences, and applied your patch.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62824@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62824
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help