[pyproject-build-system] build failure when using mesonpy pep 517 builder

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 11 Apr 2023 22:50
(name . bug-guix)(address . bug-guix@gnu.org)
87pm8akusy.fsf@gmail.com
Hi,

Attempting to update python-scipy on the core-updates branch, I tried
having it use pyproject-build-system with meson-python as the builder,
but it fails like:

Toggle snippet (18 lines)
starting phase `build'
Using 'mesonpy' to build wheels, auto-detected 'mesonpy', override '#f'.
Traceback (most recent call last):
File "<string>", line 4, in <module>
File "/gnu/store/mpclbasyclbc4pdkf96q2iksc687f3p7-meson-python-0.12.1/lib/python3.10/site-packages/mesonpy/__init__.py", line 1054, in wrapper
return func(*args, **kwargs)
File "/gnu/store/mpclbasyclbc4pdkf96q2iksc687f3p7-meson-python-0.12.1/lib/python3.10/site-packages/mesonpy/__init__.py", line 1115, in build_wheel
with _project(config_settings) as project:
File "/gnu/store/fxd7cxzv3fzkm745x26zswrsa4gfv3fs-python-3.10.7/lib/python3.10/contextlib.py", line 135, in __enter__
return next(self.gen)
File "/gnu/store/mpclbasyclbc4pdkf96q2iksc687f3p7-meson-python-0.12.1/lib/python3.10/site-packages/mesonpy/__init__.py", line 971, in _project
for key, value in config_settings.items()
AttributeError: 'list' object has no attribute 'items'
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import sys, importlib, json\nconfig_settings = json.loads (sys.argv[3])\nbuilder = importlib.import_module(sys.argv[1])\nbuilder.build_wheel(sys.argv[2], config_settings=config_settings)" "mesonpy" "dist" "[]") exit-status: 1 term-signal: #f stop-signal: #f>
phase `build' failed after 0.4 seconds

As I've seen this same error with another package/attempt (meson-python
itself), I'm creating this ticket. It's probably our custom Python code
in pyproject-build-system that needs to be updated.

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 62781@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62781
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch