[PATCH 0/9] Add Easyeffects

  • Done
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 11 Apr 2023 10:06
(name . Guix Patches)(address . guix-patches@gnu.org)
5fc823de-68d2-df3d-c7a0-2b6b474e262c@brendan.scot
I realized there was already a patch for this package here but its a bit

I did not use package-with-c-toolchain method because it seemed to
create some weird module dependency cycle with commencement
that broke compilation, so I just added gcc-11 to inputs.

I had to update a few dependencies to get this working, and we cannot
have the latest version until GTK>=4.10 is in guix. Additionally, serd
has a test suite now but there was an error with test_quiet.py "not
existing" even though it does, so I was left stumped and disabled tests
to avoid going insane.

Also this ends up causing a webkitgtk rebuild. Hope that isn't an issue.
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:08
[PATCH 1/9] gnu: vamp: Update to 2.10.0.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080853.22535-1-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (vamp): Update to 2.10.0.
---
gnu/packages/audio.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cf7fcd87c8..9125955d46 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2018, 2022 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2018, 2022, 2023 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
@@ -3883,16 +3883,16 @@ (define-public timidity++
(define-public vamp
(package
(name "vamp")
- (version "2.6")
+ (version "2.10.0")
(source (origin
(method url-fetch)
(uri (string-append
- "https://code.soundsoftware.ac.uk"
- "/attachments/download/1520/vamp-plugin-sdk-"
- version ".tar.gz"))
+ "https://code.soundsoftware.ac.uk/attachments/download/"
+ "2691" ; This mysterious number changes with each update
+ "/vamp-plugin-sdk-" version ".tar.gz"))
(sha256
(base32
- "0pzq0yy2kdl3jgfc2aqmh5m55nk1ild0hq8mydiiw35c6y0mglyh"))))
+ "0pzpkxrz71fzqd2m83kjyafzqzrifzsq5phcn7mqq52blii3gbxf"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 2/9] gnu: lv2: Update to 1.18.10.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-1-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (lv2): Update to 1.18.10.
[build-system]: Use meson.
[arguments]: Enable tests.
---
gnu/packages/audio.scm | 11 ++++-------
1 file changed, 4 insertions(+), 7 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9125955d46..a02c49130c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3134,18 +3134,15 @@ (define-public lilv
(define-public lv2
(package
(name "lv2")
- (version "1.18.2")
+ (version "1.18.10")
(source (origin
(method url-fetch)
(uri (string-append "https://lv2plug.in/spec/lv2-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "0pp0n9x1rg8d4fw853z9cvfifjdi4bl85yjxxddqa1acfjy1z2af"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:configure-flags '("--no-plugins")))
+ "0gwm63jrvg9lww0rl3sjkgbjwfz0vascpb19cfxmhkmm477ipibq"))))
+ (build-system meson-build-system)
(inputs
;; Leaving off cairo and gtk+-2.0 which are needed for example plugins
(list libsndfile))
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 3/9] gnu: serd: Update to 0.30.16.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-2-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/rdf.scm (serd): Update to 0.30.16.
[build-system]: Use meson.
[arguments]: Remove.ldflag hack not needed with meson.
---
gnu/packages/rdf.scm | 23 ++++++++---------------
1 file changed, 8 insertions(+), 15 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 13e62baa84..c62bcd4380 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@ (define-module (gnu packages rdf)
#:use-module (guix download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system waf)
#:use-module (gnu packages)
@@ -278,27 +280,18 @@ (define-public redland
(define-public serd
(package
(name "serd")
- (version "0.30.8")
+ (version "0.30.16")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/serd-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "11zs53yx40mv62vxsl15mvdh7s17y5v6lgcgahdvzxgnan7w8bk7"))))
- (build-system waf-build-system)
+ "0ilimkczibiwwvc12i14b8zi6ng42hjf9j907g8dik8rlmnlh3zm"))))
+ (build-system meson-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))
- #t)))))
- (home-page "https://drobilla.net/software/serd/")
+ `(#:tests? #f)) ; Tests fail due to "file not found" even though it exists??
+ (home-page "https://drobilla.net/software/serd.html")
(synopsis "Library for RDF syntax supporting Turtle and NTriples")
(description
"Serd is a lightweight C library for RDF syntax which supports reading
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 4/9] gnu: sord: Update to 0.16.14.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-3-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/rdf.scm (sord): Update to 0.16.14.
[build-system]: Use meson.
[arguments]: Remove.ldflag hack not needed with meson.
---
gnu/packages/rdf.scm | 21 +++++----------------
1 file changed, 5 insertions(+), 16 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index c62bcd4380..1fab18a1a2 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -305,33 +305,22 @@ (define-public serd
(define-public sord
(package
(name "sord")
- (version "0.16.8")
+ (version "0.16.14")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/sord-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "052y7zllrg0bzyky2rmrrwnnf16p6bk7q40rq9mgm0mzm8p9sa3w"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))
- #t)))))
+ "06vkqk3dnn15zdnzklahib2pvbfspy2zcrnvhmxnw8fbbxyxj3r2"))))
+ (build-system meson-build-system)
(inputs
(list pcre))
(native-inputs
(list pkg-config))
(propagated-inputs
(list serd)) ; required by sord-0.pc
- (home-page "https://drobilla.net/software/sord/")
+ (home-page "https://drobilla.net/software/sord.html")
(synopsis "C library for storing RDF data in memory")
(description
"Sord is a lightweight C library for storing RDF data in memory.")
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 5/9] gnu: sratom: Update to 0.6.14.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-4-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (sratom): Update to 0.6.14.
[build-system]: Use meson.
---
gnu/packages/audio.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a02c49130c..e2d788bfeb 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3738,22 +3738,22 @@ (define-public rtmidi-4.0
(define-public sratom
(package
(name "sratom")
- (version "0.6.6")
+ (version "0.6.14")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/sratom-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "178v90qvsp6lw4sqdmdz0bzyjkgwhv9m75ph1d1z8say5bv0p4gv"))))
- (build-system waf-build-system)
+ "1rm1mkzmqr8k818xxpm69f5jp1fnxjglj3l5ngcysfmq1psgm0lr"))))
+ (build-system meson-build-system)
(arguments `(#:tests? #f)) ;no check target
(propagated-inputs
;; In Requires of sratom-0.pc.
(list lv2 serd sord))
(native-inputs
(list pkg-config))
- (home-page "https://drobilla.net/software/sratom/")
+ (home-page "https://drobilla.net/software/sratom.html")
(synopsis "Library for serialising LV2 atoms to/from RDF")
(description
"Sratom is a library for serialising LV2 atoms to/from RDF, particularly
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 6/9] gnu: rubberband: Update to 3.2.1.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-5-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (rubberband): Update to 3.2.1
[origin]: Use current upstream repository location.
[arguments]: Use libsamplerate over builtin resampler.
Use guix fftw over bundled version.
[inputs]: Add lv2 plugin support. Add fftw.
[native-search-paths]: Add lv2 nad ladspa search paths.
---
gnu/packages/audio.scm | 46 ++++++++++++++++++++++++------------------
1 file changed, 26 insertions(+), 20 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e2d788bfeb..7d62617667 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -143,6 +143,7 @@ (define-module (gnu packages audio)
#:use-module (guix build-system trivial)
#:use-module (guix build-system waf)
#:use-module (guix download)
+ #:use-module (guix hg-download)
#:use-module (guix git-download)
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
@@ -3663,33 +3664,38 @@ (define-public resample
(define-public rubberband
(package
(name "rubberband")
- (version "1.8.2")
+ (version "3.2.1")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://bitbucket.org/breakfastquay/rubberband/get/v"
- version
- ".tar.bz2"))
- (file-name (string-append name "-" version ".tar.bz2"))
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://hg.sr.ht/~breakfastquay/rubberband")
+ (changeset (string-append "v" version))))
+ (file-name (hg-file-name name version))
(sha256
(base32
- "0462fmjnfqpv2qi0s6ny42drqarkr0xy9lw8frjmfgzyzl5n9294"))))
- (build-system gnu-build-system)
+ "0zxq4d4i89s83r95vrb0h4zpkpqbsy2y2vralg30x57z3y2w702i"))))
+ (build-system meson-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-jni-installation
- ;; ‘make install’ unconditionally installs librubberband-jni.so,
- ;; which is never built by ‘make all’. Skip it.
- (lambda _
- (substitute* "Makefile.in"
- ((".*cp -f \\$\\(JNI_TARGET\\).*") ""))
- #t)))))
+ '(#:tests? #f ; missing boost unit test library
+ #:configure-flags
+ '("-Dresampler=libsamplerate"
+ "-Dfft=fftw" ; To avoid using bundled version
+ "-Ddefault_library=shared"))) ; Don't build static library
(inputs
- (list ladspa libsamplerate vamp))
+ (list ladspa
+ libsamplerate
+ vamp
+ lv2
+ fftw))
(native-inputs
(list pkg-config))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))
+ (search-path-specification
+ (variable "LADSPA_PATH")
+ (files '("lib/ladspa")))))
(home-page "https://breakfastquay.com/rubberband/")
(synopsis "Audio time-stretching and pitch-shifting library")
(description
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 7/9] gnu: mda-lv2: Update to 1.2.10.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-6-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (mda-lv2): Update to 1.2.10.
[build-system]: Use meson.
[arguments]: Remove unnecessary flags
---
gnu/packages/audio.scm | 15 +++++----------
1 file changed, 5 insertions(+), 10 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7d62617667..f73f181512 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -6209,20 +6209,15 @@ (define-public python-librosa
(define-public mda-lv2
(package
(name "mda-lv2")
- (version "1.2.6")
+ (version "1.2.10")
(source
(origin
(method url-fetch)
(uri (string-append "http://download.drobilla.net/mda-lv2-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
- (base32 "1nspk2j11l65m5r9z5isw8j749vh9a89wgx8mkrrq15f4iq12rnd"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; There are no tests.
- #:configure-flags
- (list (string-append "--prefix="
- (assoc-ref %outputs "out")))))
+ (base32 "0nm7qahkrxjydv1wii46ca6948srwhjilhlp54z9bpcnln35ksmf"))))
+ (build-system meson-build-system)
(inputs
(list lv2))
(native-inputs
@@ -6231,7 +6226,7 @@ (define-public mda-lv2
(list (search-path-specification
(variable "LV2_PATH")
(files '("lib/lv2")))))
- (home-page "https://drobilla.net/software/mda-lv2")
+ (home-page "https://drobilla.net/software/mda-lv2.html")
(synopsis "Audio plug-in pack for LV2")
(description
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 8/9] gnu: lilv: Update to 0.24.20.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-7-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (lilv): Update to 0.24.20.
[build-system]: Use meson.
[arguments]: Remove.ldflag hack not needed with meson.
---
gnu/packages/audio.scm | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f73f181512..519ca1493d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3095,24 +3095,19 @@ (define-public audio-to-midi
(define-public lilv
(package
(name "lilv")
- (version "0.24.12")
+ (version "0.24.20")
(source (origin
(method url-fetch)
(uri (string-append "https://download.drobilla.net/lilv-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "0qchfsyrsrp2pdpd59025kllycr04ddpzd03ha1iz70ci687g8r6"))))
- (build-system waf-build-system)
+ "1g7f29i0jajswyg67k7hdnmyqk32fmmxw6xppf9fm1mjp2wq5c2g"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'set-ldflags
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib"))))
(add-after 'unpack 'full-store-path-to-shared-library
(lambda* (#:key outputs #:allow-other-keys)
(with-directory-excursion "bindings/python"
--
2.39.2
'
'
'Brendan Tildesley wrote on 11 Apr 2023 10:09
[PATCH 9/9] gnu: Add easyeffects.
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
20230411080955.22584-8-mail@brendan.scot
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/audio.scm (easyeffects): New variable.
---
gnu/packages/audio.scm | 98 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 98 insertions(+)

Toggle diff (136 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 519ca1493d..d9c736be71 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -71,6 +71,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
#:use-module (gnu packages dbm)
#:use-module (gnu packages documentation)
@@ -80,6 +81,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages flex)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
@@ -111,6 +113,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages pulseaudio) ;libsndfile, libsamplerate
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
@@ -122,6 +125,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages tbb)
#:use-module (gnu packages telephony)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
@@ -6378,3 +6382,97 @@ (define-public cubeb
(description "Cubeb is Mozilla's cross-platform audio library.")
(home-page "https://github.com/mozilla/cubeb")
(license license:isc))))
+
+(define-public easyeffects
+ (package
+ (name "easyeffects")
+ (version "7.0.1") ; later version require gtk 4.10
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wwmm/easyeffects")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0c49yd4dfh7qarq5h651dgxdbs71is4pp1sl8r0gfswqji6bv39w"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list `(,glib "bin") ;for glib-compile-resources
+ gcc-11 ; for #include <source_location>
+ gettext-minimal
+ itstool
+ pkg-config))
+ (inputs
+ (list fftwf
+ fmt
+ gsl
+ gtk
+ json-modern-cxx ;nlohmann_json
+ libadwaita
+ libbs2b
+ libebur128
+ libportal
+ libsamplerate
+ libsigc++
+ libsndfile
+ lilv
+ pango-next
+ pipewire
+ rnnoise
+ speex
+ speexdsp
+ tbb
+ zita-convolver))
+ ;; Propagating these allows EasyEffects to find the plugins via their
+ ;; search-path specification
+ (propagated-inputs
+ (list calf
+ lsp-plugins
+ lv2
+ mda-lv2
+ rubberband
+ zam-plugins))
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _ ; Remove dependency on needless desktop cache stuff.
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true") "gtk_update_icon_cache: false")
+ (("update_desktop_database: true") "update_desktop_database: false")))))))
+ (home-page "https://github.com/wwmm/easyeffects")
+ (synopsis "Realtime Audio effects interface for Pipewire")
+ (description "EasyEffects is an advanced audio manipulation tool providing
+a graphical user interface to apply various effects and filters to audio
+streams using Pipewire. Effects can be applied in real time to audio inputs or
+outputs such as a microphone to reduce noise or apply many other effects
+including:
+
+@itemize
+@item Auto gain
+@item Bass enhancer
+@item Bass loudness
+@item Compressor
+@item Convolver
+@item Crossfeed
+@item Crystalizer
+@item De-esser
+@item Delay
+@item Echo Canceller
+@item Equalizer
+@item Exciter
+@item Filter (low-pass, high-pass, band-pass and band-reject modes)
+@item Gate
+@item Limiter
+@item Loudness
+@item Maximizer
+@item Multiband compressor
+@item Multiband gate
+@item Noise reduction
+@item Pitch
+@item Reverberation
+@item Speech Processor
+@item Stereo tools
+@end itemize")
+ (license license:gpl3+)))
--
2.39.2
R
R
Ricardo Wurmus wrote on 10 Jan 10:40 +0100
[PATCH 0/9] Add Easyeffects
(address . 62771@debbugs.gnu.org)(name . Brendan Tildesley)(address . mail@brendan.scot)
87y1cxh646.fsf@elephly.net
Thank you so much for this patch series. It looks good to me. The
biggest problem is the large number of rebuilds, but we can use
ci.guix.gnu.org to build everything with this patch series applied.

I’ll create a new branch “wip-easyeffects-62771” and apply your
(rebased) patches, and then have ci.guix.gnu.org build it for x86_64.
If there are any new failures we should address them first. Once there
are no new failures on x86_64 I’ll update the jobset to build for all
architectures.

Do you think you could keep an eye on the progress at ci.guix.gnu.org?

Minor issues that I’ll take care of before applying the patches:

* there’s a typo in a commit message:
“[native-search-paths]: Add lv2 nad ladspa search paths.”

--
Ricardo
B
B
Brendan Tildesley wrote on 10 Jan 13:32 +0100
6b211678-b129-4ea6-8051-4b1e16558ff6@app.fastmail.com
On Wed, Jan 10, 2024, at 8:40 PM, Ricardo Wurmus wrote:
Toggle quote (2 lines)
> Thank you so much for this patch series.
> [...]
You're welcome :]

I'm currently transferring at Singapore airport, heading to China. I think I will be busy and not prioritising guix at the moment. For now I'll assist on my my mobile phone by making a TODO list below:

It should be possible to remove the inclusion of gcc-11 as an input now that it is the default.
Update serd to 0.32.0
Update sord to 0.16.16
Update sratom to 0.6.16
Update rubber to 3.3.0
Update lilv to 0.24.22
Update lilv homepage to have .html on the end.
Fix typo in commit: native-search-paths]: Add lv2 nad ladspa search paths
Attachment: file
R
R
Ricardo Wurmus wrote on 10 Jan 13:34 +0100
8734v574c4.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (6 lines)
> I’ll create a new branch “wip-easyeffects-62771” and apply your
> (rebased) patches, and then have ci.guix.gnu.org build it for x86_64.
> If there are any new failures we should address them first. Once there
> are no new failures on x86_64 I’ll update the jobset to build for all
> architectures.

I’ve rebased the patch set on top of master and took the opportunity to
enable the test suites in lilv, sratom, and serd.

The branch is being built here:


--
Ricardo
R
R
Ricardo Wurmus wrote on 10 Jan 19:47 +0100
(name . Brendan Tildesley)(address . mail@brendan.scot)(address . 62771@debbugs.gnu.org)
87a5pd58jr.fsf@elephly.net
"Brendan Tildesley" <mail@brendan.scot> writes:

Toggle quote (9 lines)
> It should be possible to remove the inclusion of gcc-11 as an input now that it is the default.
> Update serd to 0.32.0
> Update sord to 0.16.16
> Update sratom to 0.6.16
> Update rubber to 3.3.0
> Update lilv to 0.24.22
> Update lilv homepage to have .html on the end.
> Fix typo in commit: native-search-paths]: Add lv2 nad ladspa search paths

I’ve done all this and pushed to the wip-easyeffects-62771 branch.

Toggle quote (2 lines)
> I'm currently transferring at Singapore airport, heading to China.

Safe travels!

--
Ricardo
B
B
Brendan Tildesley wrote on 11 Jan 05:37 +0100
[PATCH 0/9] Add Easyeffects
(address . 62771@debbugs.gnu.org)
3D8F0B11-188E-43CA-9E0A-F8272D715EDC@brendan.scot

Attachment: file
R
R
Ricardo Wurmus wrote on 11 Jan 23:51 +0100
87wmsf4h5u.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (13 lines)
> "Brendan Tildesley" <mail@brendan.scot> writes:
>
>> It should be possible to remove the inclusion of gcc-11 as an input now that it is the default.
>> Update serd to 0.32.0
>> Update sord to 0.16.16
>> Update sratom to 0.6.16
>> Update rubber to 3.3.0
>> Update lilv to 0.24.22
>> Update lilv homepage to have .html on the end.
>> Fix typo in commit: native-search-paths]: Add lv2 nad ladspa search paths
>
> I’ve done all this and pushed to the wip-easyeffects-62771 branch.

I just merged it into the master branch.

--
Ricardo
Closed
?