[PATCH] services: dhcp-client-configuration: Add 'shepherd-requirement' field.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230411073357.30021-1-sarg@sarg.org.ru
* gnu/services/networking.scm (<dhcp-client-configuration>)
[shepherd-requirement]: New field.
(dhcp-client-shepherd-service): Honor it.
(dhcp-client-configuration-shepherd-requirement): Export accessor.
* doc/guix.texi (Networking Setup): Document it.
---
doc/guix.texi | 8 +++++++-
gnu/services/networking.scm | 6 +++++-
2 files changed, 12 insertions(+), 2 deletions(-)

Toggle diff (63 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index ac60acf98c..25f06fd0a8 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19892,6 +19892,12 @@ should listen on---e.g., @code{'("eno1")}.
When set to @code{'all}, the DHCP client listens on all the available
non-loopback interfaces that can be activated. Otherwise the DHCP
client listens only on the specified interfaces.
+
+@item @code{shepherd-requirement} (default: @code{'()})
+This option can be used to provide a list of symbols naming Shepherd services
+that this service will depend on, such as @code{'wpa-supplicant} or
+@code{'iwd} if you require authenticated access for encrypted WiFi or Ethernet
+networks.
@end table
@end deftp
@@ -19995,7 +20001,7 @@ Data Type representing the configuration of connman.
@item @code{connman} (default: @var{connman})
The connman package to use.
-@item @code{shepherd-requirement} (default: @code{()})
+@item @code{shepherd-requirement} (default: @code{'()})
This option can be used to provide a list of symbols naming Shepherd services
that this service will depend on, such as @code{'wpa-supplicant} or
@code{'iwd} if you require authenticated access for encrypted WiFi or Ethernet
diff --git a/gnu/services/networking.scm b/gnu/services/networking.scm
index 19c109d238..1b2e6a8c53 100644
--- a/gnu/services/networking.scm
+++ b/gnu/services/networking.scm
@@ -89,6 +89,7 @@ (define-module (gnu services networking)
dhcp-client-configuration?
dhcp-client-configuration-package
dhcp-client-configuration-interfaces
+ dhcp-client-configuration-shepherd-requirement
dhcpd-service-type
dhcpd-configuration
@@ -279,6 +280,8 @@ (define-record-type* <dhcp-client-configuration>
dhcp-client-configuration?
(package dhcp-client-configuration-package ;file-like
(default isc-dhcp))
+ (shepherd-requirement dhcp-client-configuration-shepherd-requirement
+ (default '()))
(interfaces dhcp-client-configuration-interfaces
(default 'all))) ;'all | list of strings
@@ -286,11 +289,12 @@ (define dhcp-client-shepherd-service
(match-lambda
((? dhcp-client-configuration? config)
(let ((package (dhcp-client-configuration-package config))
+ (shepherd-requirement (dhcp-client-configuration-shepherd-requirement config))
(interfaces (dhcp-client-configuration-interfaces config))
(pid-file "/var/run/dhclient.pid"))
(list (shepherd-service
(documentation "Set up networking via DHCP.")
- (requirement '(user-processes udev))
+ (requirement `(user-processes udev ,@shepherd-requirement))
;; XXX: Running with '-nw' ("no wait") avoids blocking for a minute when
;; networking is unavailable, but also means that the interface is not up
--
2.39.2
Ludovic Courtès wrote 2 years ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62770-done@debbugs.gnu.org)
87ilcz3v1c.fsf@gnu.org
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (6 lines)
> * gnu/services/networking.scm (<dhcp-client-configuration>)
> [shepherd-requirement]: New field.
> (dhcp-client-shepherd-service): Honor it.
> (dhcp-client-configuration-shepherd-requirement): Export accessor.
> * doc/guix.texi (Networking Setup): Document it.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62770@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62770
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help