[PATCH] gnu: minetest: Update to 5.7.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Parnikkapore
Owner
unassigned
Submitted by
Parnikkapore
Severity
normal

Debbugs page

Parnikkapore wrote 2 years ago
(address . guix-patches@gnu.org)
f37774eae9cc57e5a7b9a916aa5a524bcf1ef478.1681044825.git.poomklao@yahoo.com
* gnu/packages/minetest.scm (minetest): Update to 5.7.0.
* gnu/packages/minetest.scm (minetest): Move check phase to after
install, as the tests refer to data files in the installation.
* gnu/packages/minetest.scm (minetest-data): Update to 5.7.0.
* gnu/packages/games.scm (irrlicht-for-minetest): Update to 1.9.0mt10.
---
gnu/packages/games.scm | 4 ++--
gnu/packages/minetest.scm | 9 +++++----
2 files changed, 7 insertions(+), 6 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 77c4a12a6e..08d17edfb0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3637,7 +3637,7 @@ (define-public irrlicht-for-minetest
(package
(inherit irrlicht)
(name "irrlicht-for-minetest")
- (version "1.9.0mt8")
+ (version "1.9.0mt10")
(source
(origin
(method git-fetch)
@@ -3647,7 +3647,7 @@ (define-public irrlicht-for-minetest
(file-name (git-file-name name version))
(sha256
(base32
- "1646pj40dqkzbbc2lxzbmq2pjyrkgggbi2lah6pa5mv420p402kg"))))
+ "0y5vchz91khs8dmrkpgc7sqmvzx2yjj6svivvm80r4yppv7s03rw"))))
(build-system cmake-build-system)
(arguments
;; No check target.
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 4c14d9412c..bf0df314a7 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -52,7 +52,7 @@ (define-module (gnu packages minetest)
(define-public minetest
(package
(name "minetest")
- (version "5.6.1")
+ (version "5.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -61,7 +61,7 @@ (define-public minetest
(file-name (git-file-name name version))
(sha256
(base32
- "1bgk369n7r52vh3hdngrlf98k3v84ch2qp341xhs53ixrns2crfn"))
+ "008l44zwwsarwk4hn7wx2nj2m21b1iqsphl7g69rrlxj760zl0pl"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -106,7 +106,8 @@ (define-public minetest
"(void)0;"))
(setenv "MINETEST_SUBGAME_PATH" ; for check
(string-append (getcwd) "/games"))))
- (replace 'check
+ (delete 'check)
+ (add-after 'install 'check
(lambda* (#:key tests? #:allow-other-keys)
;; Thanks to our substitutions, the tests should also run
;; when invoked on the target outside of `guix build'.
@@ -165,7 +166,7 @@ (define minetest-data
(file-name (git-file-name name version))
(sha256
(base32
- "1w0vdk6a1rhsfwyfviayfwsyqbzwikqazkgbrfl39anf3a50rvv1"))))
+ "02kbj1h6jsq6k8x4v2ir0njczdz7nyx6dbym85ixxp3mrqxiws61"))))
(build-system copy-build-system)
(arguments
(list #:install-plan

base-commit: 02033bfc05a1e82b12e80c6d000e1724e910e899
--
2.39.2
Christopher Baines wrote 2 years ago
(name . Parnikkapore)(address . poomklao@yahoo.com)
87wn2fwumi.fsf@cbaines.net
Parnikkapore via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (10 lines)
> * gnu/packages/minetest.scm (minetest): Update to 5.7.0.
> * gnu/packages/minetest.scm (minetest): Move check phase to after
> install, as the tests refer to data files in the installation.
> * gnu/packages/minetest.scm (minetest-data): Update to 5.7.0.
> * gnu/packages/games.scm (irrlicht-for-minetest): Update to 1.9.0mt10.
> ---
> gnu/packages/games.scm | 4 ++--
> gnu/packages/minetest.scm | 9 +++++----
> 2 files changed, 7 insertions(+), 6 deletions(-)

Thanks for the patch, I've tweaked the commit message a bit to remove
some repetition and make some bits more specific. I've pushed the
amended patch to master as 972d66b66d80a16d1427eb4c33a1b31d8369d949.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQ4PfVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeNsA/7BVn708hY0IFOIECwZXRPkygz3eRrHvtp
Y+ZY67/Se+9Bs9ABa7rDwbNJtM9GfbueyciF01TAwW2w8w6b01GGnkJFojR0pjHA
V2w8cP5IJalLd9G0jvSDWkrH1p3+blshgeUtktq0IvHK/K+nDQDriIf7lIg0T6/y
G2RmOllckajIthJQz5ovR3pR3Jf8l1FgNzjBbvE21CtJObBejjxmZh0uiO7H0h3i
TZ7AYT6zhBPNrp9uD1Y/0j9pucHNjnOyu6JNMRt7CzR8Y96wOgyMFDrDBfM5pW18
Y49CBZJbHDDFABUHd/VicBLO8Bt3IPQzfafLbv/3BoPhR84vputqeX3b9wa2v0IE
zQ90e9/ld49gIt0/y4uPwXwGJhbXkSV06VF/aU81K/nbrzZIE0E9anF8ULGBgjVs
NFS33eTRFx8obWDp5NDAan6CIWrzcMYKRJvBLgX0wPwYi9PkBvTvn0YAGbB3OKxW
n8CeoXZuM8x+nVek1sjI3o92hv9nJowI8noqOcoNB5Wm/OHvKMrAS8VmzmjKNrrO
M5qx5xlgoTTTbHaaS8VSnAMctxZ5dCG77QIsJchQA8lp1s6jf56iU+5VXOoIM0Fj
tS6fOcTxaQlOpSg0KxREquDxlUfdwecUnR2NuPFTzLD1z4l5955NbCX0E5FHK+dI
BEUoi/nLyTE=
=js+f
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62740@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62740
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help