[PATCH] gnu: Add r-littler

  • Done
  • quality assurance status badge
Details
3 participants
  • kyle
  • (
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal

Debbugs page

kyle wrote 2 years ago
(address . guix-patches@gnu.org)
9aa99d67ff185fdd557401c8cf6f3c90638a37c3.1681010036.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/statistics.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 628057a189..e61d06721e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1010,6 +1010,42 @@ (define-public r-labeling
algorithms.")
(license license:expat)))
+(define-public r-littler
+ (package
+ (name "r-littler")
+ (version "0.3.18")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "littler" version))
+ (sha256
+ (base32
+ "1lp6a62g3yhzr4pv9kynibv7k9pd546w6hifs1aficyxbyg4dgqq"))))
+ (properties `((upstream-name . "littler")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'add-to-path
+ (lambda _
+ (mkdir (string-append #$output "/bin"))
+ (copy-file "inst/bin/r"
+ (string-append #$output "/bin/r")))))))
+ (inputs (list icu4c))
+ (native-inputs
+ (list r-simplermarkdown automake autoconf zlib))
+ (home-page "https://github.com/eddelbuettel/littler")
+ (synopsis "R at the Command-Line via 'r'")
+ (description
+ "This package provides a scripting and command-line front-end is provided by r
+(aka littler') as a lightweight binary wrapper around the GNU R language and
+environment for statistical computing and graphics. While R can be used in
+batch mode, the r binary adds full support for both shebang'-style scripting
+(i.e. using a hash-mark-exclamation-path expression as the first line in
+scripts) as well as command-line use in standard Unix pipelines. In other
+words, r provides the R language without the environment.")
+ (license license:gpl2+)))
+
(define-public r-magrittr
(package
(name "r-magrittr")
--
2.39.2
kyle wrote 2 years ago
(address . 62733@debbugs.gnu.org)
a5b7a62aee4cf2ad68664c35b80b30ec6bcfdbf4.1681047393.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/statistics.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 628057a189..d057f52f08 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1010,6 +1010,42 @@ (define-public r-labeling
algorithms.")
(license license:expat)))
+(define-public r-littler
+ (package
+ (name "r-littler")
+ (version "0.3.18")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "littler" version))
+ (sha256
+ (base32
+ "1lp6a62g3yhzr4pv9kynibv7k9pd546w6hifs1aficyxbyg4dgqq"))))
+ (properties `((upstream-name . "littler")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'add-to-path
+ (lambda _
+ (install-file
+ "inst/bin/r"
+ (string-append #$output "/bin")))))))
+ (inputs (list icu4c))
+ (native-inputs
+ (list r-simplermarkdown automake autoconf zlib pkg-config))
+ (home-page "https://github.com/eddelbuettel/littler")
+ (synopsis "R at the Command-Line via 'r'")
+ (description
+ "This package provides a scripting and command-line front-end is provided by r
+(aka littler') as a lightweight binary wrapper around the GNU R language and
+environment for statistical computing and graphics. While R can be used in
+batch mode, the r binary adds full support for both shebang'-style scripting
+(i.e. using a hash-mark-exclamation-path expression as the first line in
+scripts) as well as command-line use in standard Unix pipelines. In other
+words, r provides the R language without the environment.")
+ (license license:gpl2+)))
+
(define-public r-magrittr
(package
(name "r-magrittr")
--
2.39.2
( wrote 2 years ago
(address . rekado@elephly.net)
CRS9VLHCNWU8.1LBO2GNNF34NC@guix-framework
On Sun Apr 9, 2023 at 2:36 PM BST, kyle wrote:
Toggle quote (3 lines)
> + (native-inputs
> + (list r-simplermarkdown automake autoconf zlib pkg-config))

zlib should be a regular input

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmQyws0ACgkQ7ImHg/nq
I227DQv/dBpgSLobkbv+hI29lWJ+9ib1ESklILqau+Y3PMD4kOWk3luA7df+RWEM
3bgaSnUx3zuaV/4ZG5ZnJDq3T+YOIapoGXPSqAfEXVWVl+kmPNoprPXERASYkeHQ
7N9dpkcPC/m/kkz7nnJ2v4r/UNe9C696B0nuKpDMhrklQew5m29eDbQNflTTuXGM
3fMZMs8JG0LOi1670pRfUYE7tLfnWwqpU9YHQYa7N/N5uZHbqZHZ9v+Y5MxibeCb
M++qDtxXT0bL10D6kRf1kRJPr5Jdpj09zPZ8bvGHgqIKsNOjOI7YSg2mYqlY+Enq
1pRLMg2OryJxuNjt3+mYQlX4aTJLgpX7u0gfl/lkKDrT0s208ZFM55WrNg/W0Z45
kw5zTbMub+zUbS3a9TNlRE/a8qWK7ai50GKPboW0Tqeo/Q2pynhQ3eOKw34sVPd7
ayY8qzhEAbkEFurhhwdu5m5LumrgqfWwSpuBrxkZ4TIfA8SlOIugDZuYJOMcIKab
XWEFaWEb
=C8V8
-----END PGP SIGNATURE-----


kyle wrote 2 years ago
[PATCH v3] gnu: Add r-littler
(address . 62733@debbugs.gnu.org)
211e245d7f8e899145bcf2325b23b6a4cf1fa9c6.1681488328.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/statistics.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 628057a189..b960ed5631 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1010,6 +1010,42 @@ (define-public r-labeling
algorithms.")
(license license:expat)))
+(define-public r-littler
+ (package
+ (name "r-littler")
+ (version "0.3.18")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "littler" version))
+ (sha256
+ (base32
+ "1lp6a62g3yhzr4pv9kynibv7k9pd546w6hifs1aficyxbyg4dgqq"))))
+ (properties `((upstream-name . "littler")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'add-to-path
+ (lambda _
+ (install-file
+ "inst/bin/r"
+ (string-append #$output "/bin")))))))
+ (inputs (list icu4c zlib))
+ (native-inputs
+ (list r-simplermarkdown automake autoconf pkg-config))
+ (home-page "https://github.com/eddelbuettel/littler")
+ (synopsis "R at the Command-Line via 'r'")
+ (description
+ "This package provides a scripting and command-line front-end is provided by r
+(aka littler') as a lightweight binary wrapper around the GNU R language and
+environment for statistical computing and graphics. While R can be used in
+batch mode, the r binary adds full support for both shebang'-style scripting
+(i.e. using a hash-mark-exclamation-path expression as the first line in
+scripts) as well as command-line use in standard Unix pipelines. In other
+words, r provides the R language without the environment.")
+ (license license:gpl2+)))
+
(define-public r-magrittr
(package
(name "r-magrittr")
--
2.39.2
Ricardo Wurmus wrote 2 years ago
(name . kyle)(address . kyle@posteo.net)(address . 62733-done@debbugs.gnu.org)
875y9usvbc.fsf@elephly.net
Thanks, I applied it with a few changes with commit
a117510a8c9246f8e09577780ccaf3955f98d7ad.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62733@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62733
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help