[PATCH] gnu: Add libxisf.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 8 Apr 2023 22:54
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230408205418.9146-1-sharlatanus@gmail.com
* gnu/packages/astronomy.scm (libxisf): New variable.
---
gnu/packages/astronomy.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3af948efe4..17b3c4aeba 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2057,6 +2057,35 @@ (define-public libpasastro
@end itemize\n")
(license license:gpl2+))))
+(define-public libxisf
+ (package
+ (name "libxisf")
+ ;; TODO: v0.2.2 (current latest) failed to build on configure phase, issue
+ ;; was open directly with author as he hosts source on seflhosted gitea.
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.nouspiro.space/nou/libXISF")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fz9mmj1nz5v7hlr53q8na7khadfn1hm0d1gfpzzw3167bqpy2xv"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DUSE_BUNDLED_LIBS=OFF")))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list lz4 pugixml zlib))
+ (home-page "https://nouspiro.space/?page_id=306")
+ (synopsis "Astronomical library to load and write XISF file format")
+ (description "LibXISF is C++ library that can read and write XISF files produced by
+PixInsight. It implement XISF 1.0 specification.")
+ (license license:gpl3+)))
+
(define-public missfits
(package
(name "missfits")
--
2.39.2
N
N
Nicolas Goaziou wrote on 9 Apr 2023 21:30
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62730-done@debbugs.gnu.org)
877cukkg49.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (libxisf): New variable.

I fixed the typo in th description and applied your patch. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?