[PATCH] gnu: openmw-openscenegraph: Update to Nov 2022 commit

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 8 Apr 2023 21:22
[PATCH 0/2] Update and fix the build of openmw-openscenegraph.
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
cover.1680980546.git.kaelyn.alexi@protonmail.com
Hi,

I decided to try out OpenMW after recently learning how far along the project
is. To my joy, the latest version was already packaged. To my dismay the
version of openscenegraph it depended on no longer built (I believe commit
98b9f3a4bdwhich added a separate output for plugins was what broke the child
package, as the error was with the mkdir in the new phase).

I have fixed the build by removing the new output and phase from
openmw-openscenegraph. I have also updated the package to the latest commit
from https://github.com/OpenMW/osg.Two points to note about the changes:

1) Simply updating the package to the (much) newer commit fixes the build in
the presence of the separate plugin output, but I kept the plugins in the
main output since they are needed by OpenMW and I worry that the separate
output will cause problems with OpenMW being able to find them.

2) The existing openmw-openscenegraph package appears to be at a commit from
2018 that does not seem to be a commit in https://github.com/OpenMW/osg.
has a banner saying the commit does not belong to any branch and may belong
to a fork outside of the repository. In a local checkout of the repository,
`git log 36a962845a2c87a6671fd822157e0729d164e940` says the hash is not a
valid object.

Also, feel free to adjust the commit messages as necessary. I wasn't certain
on the appropriate format or wording for either of the commits' messages.

Cheers,
Kaelyn



Kaelyn Takata (2):
gnu: openmw-openscenegraph: Fix build.
gnu: openmw-openscenegraph: Update to Nov 2022 commit.

gnu/packages/graphics.scm | 18 +++++++++++-------
1 file changed, 11 insertions(+), 7 deletions(-)


base-commit: b08cdfc6d363e9ca63118303b4628542c54a612d
--
2.39.2
K
K
Kaelyn Takata wrote on 8 Apr 2023 21:27
[PATCH 2/2] gnu: openmw-openscenegraph: Update to Nov 2022 commit.
(address . 62728@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
35d0c28292785c8b00b56fe04fb10400b4accbb5.1680980546.git.kaelyn.alexi@protonmail.com
* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit.
[arguments]: Sync the plugin flags with the mentioned wiki page.
---
gnu/packages/graphics.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 09c7c4b6d2..dff1ec86c9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1474,11 +1474,11 @@ (define-public gr-framework
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph:
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
- (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+ (let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
(hidden-package
(package
(inherit openscenegraph)
- (version (git-version "3.6" "1" commit))
+ (version (git-version "3.6" "2" commit))
(source
(origin
(method git-fetch)
@@ -1488,7 +1488,7 @@ (define-public openmw-openscenegraph
(file-name (git-file-name (package-name openscenegraph) version))
(sha256
(base32
- "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ "1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
(outputs (list "out"))
(arguments
(substitute-keyword-arguments (package-arguments openscenegraph)
@@ -1497,14 +1497,14 @@ (define-public openmw-openscenegraph
#~(append
'("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
"-DBUILD_OSG_PLUGIN_OSG=1"
+ "-DBUILD_OSG_PLUGIN_DAE=1"
"-DBUILD_OSG_PLUGIN_DDS=1"
"-DBUILD_OSG_PLUGIN_TGA=1"
"-DBUILD_OSG_PLUGIN_BMP=1"
"-DBUILD_OSG_PLUGIN_JPEG=1"
"-DBUILD_OSG_PLUGIN_PNG=1"
- "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
- ;; The jpeg plugin requires conversion between integers and booleans
- "-DCMAKE_CXX_FLAGS=-fpermissive")
+ "-DBUILD_OSG_PLUGIN_FREETYPE=1"
+ "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0")
#$flags))
((#:phases _)
#~%standard-phases)))))))
--
2.39.2
K
K
Kaelyn Takata wrote on 8 Apr 2023 21:27
[PATCH 1/2] gnu: openmw-openscenegraph: Fix build.
(address . 62728@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
ea1e4bb1b159bd837ae0fd9c5dc93fd399278a72.1680980546.git.kaelyn.alexi@protonmail.com
* gnu/packages/graphics.scm (openmw-openscenegraph): Fix build.
---
gnu/packages/graphics.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bcc27cc3bf..09c7c4b6d2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1488,6 +1489,7 @@ (define-public openmw-openscenegraph
(sha256
(base32
"05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ (outputs (list "out"))
(arguments
(substitute-keyword-arguments (package-arguments openscenegraph)
((#:configure-flags flags)
@@ -1503,7 +1505,9 @@ (define-public openmw-openscenegraph
"-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
;; The jpeg plugin requires conversion between integers and booleans
"-DCMAKE_CXX_FLAGS=-fpermissive")
- #$flags))))))))
+ #$flags))
+ ((#:phases _)
+ #~%standard-phases)))))))

(define-public povray
(package
--
2.39.2
K
K
Kaelyn Takata wrote on 27 Apr 2023 17:54
[PATCH v2] gnu: openmw-openscenegraph: Update to Nov 2022 commit.
(address . 62728@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
d0f705e9297c6a089bec7d30c556ba5ba1e7bdbf.1682610856.git.kaelyn.alexi@protonmail.com
* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit.
[arguments]: Sync the plugin flags with the mentioned wiki page.
---
gnu/packages/graphics.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 261fcf9547..a7b1024185 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1448,11 +1448,11 @@ (define-public gr-framework
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph:
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
- (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+ (let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
(hidden-package
(package
(inherit openscenegraph)
- (version (git-version "3.6" "1" commit))
+ (version (git-version "3.6" "2" commit))
(outputs (list "out"))
(source
(origin
@@ -1463,7 +1463,7 @@ (define-public openmw-openscenegraph
(file-name (git-file-name (package-name openscenegraph) version))
(sha256
(base32
- "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ "1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
(arguments
(substitute-keyword-arguments (package-arguments openscenegraph)
((#:configure-flags flags)
@@ -1471,14 +1471,14 @@ (define-public openmw-openscenegraph
#~(append
'("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
"-DBUILD_OSG_PLUGIN_OSG=1"
+ "-DBUILD_OSG_PLUGIN_DAE=1"
"-DBUILD_OSG_PLUGIN_DDS=1"
"-DBUILD_OSG_PLUGIN_TGA=1"
"-DBUILD_OSG_PLUGIN_BMP=1"
"-DBUILD_OSG_PLUGIN_JPEG=1"
"-DBUILD_OSG_PLUGIN_PNG=1"
- "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
- ;; The jpeg plugin requires conversion between integers and booleans
- "-DCMAKE_CXX_FLAGS=-fpermissive")
+ "-DBUILD_OSG_PLUGIN_FREETYPE=1"
+ "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0")
#$flags))
((#:phases phases)
#~(modify-phases #$phases
@@ -2589,4 +2589,3 @@ (define-public gpaint
It features cut-and-paste for irregular regions or polygons.")
(home-page "https://www.gnu.org/software/gpaint/")
(license license:gpl3+)))
-

base-commit: 297805b1f83aa58ba9fc775c203373338aafd5ac
--
2.39.2
K
K
Kaelyn wrote on 27 Apr 2023 18:00
(name . 62728@debbugs.gnu.org)(address . 62728@debbugs.gnu.org)
WLkb2ft4Oa6Cwp7SLu-UAM02ELJcD0Jtfo72YYEdZPWxtmZLXZge55hQaOBcF7vh7YzWziDHGHor4zOFBgdXBaq7JKmisk8EY9hzbBBw8zg=@protonmail.com
I've rebased the patch against current master, and dropped the build fix since Efraim independently applied the same fix on April 18th.

I feel the package update is still worthwhile since the current commit is extremely old and, according to GitHub, is not a commit in the repo at https://github.com/OpenMW/osg/(GitHub suggests it may be from a fork of the repo).

Cheers,
Kaelyn
K
K
Kaelyn wrote on 27 Apr 2023 18:02
(No Subject)
(name . 62728@debbugs.gnu.org)(address . 62728@debbugs.gnu.org)
AB049zLVsdirZ063xxwTBNPYUs28un0EpV4Pz4BA8vgpeT-ZuBs3mBirb_i3nbEnUJuw8xMKGBv9vTMwsrJ37UxpBzDXZxk0bYwwYX6RRYY=@protonmail.com
retitle 62728 [PATCH] gnu: openmw-openscenegraph: Update to Nov 2022 commit.
K
K
Kaelyn wrote on 18 Jun 2023 18:16
(address . control@debbugs.gnu.org)
yZxwfHYFDUqaiqG58qQJU6eCZ7LLdEOBkLpDaaP4_UDgONaJnVXFh6GGUd7HfN391-KwsE-ygDsw6-Tq_1oUqcnXULkKYiYLUQZqA1Bki2U=@protonmail.com
retitle 62728 [PATCH] gnu: openmw-openscenegraph: Update to Nov 2022 commit
L
L
Ludovic Courtès wrote on 18 Jun 2023 23:28
Re: bug#62728: [PATCH 0/2] Update and fix the build of openmw-openscenegraph.
(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)(address . 62728-done@debbugs.gnu.org)
87pm5so3yv.fsf_-_@gnu.org
Hi,

Kaelyn Takata <kaelyn.alexi@protonmail.com> skribis:

Toggle quote (3 lines)
> * gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit.
> [arguments]: Sync the plugin flags with the mentioned wiki page.

Finally applied, thanks!

Ludo’.
Closed
?