[PATCH 0/2] Disable keyword expansion for Subversion downloads

  • Done
  • quality assurance status badge
Details
5 participants
  • Ludovic Courtès
  • Christopher Baines
  • Nicolas Goaziou
  • Timothy Sample
  • Simon Tournier
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
Blocked by
L
L
Ludovic Courtès wrote on 7 Apr 2023 16:05
(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
20230407140551.8776-1-ludo@gnu.org
Hello Guix!

As discussed in https://issues.guix.gnu.org/43442, SVN keyword
expansion during checkout is problematic because it depends on local
timezone. This in itself isn't really a problem in Guix because
the timezone in the environment of fixed-output derivations is
always UTC. However, SWH disables keyword expansion (for this
reason), and thus it makes sense to follow suit.

Disabling keyword expansion entails many rebuilds. However, these
are "safe", so I'd like to have them on a branch (or simply handled
by qa.guix) that we'd merge as soon as it's built.

The second patch makes ‘recursive?’ default to #f, which AFAICS
is what all the SVN-using packages that were not explicit expected
(no changes required).

Thoughts?

Ludo’.

Ludovic Courtès (2):
svn-download: Disable keyword expansion.
svn-download: Default to non-recursive checkouts.

gnu/packages/java.scm | 2 +-
gnu/packages/machine-learning.scm | 2 +-
gnu/packages/tex.scm | 16 ++++++++--------
gnu/packages/video.scm | 4 ++--
guix/build/svn.scm | 9 ++++++++-
guix/svn-download.scm | 6 +++---
6 files changed, 23 insertions(+), 16 deletions(-)


base-commit: 47fe66586e0fbc177288ec91cc88ea0b081505b0
--
2.39.2
L
L
Ludovic Courtès wrote on 7 Apr 2023 16:07
[PATCH 2/2] svn-download: Default to non-recursive checkouts.
(address . 62712@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
20230407140724.8815-2-ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

As it turns out, all packages that fetch code from Subversion expect it
to be non-recursive by default. Clarify that.

Reported by Timothy Sample <samplet@ngyro.com>.

* guix/svn-download.scm (<svn-reference>)[recursive?]: Default to #f.
(<svn-multi-reference>)[recursive?]: Likewise.
---
guix/svn-download.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/guix/svn-download.scm b/guix/svn-download.scm
index e0a26b73ee..769571b5f6 100644
--- a/guix/svn-download.scm
+++ b/guix/svn-download.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014-2016, 2019, 2021-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014-2016, 2019, 2021-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
;;;
@@ -63,7 +63,7 @@ (define-record-type* <svn-reference>
svn-reference?
(url svn-reference-url) ; string
(revision svn-reference-revision) ; number
- (recursive? svn-reference-recursive? (default #t))
+ (recursive? svn-reference-recursive? (default #f))
(user-name svn-reference-user-name (default #f))
(password svn-reference-password (default #f)))
@@ -132,7 +132,7 @@ (define-record-type* <svn-multi-reference>
(url svn-multi-reference-url) ; string
(revision svn-multi-reference-revision) ; number
(locations svn-multi-reference-locations) ; list of strings
- (recursive? svn-multi-reference-recursive? (default #t))
+ (recursive? svn-multi-reference-recursive? (default #f))
(user-name svn-multi-reference-user-name (default #f))
(password svn-multi-reference-password (default #f)))
--
2.39.2
L
L
Ludovic Courtès wrote on 7 Apr 2023 16:07
[PATCH 1/2] svn-download: Disable keyword expansion.
(address . 62712@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
20230407140724.8815-1-ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

Subversion keyword expansion is potentially non-reproducible as some of
them expand time strings relative to the local time zone:


In practice this is not a problem in Guix since Subversion checkouts
happen in an isolated environment using the "default timezone" (UTC).

However, Software Heritage disables keyword expansion for this very
reason. By following suit, we make sure content can be retrieved from
there.

Reported by Timothy Sample <samplet@ngyro.com>.

* guix/build/svn.scm (svn-fetch): Pass '--ignore-keywords'.
* gnu/packages/java.scm (java-geronimo-xbean-reflect):
* gnu/packages/machine-learning.scm (ghmm): Adjust source hash
accordingly.
* gnu/packages/tex.scm (texlive-hyphen-base): Likewise.
(texlive-dvips): Likewise.
(texlive-cm): Likewise.
(texlive-tex-plain): Likewise.
(texlive-kpathsea): Likewise
(texlive-latexconfig): Likewise.
(texlive-tetex): Likewise.
(texlive-pdftex): Likewise.
* gnu/packages/video.scm (libsmpeg): Likewise.
(libsmpeg-with-sdl1): Likewise.
---
gnu/packages/java.scm | 2 +-
gnu/packages/machine-learning.scm | 2 +-
gnu/packages/tex.scm | 16 ++++++++--------
gnu/packages/video.scm | 4 ++--
guix/build/svn.scm | 9 ++++++++-
5 files changed, 20 insertions(+), 13 deletions(-)

Toggle diff (151 lines)
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index de3a0003e5..1405d0d69a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -11216,7 +11216,7 @@ (define-public java-geronimo-xbean-reflect
(file-name (string-append name "-" version))
(sha256
(base32
- "18q3i6jgm6rkw8aysfgihgywrdc5nvijrwnslmi3ww497jvri6ja"))))
+ "0zjqmsad4xk0iar23hdyvx19nxczybd2bh0i35xrafli5cmh720k"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "geronimo-xbean-reflect.jar"
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 37d4ef78ad..503b41d64c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -233,7 +233,7 @@ (define-public ghmm
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0qbq1rqp94l530f043qzp8aw5lj7dng9wq0miffd7spd1ff638wq"))))
+ "07kdsngvr4n1qxpqzv1nlay7g41d6jzjppa8vzmrg220s8ing87z"))))
(build-system gnu-build-system)
(arguments
`(#:imported-modules (,@%gnu-build-system-modules
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b40e72c582..056741b052 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -731,7 +731,7 @@ (define-public texlive-hyphen-base
"/tex/generic/hyphen/hypht1.tex"
"/tex/generic/hyphen/zerohyph.tex")
(base32
- "1sagn9aybs34m1s6m3zwya5g5kbiwfnw8ifcgxssygmzzs88dgjp")
+ "1nad1bqpjsywm49hlv7d75mqvgha3j5vayvkvfhv8wwzgdb3mk84")
#:trivial? #t))
(home-page "https://tug.org/texlive/")
(synopsis "Core hyphenation support files")
@@ -783,7 +783,7 @@ (define-public texlive-dvips
"/fonts/enc/dvips/base/"
"/tex/generic/dvips/")
(base32
- "0rns1hpjy4fmsskmkwx197j8qbgdmyj0j9214sq9vhpa6nv7czm3")
+ "1fb73mfw9mp4ylp6sfc0465rbdb7k830aq0qf3c085c3n0zyrin8")
#:trivial? #t))
(home-page "https://www.ctan.org/pkg/dvips")
(synopsis "DVI to PostScript drivers")
@@ -1041,7 +1041,7 @@ (define-public texlive-cm
"/fonts/map/dvips/cm/cmtext-bsr-interpolated.map"
"/doc/fonts/cm/")
(base32
- "1ky4gvcn8qn3d61bvb39512b8r92igv6il7vh02hw04223yj6q8i")
+ "0mfslqs9saqkb3z3xdhsqnklxk858nmipgj1y93by2791jzkma1d")
#:trivial? #t)))
(package
(inherit template)
@@ -1645,7 +1645,7 @@ (define-public texlive-tex-plain
"texlive-tex-plain"
(list "/tex/plain/")
(base32
- "0gwygkm8i2jmpf7bfg6fb6824rl7fq4a2s0wni73v0fz6s4chr1n")
+ "1hafbphx1486069cky87hyksx6ia5gd83m4wp2xmgc09z87faf0h")
#:trivial? #t))
(home-page "https://www.ctan.org/pkg/plain")
(synopsis "Plain TeX format and supporting files")
@@ -2851,7 +2851,7 @@ (define-public texlive-kpathsea
"/web2c/tcvn-t5.tcx"
"/web2c/viscii-t5.tcx")
(base32
- "00q2nny7lw7jxyln6ch4h0alygbrzk8yynliyc291m53kds1h0mr")
+ "08nfk5hicqbvnz73rjbxi97lcakd9i1k2cy4qi2cwghan92650jq")
#:trivial? #t)))
(package
(inherit template)
@@ -2914,7 +2914,7 @@ (define-public texlive-latexconfig
"texlive-latexconfig"
(list "/tex/latex/latexconfig/")
(base32
- "10ynmd8b9b9l1wl1mva23yz4zir53p6r5z31s39wmxz19pj12qvx")
+ "1x5fyr2185nx3qlyariykdz44hcy5azimrk9db2p707dg08bjhsd")
#:trivial? #t))
(home-page "https://www.tug.org/")
(synopsis "Configuration files for LaTeX-related formats")
@@ -3748,7 +3748,7 @@ (define-public texlive-tetex
"/fonts/enc/dvips/tetex/"
"/fonts/map/dvips/tetex/")
(base32
- "1si3as8mwi8837965djlw6jhwwzsp3r1hkflvdxv2avx9vb45hjb")
+ "05mf8yqdj2wrc1zm3al2j4aam2wx0ky6a7slxw17pkd1c7rmvjrq")
#:trivial? #t))
(home-page "https://www.ctan.org/pkg/tetex")
(synopsis "Font maps originally from teTeX")
@@ -8195,7 +8195,7 @@ (define-public texlive-pdftex
"/tex/generic/pdftex/glyphtounicode.tex"
"/tex/generic/pdftex/pdfcolor.tex")
(base32
- "1wx928rqsv0x1a8vc7aq49w3nglr4bmlhl822slqglymfxrmb91b")
+ "0w4ar5g7x4w8zw8z6hdwqxwcbglfzzq7pcznz8rawllwy6dssr8g")
#:trivial? #t))
;; TODO: add this missing package:
;; dehyph
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 47b5fd1593..359880df53 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3795,7 +3795,7 @@ (define-public libsmpeg
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "18yfkr70lr1x1hc8snn2ldnbzdcc7b64xmkqrfk8w59gpg7sl1xn"))))
+ "1srzyjks9s0g4k7ms8vc0hjby2g6shndnr552hl63pn90sgmwxs9"))))
(build-system gnu-build-system)
(arguments
;; libsmpeg fails to build with -std=c++11, which is the default with
@@ -3831,7 +3831,7 @@ (define-public libsmpeg-with-sdl1
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0jfi085rf3fa5xsn0vd3nqf32my8ph9c6a9445y7a8lrlz4dms64"))))
+ "1jy9xqykhwfg8in0fxjcqcvwazii1ckzs39wp749b926q7ny5bwy"))))
(inputs
(list sdl))))
diff --git a/guix/build/svn.scm b/guix/build/svn.scm
index 2d960cb364..875d3c50ca 100644
--- a/guix/build/svn.scm
+++ b/guix/build/svn.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2020, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
@@ -47,6 +47,13 @@ (define* (svn-fetch url revision directory
;; verify the checksum later. This can be removed when
;; ca-certificates package is added.
"--trust-server-cert" "-r" (number->string revision)
+
+ ;; Disable keyword substitutions (keywords are CVS-like strings
+ ;; like "$Date$", "$Id$", and so on) for two reasons: (1) some
+ ;; expansions depend on the local time zone, and (2) SWH disables
+ ;; it in its archive for this very reason.
+ "--ignore-keywords"
+
`(,@(if (and user-name password)
(list (string-append "--username=" user-name)
(string-append "--password=" password))
--
2.39.2
T
T
Timothy Sample wrote on 7 Apr 2023 18:54
Re: bug#62712: [PATCH 0/2] Disable keyword expansion for Subversion downloads
(name . Ludovic Courtès)(address . ludo@gnu.org)
87jzyny6oi.fsf_-_@ngyro.com
Hi Ludo,

Whoops! I guess I was a little slow getting my patch in. I’ve
highlighted a few sources you missed below, as well as attached my patch
(for comparison and for listing the new hashes of the missing sources).

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/java.scm (java-geronimo-xbean-reflect):

Also java-geronimo-genesis-2.1.

Toggle quote (3 lines)
> * gnu/packages/tex.scm (texlive-hyphen-base): Likewise.
> (texlive-dvips): Likewise.

Also texlive-dvipdfmx.

Toggle quote (7 lines)
> (texlive-cm): Likewise.
> (texlive-tex-plain): Likewise.
> (texlive-kpathsea): Likewise
> (texlive-latexconfig): Likewise.
> (texlive-tetex): Likewise.
> (texlive-pdftex): Likewise.

Also texlive-xetex.

There’s also the “texlive-scripts” input in texlive-bin, and the
“texlive-luatexconfig” native input in texlive-latex-base.

Toggle quote (2 lines)
> [...]

I generated a big diff for all 17 sources that I found (mostly because
it excites me that Guix can do stuff like that). Basically all the
changes were boring (as we expected).

For “texlive-scripts”, I added a phase that approximates keyword
expansion for the few scripts that use it to output version information.
It‘s not exactly the same as what Subversion does. Subversion uses the
last revision that updated the given file, and I just use
‘%texlive-revision’ for every file. I’m not too attached to this
approach, but it felt like the right thing to do.

Toggle quote (4 lines)
> The second patch makes ‘recursive?’ default to #f, which AFAICS is
> what all the SVN-using packages that were not explicit expected (no
> changes required).

I also carefully checked turning recursion off by default. I’m
confident that nothing changes.


-- Tim
L
L
Ludovic Courtès wrote on 8 Apr 2023 23:23
(name . Timothy Sample)(address . samplet@ngyro.com)
871qkuax09.fsf_-_@gnu.org
Hi Timothy!

Timothy Sample <samplet@ngyro.com> skribis:

Toggle quote (2 lines)
> Whoops! I guess I was a little slow getting my patch in.

No problem! I had it on my to-do list.

Toggle quote (4 lines)
> I’ve highlighted a few sources you missed below, as well as attached
> my patch (for comparison and for listing the new hashes of the missing
> sources).

Oh, good that you were able to find some more!

Toggle quote (4 lines)
> I generated a big diff for all 17 sources that I found (mostly because
> it excites me that Guix can do stuff like that). Basically all the
> changes were boring (as we expected).

Excellent.

Toggle quote (7 lines)
> For “texlive-scripts”, I added a phase that approximates keyword
> expansion for the few scripts that use it to output version information.
> It‘s not exactly the same as what Subversion does. Subversion uses the
> last revision that updated the given file, and I just use
> ‘%texlive-revision’ for every file. I’m not too attached to this
> approach, but it felt like the right thing to do.

I wouldn’t mind doing nothing, but what you did sounds good.

Toggle quote (7 lines)
>> The second patch makes ‘recursive?’ default to #f, which AFAICS is
>> what all the SVN-using packages that were not explicit expected (no
>> changes required).
>
> I also carefully checked turning recursion off by default. I’m
> confident that nothing changes.

Excellent. I’ll push it to ‘master’.

Toggle quote (10 lines)
>>From 19c14a09e9e1d92a1035d15dbbb8d12fb3b59d17 Mon Sep 17 00:00:00 2001
> From: Timothy Sample <samplet@ngyro.com>
> Date: Wed, 5 Apr 2023 13:46:28 -0600
> Subject: [PATCH] svn-download: Do not expand keywords.
> MIME-Version: 1.0
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> See <https://issues.guix.gnu.org/43442#15>.

For posterity, you can add something along the lines of what I had:

Subversion keyword expansion is potentially non-reproducible as some of
them expand time strings relative to the local time zone:


In practice this is not a problem in Guix since Subversion checkouts
happen in an isolated environment using the "default timezone" (UTC).

However, Software Heritage disables keyword expansion for this very
reason. By following suit, we make sure content can be retrieved from
there.

Toggle quote (4 lines)
> + ;; Disable keyword substitution (keywords are CVS-like strings
> + ;; like "$Date$", "$Id$", and so on).
> + "--ignore-keywords"

Likewise:

+ ;; Disable keyword substitutions (keywords are CVS-like strings
+ ;; like "$Date$", "$Id$", and so on) for two reasons: (1) some
+ ;; expansions depend on the local time zone, and (2) SWH disables
+ ;; it in its archive for this very reason.
+ "--ignore-keywords"

Chris, should we get it built on qa.guix? It’s on the order of 7K
rebuilds per architecture since ‘texlive-bin’ is modified.
Alternatively we can set up ci.guix for it, if you think it’s more
appropriate resource-wise.

WDYT?

Ludo’.

PS: I’ll be AFK for the next few days.
C
C
Christopher Baines wrote on 9 Apr 2023 23:31
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 62712@debbugs.gnu.org)
878rf0zqdn.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (7 lines)
> Chris, should we get it built on qa.guix? It’s on the order of 7K
> rebuilds per architecture since ‘texlive-bin’ is modified.
> Alternatively we can set up ci.guix for it, if you think it’s more
> appropriate resource-wise.
>
> WDYT?

The data service comparison is available now which is good.

The builds won't be submitted automatically since there's so many, but
I've shuffled the code around to allow manually submitting them, I'm
running the following command in a screen session on bayfront:

root@bayfront /var/lib/qa-frontpage# sudo -u qa-frontpage /gnu/store/lv4014zwba44fzf035pafba228lypqyl-guix-qa-frontpage-0-7.53bd333/bin/guix-qa-frontpage submit-issue-builds 62712 --priority=600


It will be some time before the builds are completed though, I also need
to try and sort out something for the ARM build machines, as they seem
to be really struggling with slow upload speeds at the moment.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQzMLRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeM5A/6A66iQ16wCFceApfS8S0iv91uYYBD9PtH
pkG+qxyeKjbcBCzfXpsWJcbjaGeqNOPvq0NdAtXkTc/ASrALLxyvt22KXosxUFqI
Up22jkebxMA2o9JawxxX3LuLZ08txAobAh8urYMz/nSqGcTOPE/eWJdak3OklmJg
fQN8E6StsauTDQ89N8obXvYXMl0jvlRRBdIcPpVK4HD2SXPwPOJSoTLKjGPQqdQd
PPeCF8yKrA2hdT5G1ekEaN9fyCoMruO/7jnSUHM2AT/C9JsIsIO4bx0uz36cZE85
fLMwxHqRriwYNG7FrBnD5uwww5HfLRZodYFhiNbAUIWuynNXK7hg/Zjti4zHzttM
D/8aTt/y4gnaN1FIOiAT3HHSPjN2ED4sD/xMAEFiQUK4eex31B4BEK5Yrbu/X17t
qh93eoSISI7MkKoWg5ZgvCFQDBJg1AY9RcXX45O45/jTgaHUyHxSlzAFb4XRTJ1L
P0A9/iJEGqGvyZ/LKBCPHJP5+Hk/gjmPhCBTnw1IJ9BnHzok6di8r99qe3H2z6fY
AdcNAb6C92gv1uQDUtRts4VtFBj/fYBRtcNvu5yCOdRfJnaBzgduFaFHibbKyzIh
odDm214APaZEfktvMDNfWIFl97jLDiC4+MNufRhN79AG6YmKpSlvDrXqGkaDlue7
OuFSIuDyLkY=
=qeMe
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 12 Apr 2023 15:49
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 62712@debbugs.gnu.org)
87r0spxl7z.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (19 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Chris, should we get it built on qa.guix? It’s on the order of 7K
>> rebuilds per architecture since ‘texlive-bin’ is modified.
>> Alternatively we can set up ci.guix for it, if you think it’s more
>> appropriate resource-wise.
>>
>> WDYT?
>
> The data service comparison is available now which is good.
>
> The builds won't be submitted automatically since there's so many, but
> I've shuffled the code around to allow manually submitting them, I'm
> running the following command in a screen session on bayfront:
>
> root@bayfront /var/lib/qa-frontpage# sudo -u qa-frontpage
> /gnu/store/lv4014zwba44fzf035pafba228lypqyl-guix-qa-frontpage-0-7.53bd333/bin/guix-qa-frontpage
> submit-issue-builds 62712 --priority=600

This has now finished running (I don't exactly know when), so the
package changes information on [1] is now showing up.

All the x86_64-linux builds have already completed, and builds for other
systems are happening.

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQ2t1BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcNVQ//SahZuhcNXDTK0+9mRXQp4Vrzbyh3TFfe
p0MwDNNI72/hPk34SMAksPRoMO2h3qtheJsDApI32f67enUFlei09lSoMs1EwPb7
DSBFEZQj90RtimGjB/XtugDGfiQhx1D5uZ3IpYBRhcND00nkAPSto+iLC2HOMvs5
I5glXnw+OTR9fepG53ZxtMZA5DmA87CnTb46E4dtVO/GvFvcA582E0oX+CJAS29P
Tbh4B2FxlBbFiXCrkNyxItpihXz1EKkQuA2Ebahjl+GbQIXuSx718j8ai09FMICU
60/OM2b1iGPMdICtELN6mf8nfK64LhV3TnAaW5Vgzrv30tuUz/WWjpzRMAXUUvln
8R1j9+STD0SDH6IidES8uPe31mFbwgLvX+Hr0GbNOjiWVUL6n8D977S6hKEpxkhP
dlZWrS8EluukBcGO2ze8i3Gp4vg9KZxixnp6GurrYhLqZWgtJI27Y15mESVm+Wx7
uHu0NHyfzSJP9E/u6MLc0q/pa9Xo8Qlt37HejtkPyyFftZoOkHymF/QiRIm9iZO3
4qc4iqNlYAVuWgLMi4DQ2+kJK7DVE5AD8H7ATLIeSbwDI64pcuptdnNd/FBfqD8q
fVukkdNeD0dfbPDDRQMQv0spsrJt2DK6HD1EQ7Tj9o3ImvLfyvZvwvsjSt5Of0nw
mKqK2SZlDEI=
=VfYt
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 20 Apr 2023 11:57
(name . Christopher Baines)(address . mail@cbaines.net)(address . 62712@debbugs.gnu.org)
87fs8ux4ek.fsf@gnu.org
Hi Chris,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (29 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Chris, should we get it built on qa.guix? It’s on the order of 7K
>>> rebuilds per architecture since ‘texlive-bin’ is modified.
>>> Alternatively we can set up ci.guix for it, if you think it’s more
>>> appropriate resource-wise.
>>>
>>> WDYT?
>>
>> The data service comparison is available now which is good.
>>
>> The builds won't be submitted automatically since there's so many, but
>> I've shuffled the code around to allow manually submitting them, I'm
>> running the following command in a screen session on bayfront:
>>
>> root@bayfront /var/lib/qa-frontpage# sudo -u qa-frontpage
>> /gnu/store/lv4014zwba44fzf035pafba228lypqyl-guix-qa-frontpage-0-7.53bd333/bin/guix-qa-frontpage
>> submit-issue-builds 62712 --priority=600
>
> This has now finished running (I don't exactly know when), so the
> package changes information on [1] is now showing up.
>
> All the x86_64-linux builds have already completed, and builds for other
> systems are happening.
>
> 1: https://qa.guix.gnu.org/issue/62712

Thanks a lot!

With ‘core-updates’ coming up, I’m not sure what the best strategy is.
The data at qa.guix should give us confidence, so perhaps we can rebase
it after the ‘core-updates’ merge and apply it at that point?

Ludo’.
S
S
Simon Tournier wrote on 25 Apr 2023 14:41
Re: [bug#62712] [PATCH 0/2] Disable keyword expansion for Subversion downloads
(address . 62712@debbugs.gnu.org)
868regb0cn.fsf@gmail.com
Hi,

Oh cool! Thanks.

On Thu, 20 Apr 2023 at 11:57, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (4 lines)
> With ‘core-updates’ coming up, I’m not sure what the best strategy is.
> The data at qa.guix should give us confidence, so perhaps we can rebase
> it after the ‘core-updates’ merge and apply it at that point?

Yes, it looks good to me.

Cheers,
simon
S
S
Simon Tournier wrote on 5 May 2023 16:09
Re: bug#62712: [PATCH 0/2] Disable keyword expansion for Subversion downloads
(name . Ludovic Courtès)(address . ludo@gnu.org)
87cz3e7tvl.fsf_-_@gmail.com
Hi Ludo,

On jeu., 20 avril 2023 at 11:57, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (4 lines)
> With ‘core-updates’ coming up, I’m not sure what the best strategy is.
> The data at qa.guix should give us confidence, so perhaps we can rebase
> it after the ‘core-updates’ merge and apply it at that point?

What is the status of this patch? The merge of ’core-updates’ is behind
us now \o/ yeah! and all seems green for installing this patch, no?

Cheers,
simon
N
N
Nicolas Goaziou wrote on 6 May 2023 02:22
Re: [bug#62712] [PATCH 0/2] Disable keyword expansion for Subversion downloads
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
87cz3exq93.fsf@nicolasgoaziou.fr
Hello,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (3 lines)
> What is the status of this patch? The merge of ’core-updates’ is behind
> us now \o/ yeah! and all seems green for installing this patch, no?

It was applied in "tex-team" branch, which is currently being built by
the CI.

Regards,
--
Nicolas Goaziou
S
S
Simon Tournier wrote on 9 May 2023 14:22
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
871qjp7kzn.fsf@gmail.com
Hi,

On sam., 06 mai 2023 at 02:22, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (3 lines)
> It was applied in "tex-team" branch, which is currently being built by
> the CI.

Cool! This branch seems green, isn’t it? Is it merged?

Well, since the patch is installed, what about closing this submission?

Cheers,
simon
L
L
Ludovic Courtès wrote on 10 May 2023 18:22
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
87lehw88cf.fsf@gnu.org
Hi!

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (7 lines)
> On sam., 06 mai 2023 at 02:22, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
>> It was applied in "tex-team" branch, which is currently being built by
>> the CI.
>
> Cool! This branch seems green, isn’t it? Is it merged?

Nope. Unfortunately, due to the recent ‘rust-team’ merge, we’ll have to
merge back and wait for CI to build it again.

Nicolas, can you take care of merging ‘master’ into the branch? (Or
rebasing it.)

Ludo’.
N
N
Nicolas Goaziou wrote on 11 May 2023 23:40
(name . Ludovic Courtès)(address . ludo@gnu.org)
87sfc235tm.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (3 lines)
> Nicolas, can you take care of merging ‘master’ into the branch? (Or
> rebasing it.)

Done. I re-created `tex-team' on top of `master'. It can be built again.

Regards,
--
Nicolas Goaziou
C
C
Christopher Baines wrote on 12 May 2023 13:45
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87r0rlrcq2.fsf@cbaines.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (9 lines)
> Hello,
>
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Nicolas, can you take care of merging ‘master’ into the branch? (Or
>> rebasing it.)
>
> Done. I re-created `tex-team' on top of `master'. It can be built again.

Given this might be the next branch to try and merge to master, would
you be interested in trying out the proecss I set out here [1]?


All that would involve is creating a guix-patches issue saying you're
looking to merge the tex-team branch.

I'm interested in this since I want to look at getting the qa-frontpage
to spot these issues for branch merges, and then use that information to
manage builds and testing.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmReJ9VfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XecwRAApVcwSrKLGSVNiYYRPXUd5+13XYR4knbY
jONNXOhEQkO6LfuyxSdpKAdvrXCbFOVVi4ctACkgw2kc3+mIKS9EMGIZqZoMaFJK
7FJKhfyqn//xfY5StUlCWVqG7lODZ3O/SlqG+L3vUSoiXDdRkWgtQIZOzdyLgtVI
ARSf1xLq+B77reAQWHAoowhXHvqVCnNPuL1BRJivCcoDfeX9/1+awFM5VQR4Cinf
D8yHWw72IrmQ0MraqOGE72OxRafgJmu1pA9bC5wm/nhExswRcb7anEX19KIqSlL6
pTeMCcuihkuPQ1HlQtzTvPD4KMYGOCv+lPq8pGJqwFTAOE2EAb94KLK3RHS9SPdq
lppS8JYBRtQ/ceUHHUAERa1RxIXRPDpc4fpLronI+Qf1j+SFq7XJoHawze4Seyky
iDCMsZnxTzB/ntDWNhn7IU5GFA8wSo3RHZG0kcrxFDstB9w+XfT9Wa2eqFBSUG4j
vbBq1DXXjDoYQ5Z+yUrZQkTQngIqLkG9fyHU7K4KU12bcogZmZLjCTpNHfCBxp/K
ZOyiZIKq+H47V/PV6rua8E8lbriSK75VUiUQ3v36FPzl0HhWmTqnCdaiogH7xgna
huQanAvPRe9ORNYwfjle6ODVgRQ8Odf3dfHMJIIJTuwQjg9wT/D+vSUHEOZublvW
oVHHRkmxdkk=
=EBLv
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 15 May 2023 17:50
(name . Christopher Baines)(address . mail@cbaines.net)
877ct9387r.fsf@nicolasgoaziou.fr
Hello,

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (8 lines)
> Given this might be the next branch to try and merge to master, would
> you be interested in trying out the proecss I set out here [1]?
>
> 1: https://issues.guix.gnu.org/63459
>
> All that would involve is creating a guix-patches issue saying you're
> looking to merge the tex-team branch.


Regards,
--
Nicolas Goaziou
C
C
Christopher Baines wrote on 16 May 2023 11:54
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87o7mkeh3h.fsf@cbaines.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (14 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> writes:
>
>> Given this might be the next branch to try and merge to master, would
>> you be interested in trying out the proecss I set out here [1]?
>>
>> 1: https://issues.guix.gnu.org/63459
>>
>> All that would involve is creating a guix-patches issue saying you're
>> looking to merge the tex-team branch.
>
> Done in <https://issues.guix.gnu.org/63521>

Awesome, thanks. I'll have a look at getting the qa-frontpage to detect
that issue and start submitting builds for the tex-team branch.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmRjUvJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd0mg//ULKAjoCCA3xtRsDe7ciM0KzIbvZTg0Qj
5J9MmMXK9MwY5Fh1yCUvktKpcqBc51HRhn2hJK9Fb67WY2VPNJCf8n5KqolCdGPu
+cFbj2s5KsMFyRHT7ZXPRX1dkcdi6tKn2bXm8geKx3unkgWK88SY64EKXjj9VzrD
2E53cl0OQXFWiiPdWRnBBO70HpZUrig6IFsyqsNwuQNJlZ48DGLgBKoMP+azzTRE
9468jltciVLDdotLYxPG0nne6VMjKynGZoLEljsnYumgB6W+VgFP5pCCvcB0OhOt
ROk/vtFfUvNX+CXreBK1cA+BUNG9T5EV8TJuKGMWIbj0qNYY+bmBVQx68aRfROiT
a5yVKT9xgmV3qB/8wLSumJ5qcb5G1B0sEpkowembtDR6EXVshNPQPHEczpN3lcaZ
dMT5QRsW2aPORxMzpvOwtPzWZyNH7Rt4gWnId02SJ0BIplbpOf2liGbv6FpGgQJK
FaxYQat5+U1WClakjb/8lMfM1gcY4Olph6p/ZzdsvZqCZjRJrLQiyRrBfjmZYYJH
n8qPrmYbsIfDXxINxJIztIEOGrz7zhe8Qz39oq9bI+qQNiSDDUv6b/Olh83Y94SV
TTsPexHsN03HS7fZc6/v/0LPcbyMXgF+8wibRA99Q8DdaxQA3YOwYwd8E0Ip1j1Z
MP9EcRw9HLY=
=62qT
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 22 May 2023 18:01
control message for bug #62712
(address . control@debbugs.gnu.org)
87sfbouzhj.fsf@gnu.org
block 62712 by 63521
quit
L
L
Ludovic Courtès wrote on 18 Jun 2023 23:21
Re: bug#62712: [PATCH 0/2] Disable keyword expansion for Subversion downloads
(name . Christopher Baines)(address . mail@cbaines.net)
87y1kgo49y.fsf_-_@gnu.org
This was merged last week (see commit
e6da6e3152b01b36d925d8670f1b8c3e1a39ef4b).

Closing!

Ludo’.
Closed
?