[PATCH 0/2]: gnu wsjtx: Update to 2.6.1 and improve style.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
[PATCH 0/2]: gnu wsjtx: Update to 2.6.1 and improve style.
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230406213157.27820-1-sharlatanus@gmail.com
Hi Guix!

I've started a long journey to enable Qt6 for Stellarium. But at first I
need to rename "qtserialport" to "qtserialport-5" and pack new "qtserialport"
based on Qt6.

This patch series provides one of many future updates and adjustments of
projects where "qtserialport" is in use to make sure they are not failing to
build.

Sharlatan Hellseher (2):
gnu: wsjtx: Update to 2.6.1.
gnu: wsjtx: Improve package style.

gnu/packages/radio.scm | 32 ++++++++++++++++++--------------
1 file changed, 18 insertions(+), 14 deletions(-)

--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/2] gnu: wsjtx: Update to 2.6.1.
(address . 62702@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230406213347.27898-1-sharlatanus@gmail.com
* gnu/packages/radio.scm (wsjtx): Update to 2.6.1.
---
gnu/packages/radio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index ad7982f256..d3bd3b9dee 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1510,7 +1510,7 @@ (define-public tlf
(define-public wsjtx
(package
(name "wsjtx")
- (version "2.5.4")
+ (version "2.6.1")
(source
(origin
(method git-fetch)
@@ -1519,7 +1519,7 @@ (define-public wsjtx
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0nciw9smrfcsirlwyny5r9h7sk2zvm40m56y1hxpgpmbnh6mqikh"))))
+ (base32 "1lqd77v9xm58k9g9kfwxva3mmzm1yyk1v27nws5j1a293zfg2hkw"))))
(build-system qt-build-system)
(native-inputs
(list asciidoc gfortran pkg-config qttools-5 ruby-asciidoctor))
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/2] gnu: wsjtx: Improve package style.
(address . 62702@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230406213347.27898-2-sharlatanus@gmail.com
* gnu/package/radio.scm (wsjtx)
Improve package style by shifting order of components.
[native-inputs]: Columnize, sort alphabetically.
[inputs]: Remove labels, sort alphabetically.
---
gnu/packages/radio.scm | 28 ++++++++++++++++------------
1 file changed, 16 insertions(+), 12 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index d3bd3b9dee..c589f95954 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1521,19 +1521,24 @@ (define-public wsjtx
(sha256
(base32 "1lqd77v9xm58k9g9kfwxva3mmzm1yyk1v27nws5j1a293zfg2hkw"))))
(build-system qt-build-system)
+ (arguments
+ (list #:tests? #f)) ; No test suite
(native-inputs
- (list asciidoc gfortran pkg-config qttools-5 ruby-asciidoctor))
+ (list asciidoc
+ gfortran
+ pkg-config
+ qttools-5
+ ruby-asciidoctor))
(inputs
- `(("boost" ,boost)
- ("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("hamlib" ,wsjtx-hamlib)
- ("libusb" ,libusb)
- ("qtbase" ,qtbase-5)
- ("qtmultimedia-5" ,qtmultimedia-5)
- ("qtserialport" ,qtserialport)))
- (arguments
- `(#:tests? #f)) ; No test suite
+ (list boost
+ fftw
+ fftwf
+ libusb
+ qtbase-5
+ qtmultimedia-5
+ qtserialport
+ wsjtx-hamlib))
+ (home-page "https://www.physics.princeton.edu/pulsar/k1jt/wsjtx.html")
(synopsis "Weak-signal ham radio communication program")
(description
"WSJT-X implements communication protocols or modes called FT4, FT8,
@@ -1541,7 +1546,6 @@ (define-public wsjtx
detecting and measuring your own radio signals reflected from the Moon. These
modes were all designed for making reliable, confirmed QSOs under extreme
weak-signal conditions.")
- (home-page "https://www.physics.princeton.edu/pulsar/k1jt/wsjtx.html")
(license license:gpl3)))
(define-public jtdx
--
2.39.2
Leo Famulari wrote 2 years ago
Re: [bug#62702] [PATCH 0/2]: gnu wsjtx: Update to 2.6.1 and improve style.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62702-done@debbugs.gnu.org)
ZDdx3iTMrdmEDeN9@jasmine.lan
On Thu, Apr 06, 2023 at 10:31:57PM +0100, Sharlatan Hellseher wrote:
Toggle quote (10 lines)
> Hi Guix!
>
> I've started a long journey to enable Qt6 for Stellarium. But at first I
> need to rename "qtserialport" to "qtserialport-5" and pack new "qtserialport"
> based on Qt6.
>
> This patch series provides one of many future updates and adjustments of
> projects where "qtserialport" is in use to make sure they are not failing to
> build.

Thanks for working on this project and taking care of the details!

Pushed as 982698c52fb388e278dc4cec4b124406f23f102a
Closed
Sharlatan Hellseher wrote 2 years ago
(address . 62702@debbugs.gnu.org)
CAO+9K5rbQj-Lqr1+Y=mynj6ymbr0wxy47cp8E089nQU4JG_tWA@mail.gmail.com
Hi Leo,
Thanks for review and suggestions. I've ended up by splitting my
initial patch into 3 to increase visibility of the changes.
Sharlatan Hellseher (3):
gnu: packages music: Delete use-module duplicates.
gnu: packages music: Sort use-module alphabetically.
gnu: abjad: Fix build.
gnu/packages/music.scm | 96 +++++++++++++++++++++---------------------
1 file changed, 48 insertions(+), 48 deletions(-)
base-commit: c371555a4b46a5c9288f54753b0f158f9c4b8abc
--
2.39.2
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 2 years ago
(address . 62702@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230413210522.23854-1-sharlatanus@gmail.com
* gnu/packages/music.scm: Delete duplicated (guix build-system qt).
---
gnu/packages/music.scm | 2 --
1 file changed, 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 69fe7009be..10281a6a12 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -84,11 +84,9 @@ (define-module (gnu packages music)
#:use-module (guix build-system qt)
#:use-module (guix build-system scons)
#:use-module (guix build-system glib-or-gtk)
- #:use-module (guix build-system qt)
#:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
#:use-module (guix build-system go)
- #:use-module (guix build-system qt)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages algebra)
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/3] gnu: packages music: Sort use-module alphabetically.
(address . 62702@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230413210522.23854-2-sharlatanus@gmail.com
* gnu/packages/music.scm: Sort use-module alphabetically to ease
maintenance.
---
gnu/packages/music.scm | 34 +++++++++++++++++-----------------
1 file changed, 17 insertions(+), 17 deletions(-)

Toggle diff (113 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 10281a6a12..054d48bb39 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -69,31 +69,31 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages music)
- #:use-module (guix gexp)
- #:use-module (guix utils)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix build-system gnu)
#:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system scons)
- #:use-module (guix build-system glib-or-gtk)
- #:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
- #:use-module (guix build-system go)
+ #:use-module (guix build-system waf)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
+ #:use-module (gnu packages assembly)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
- #:use-module (gnu packages assembly)
#:use-module (gnu packages backup)
#:use-module (gnu packages base) ;libbdf
#:use-module (gnu packages bash)
@@ -102,9 +102,9 @@ (define-module (gnu packages music)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages cdrom)
- #:use-module (gnu packages code)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
@@ -123,13 +123,14 @@ (define-module (gnu packages music)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages game-development)
#:use-module (gnu packages gcc)
- #:use-module (gnu packages gnupg)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnunet)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gpodder)
#:use-module (gnu packages graphics)
#:use-module (gnu packages graphviz)
@@ -142,12 +143,13 @@ (define-module (gnu packages music)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages java)
#:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages libffi)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux) ; for alsa-utils
#:use-module (gnu packages lirc)
#:use-module (gnu packages llvm)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages mp3)
#:use-module (gnu packages mpd)
@@ -180,8 +182,8 @@ (define-module (gnu packages music)
#:use-module (gnu packages stb)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
- #:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
@@ -192,11 +194,9 @@ (define-module (gnu packages music)
#:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages xiph)
- #:use-module (gnu packages golang)
- #:use-module (gnu packages lua)
#:use-module ((srfi srfi-1) #:select (last)))
(define-public audacious
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/3] gnu: abjad: Fix build.
(address . 62702@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230413210522.23854-3-sharlatanus@gmail.com
* gnu/packages/music.scm (abjad): Fix build.
[arguments]: Use gexp.
<phases>: Add disable-failing-tests phase to fix build process of the
package.
[propagated-inputs]: Move python-flake8, python-isort, python-mypy,
python-pytest, python-pytest-cov, python-pytest-helpers-namespace,
python-six, python-sphinx-autodoc-typehints from here ...
[native-inputs]: ... to here. Remove python-black.
---
gnu/packages/music.scm | 60 ++++++++++++++++++++++--------------------
1 file changed, 31 insertions(+), 29 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 054d48bb39..9c47fe0a8f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -77,6 +77,7 @@ (define-module (gnu packages music)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system scons)
@@ -1554,50 +1555,51 @@ (define-public music21
(define-public abjad
(package
(name "abjad")
+ ;; XXX: The latest version which supports current Guix's Python 3.9.9.
(version "3.4")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Abjad/abjad")
- (commit (string-append "v" version))))
+ (url "https://github.com/Abjad/abjad")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0s63vk9fifp0im9c31kb9ck39mbaxhrls993d8fvg0nkg41z1jnz"))))
- (build-system python-build-system)
+ (base32 "0s63vk9fifp0im9c31kb9ck39mbaxhrls993d8fvg0nkg41z1jnz"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'loosen-requirements
- (lambda _
- (substitute* "setup.py"
- ;; Permit newer versions of uqbar. Remove for >3.4.
- ((", <0\\.5\\.0")
- ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; See: https://stackoverflow.com/a/34140498
- (invoke "python" "-m" "pytest" "tests")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX. Permit newer version of uqbar, remove for >3.4. Remove in
+ ;; the next update.
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ((", <0\\.5\\.0") ""))))
+ ;; FIXME: Check why it's failing with this: Note: compilation failed
+ ;; and \version outdated, did you update input syntax with
+ ;; convert-ly?
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/test_ext_sphinx.py"
+ (("def test_ext_sphinx_01") "def __off_test_ext_sphinx_01")))))))
(inputs
(list lilypond))
- (propagated-inputs
- (list python-ply
- python-quicktions
- python-roman
- python-six
- python-uqbar
- ;; XXX: These test dependencies(?) are listed as install_requires
- ;; in setup.py. Propagate accordingly.
- python-black
- python-flake8
+ (native-inputs
+ (list python-flake8
python-isort
python-mypy
python-pytest
python-pytest-cov
python-pytest-helpers-namespace
+ python-six
python-sphinx-autodoc-typehints))
+ (propagated-inputs
+ (list python-quicktions
+ python-ply
+ python-roman
+ python-uqbar))
(home-page "https://abjad.github.io")
(synopsis "Python API for building LilyPond files")
(description
@@ -1607,7 +1609,7 @@ (define-public abjad
programming language, you can use Abjad to make systematic changes to music as you work.
Because Abjad wraps the LilyPond music notation package, you can use Abjad to control the
typographic detail of symbols on the page.")
- (license license:expat)))
+ (license license:expat)))
(define-public abjad-ext-rmakers
(package
--
2.39.2
Leo Famulari wrote 2 years ago
Re: [bug#62702]
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62702-done@debbugs.gnu.org)
ZDmTxgLn/47uw6d2@jasmine.lan
On Thu, Apr 13, 2023 at 10:02:04PM +0100, Sharlatan Hellseher wrote:
Toggle quote (10 lines)
> Hi Leo,
>
> Thanks for review and suggestions. I've ended up by splitting my
> initial patch into 3 to increase visibility of the changes.
>
> Sharlatan Hellseher (3):
> gnu: packages music: Delete use-module duplicates.
> gnu: packages music: Sort use-module alphabetically.
> gnu: abjad: Fix build.

Thanks for these thoughtful revisions! They are a big improvement.

I tweaked the commit messages slightly, added a copyright line for you
to music.scm, and pushed as cbba52aaf7ca9b05c3ff86bfda5d3a7969135e6b

By the way, I think the bug tickets got messed up. Here we are, in the
wsjtx ticket :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62702@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62702
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help