[PATCH] gnu: Add pmbootstrap.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 3 Apr 2023 10:17
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
MDlQnvmTSMdBOA-miRitrZEVpgtjih5PpVMCx7sTCkEKyb7WuDMgjNwLNrXU-yonYNvlUvepis5BZ_FYW4U7t-y5QW30P_f3NpFZha1cXe4=@proton.me
* gnu/packages/postmarketos.scm: New file.
(pmbootstrap): New public variable.
* gnu/packages/local.mk (GNU_SYSTEM_MODULES): Add the new file.
---
gnu/local.mk | 1 +
gnu/packages/postmarketos.scm | 68 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 69 insertions(+)
create mode 100644 gnu/packages/postmarketos.scm

Toggle diff (86 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 186d82a..92848b2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -502,6 +502,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/poedit.scm \
%D%/packages/polkit.scm \
%D%/packages/popt.scm \
+ %D%/packages/postmarketos \
%D%/packages/printers.scm \
%D%/packages/profiling.scm \
%D%/packages/prolog.scm \
diff --git a/gnu/packages/postmarketos.scm b/gnu/packages/postmarketos.scm
new file mode 100644
index 0000000..9de45ec
--- /dev/null
+++ b/gnu/packages/postmarketos.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sughosha <sughosha@proton.me>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages postmarketos)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages version-control))
+
+(define-public pmbootstrap
+ (package
+ (name "pmbootstrap")
+ (version "1.51.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pmbootstrap" version))
+ (sha256
+ (base32
+ "08g55fh24n3wpva7d1ps6fnk65ik49wfycjpwrjs9w0889zlwsl1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/pmbootstrap")
+ `("PATH" = ("/run/setuid-programs" ,(getenv "PATH")))
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH"))))))
+ ;; Dissociate "sudo" as setuid-programs is preferred
+ (add-after 'sanity-check 'dissociate-sudo
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (sudo (assoc-ref inputs "sudo")))
+ (substitute* (string-append out "/bin/pmbootstrap")
+ (((string-append ":" sudo "/sbin"))
+ "")
+ (((string-append ":" sudo "/bin"))
+ ""))))))))
+ (native-inputs (list sudo))
+ (inputs (list bash-minimal git openssl procps))
+ (home-page "https://git.sr.ht/~postmarketos/pmbootstrap")
+ (synopsis "Bootstrap a postmarketOS system")
+ (description
+ "This package provides a sophisticated chroot / build / flash tool to
+ develop and install postmarketOS.")
+ (license license:gpl3+)))
--
libgit2 1.5.1
S
S
Sughosha wrote on 3 Apr 2023 10:24
[PATCH v2] gnu: Add pmbootstrap.
(name . 62640@debbugs.gnu.org)(address . 62640@debbugs.gnu.org)
pPkb5iqZT19LQLqcOCVOnD94Y9Y_nSvMYMYSP2N2krL3rZE5m9VMMc6bAkKc_4K5_75sPWRMhpBgaDGHQ2mTTheuwIS9xxnG5HYIr30IS7s=@proton.me
* gnu/packages/postmarketos.scm: New file.
(pmbootstrap): New public variable.
* gnu/packages/local.mk (GNU_SYSTEM_MODULES): Add the new file.
---
gnu/local.mk | 1 +
gnu/packages/postmarketos.scm | 68 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 69 insertions(+)
create mode 100644 gnu/packages/postmarketos.scm

Toggle diff (86 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 186d82a..12e5f68 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -502,6 +502,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/poedit.scm \
%D%/packages/polkit.scm \
%D%/packages/popt.scm \
+ %D%/packages/postmarketos.scm \
%D%/packages/printers.scm \
%D%/packages/profiling.scm \
%D%/packages/prolog.scm \
diff --git a/gnu/packages/postmarketos.scm b/gnu/packages/postmarketos.scm
new file mode 100644
index 0000000..9de45ec
--- /dev/null
+++ b/gnu/packages/postmarketos.scm
@@ -0,0 +1,68 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sughosha <sughosha@proton.me>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages postmarketos)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages version-control))
+
+(define-public pmbootstrap
+ (package
+ (name "pmbootstrap")
+ (version "1.51.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pmbootstrap" version))
+ (sha256
+ (base32
+ "08g55fh24n3wpva7d1ps6fnk65ik49wfycjpwrjs9w0889zlwsl1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/pmbootstrap")
+ `("PATH" = ("/run/setuid-programs" ,(getenv "PATH")))
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH"))))))
+ ;; Dissociate "sudo" as setuid-programs is preferred
+ (add-after 'sanity-check 'dissociate-sudo
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (sudo (assoc-ref inputs "sudo")))
+ (substitute* (string-append out "/bin/pmbootstrap")
+ (((string-append ":" sudo "/sbin"))
+ "")
+ (((string-append ":" sudo "/bin"))
+ ""))))))))
+ (native-inputs (list sudo))
+ (inputs (list bash-minimal git openssl procps))
+ (home-page "https://git.sr.ht/~postmarketos/pmbootstrap")
+ (synopsis "Bootstrap a postmarketOS system")
+ (description
+ "This package provides a sophisticated chroot / build / flash tool to
+ develop and install postmarketOS.")
+ (license license:gpl3+)))
--
libgit2 1.5.1
?