[PATCH] gnu: cl-out123: Update to 1.0.0-2.41771bf.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230402223518.11352-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (sbcl-cl-out123): Update to 1.0.0-2.41771bf.
[arguments]<tests>: Explicitly disable them as not provided upstream.
<phases>: Simplify fix-paths phase. Remove redundant phase
fix-ecl-package-name after issue was resolved upstream.
[inputs]: Remove labels.
---
gnu/packages/lisp-xyz.scm | 38 ++++++++++++++------------------------
1 file changed, 14 insertions(+), 24 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5139ac93ce..5ddb254d93 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14062,8 +14062,8 @@ (define-public cl-mpg123
(sbcl-package->cl-source-package sbcl-cl-mpg123))
(define-public sbcl-cl-out123
- (let ((commit "6b58d3f8c2a28ad09059ac4c60fb3c781b9b421b")
- (revision "1"))
+ (let ((commit "41771bfd419e7349ad569f8e6fcd8a26d6f9e5b7")
+ (revision "2"))
(package
(name "sbcl-cl-out123")
(version (git-version "1.0.0" revision commit))
@@ -14075,39 +14075,29 @@ (define-public sbcl-cl-out123
(commit commit)))
(file-name (git-file-name "cl-out123" version))
(sha256
- (base32 "0mdwgfax6sq68wvdgjjp78i40ah7wqkpqnvaq8a1c509k7ghdgv1"))
+ (base32 "0ahgc5l5lbpl3ini4pn5crh8b7dlr386pxczl0d4h6djhccxzs4w"))
(modules '((guix build utils)))
(snippet
'(begin
;; Remove bundled pre-compiled libraries.
- (delete-file-recursively "static")
- #t))))
+ (delete-file-recursively "static")))))
(build-system asdf-build-system/sbcl)
(arguments
- `(#:phases
+ `(#:tests? #f ; No tests
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "low-level.lisp"
- (("libout123.so" all)
- (string-append (assoc-ref inputs "libout123")
- "/lib/" all)))))
- ;; NOTE: (Sharlatan-20210129T134529+0000): ECL package `ext' has no
- ;; exported macro `without-interrupts' it's moved to `mp' package
- ;; https://github.com/Shirakumo/cl-out123/issues/2
- ;; https://gitlab.com/embeddable-common-lisp/ecl/-/blob/develop/src/lsp/mp.lsp
- (add-after 'unpack 'fix-ecl-package-name
- (lambda _
- (substitute* "wrapper.lisp"
- (("ext:without-interrupts.*") "mp:without-interrupts\n"))
- #t)))))
+ (("libout123.so")
+ (search-input-file inputs "/lib/libout123.so"))))))))
(inputs
- `(("bordeaux-threads" ,sbcl-bordeaux-threads)
- ("cffi" ,sbcl-cffi)
- ("documentation-utils" ,sbcl-documentation-utils)
- ("libout123" ,mpg123)
- ("trivial-features" ,sbcl-trivial-features)
- ("trivial-garbage" ,sbcl-trivial-garbage)))
+ (list mpg123
+ sbcl-bordeaux-threads
+ sbcl-cffi
+ sbcl-documentation-utils
+ sbcl-trivial-features
+ sbcl-trivial-garbage))
(home-page "https://shirakumo.github.io/cl-out123/")
(synopsis "Common Lisp bindings to libout123")
(description
--
2.39.2
Guillaume Le Vaillant wrote 2 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62631-done@debbugs.gnu.org)
87a5zoaw2i.fsf@kitej
Patch pushed as e11f28d90c9b7cddd08eba0032f1ae128fdb82e6.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZCvgJQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+J+QD/UPO40Ln/XpsH9FzDWBFoJqJZJEig0iSivzjJ
MSdpwBoA/0o/nF0E7VTHaOse14FDHIeNtrLacqZym4/pfc2C3ufV
=43N1
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62631@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62631
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help