[PATCH] gnu: Add cl-fast-ecs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 2 Apr 2023 21:30
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230402193017.10888-1-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-fast-ecs, ecl-cl-fast-ecs,
sbcl-cl-fast-ecs): New variables.
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ff6eebed25..5139ac93ce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6962,6 +6962,43 @@ (define-public cl-fastcgi
(define-public ecl-cl-fastcgi
(sbcl-package->ecl-package sbcl-cl-fastcgi))
+(define-public sbcl-cl-fast-ecs
+ (package
+ (name "sbcl-cl-fast-ecs")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/lockie/cl-fast-ecs")
+ (commit version)))
+ (file-name (git-file-name "cl-fast-ecs" version))
+ (sha256
+ (base32 "06cnhm8zpyqyjr17mji5wvj4gh2glpdw8gqy1vwrq3vgphfmg560"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-parachute))
+ (inputs
+ (list sbcl-alexandria sbcl-trivial-garbage))
+ (home-page "https://lockie.gitlab.io/cl-fast-ecs/")
+ (synopsis "Blazingly fast Entity-Component-System microframework")
+ (description
+ "CL-FAST-ECS is a Common Lisp library providing an implementation of the
+@acronym{ECS, Entity-Component-System} pattern, primarily focused on speed and
+interactive development.
+
+ECS is an architectural data-oriented design pattern that allows for the
+effective processing of a large number of in-game objects while keeping the code
+and data separated. This provides flexibility in the way that game objects are
+built at runtime.")
+ (license license:expat)))
+
+(define-public cl-fast-ecs
+ (sbcl-package->cl-source-package sbcl-cl-fast-ecs))
+
+(define-public ecl-cl-fast-ecs
+ (sbcl-package->ecl-package sbcl-cl-fast-ecs))
+
(define-public sbcl-cl-flac
(let ((commit "d094d33d3cc2cf263263b917798d338eded3c532")
(revision "0"))
--
2.39.2
G
G
Guillaume Le Vaillant wrote on 4 Apr 2023 10:26
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62628-done@debbugs.gnu.org)
87ilecaw7w.fsf@kitej
Patch pushed as 3905bd72996578a83dcc5aa40c0bdcee1cd08cc6.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZCvfYw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8rxAD/VSMKQzylYzXFVMJXPWjzuecq11t4PVFaIH4d
M7NTiHUBAJMR81Ly7i7QNKWpjnapa0HfqhInfL+7GtLOP1E/qA3I
=0uRM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62628@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62628
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch