(backtrace) hangs and causes excessive memory usage

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . bug-guile@gnu.org)
878rfamamq.fsf@cbaines.net
I've got this problem in the guix-build-coordinator, but I've been so
far unable to reproduce it in a standalone manor.

When (backtrace) is called, the output seems to start, but then stops as
seen below. The memory usage also seems to then start increasing with
increasingly large jumps over a period of hours.

I've seen calling (backtrace) crash before, but this behaviour where it
seems to get stuck is new. I can't tell for sure whether the excessive
memory usage is directly related, or a consequence of the problem.

I've included some output from (backtrace) where this problem occurs
below.


Backtrace:
In ice-9/boot-9.scm:
1752:10 13 (with-exception-handler _ _ #:unwind? _ # _)
In guix-build-coordinator/coordinator.scm:
900:9 12 (_)
In prometheus.scm:
429:4 11 (call-with-duration-metric _ _ _ #:buckets _ #:docstring …)
In ice-9/boot-9.scm:
1747:15 10 (with-exception-handler #<procedure 7f18a15931c0 at gu…> …)
In guix-build-coordinator/coordinator.scm:
913:15 9 (_)
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
In guix-build-coordinator/coordinator.scm:
915:19 7 (_)
858:10 6


Backtrace:
In guix-build-coordinator/utils.scm:
1179:6 13 (_)
In ice-9/boot-9.scm:
1747:15 12 (with-exception-handler #<program 7fb7adc56a00 7fb7ab4…> …)
1747:15 11 (with-exception-handler #<program 7fb7adbf6f00 7fb7a98…> …)
In guix-build-coordinator/coordinator.scm:
1011:8 10 (_)
In ice-9/boot-9.scm:
1752:10 9 (with-exception-handler _ _ #:unwind? _ # _)
In prometheus.scm:
429:4 8 (call-with-duration-metric _ _ _ #:buckets _ #:docstring …)
In ice-9/eval.scm:
619:8 7
Christopher Baines wrote 2 years ago
(address . 62623@debbugs.gnu.org)
87ilds5eep.fsf@cbaines.net
Someone else has this problem, which makes me feel a bit better since I
had no idea what's going on here.

I'm assuming that (backtrace) causing issues is still a problem with
Guile itself, but it seems like there's some involvement of
guile-fibers (which fits with my experience):

Christopher Baines wrote 1 months ago
(address . 62623-done@debbugs.gnu.org)
87lduajh5r.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (9 lines)
> Someone else has this problem, which makes me feel a bit better since I
> had no idea what's going on here.
>
> I'm assuming that (backtrace) causing issues is still a problem with
> Guile itself, but it seems like there's some involvement of
> guile-fibers (which fits with my experience):
>
> https://github.com/wingo/fibers/issues/76

I'm not sure, but I think this is fixed now.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmetw2BfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdO2g/+P2wNAw+wgNQM97OMuc+Hg8Nj03Ee5/cf
ngf9oHIEY7X/6vmGx+cor9mMFKEmUHGKci1sBFjmCVVBX/dv3Mswag//PbHWrU0F
sjhzGBCmdpvNpRtUR9RUpn9HgEyClmYFQZ3cGGu0sFDgyIL+JxofhAAoULVhA4U2
060pI2LclHH8yywX2k074iapVezE5qEKOXBp4Upi6WEdH0R3iIZM9iwvUOYOGyy4
kGqaR1FFIfDFyeXMmBnpVAIrSoiVZQdSiJlS1Fje2PIGs6ZhT9Zhxhoe6yClaMGS
4NRJHcAcZFXBWfGBS0QkfICvpdHS4WXekZ3OZPK7kUTuZRu7bpGOiGHziMKV27/8
iV/t6F7kdqkxDQvxgsGcRNUs6QqgxEOJHJRuTR4yKuFxj6dQkMAN/RXzzT6Hq/M6
oWjoGzkdZzLhrBINb0urz9kla1uQJJvTwp76/pDm4Iu+3s8pvlU5l+Axy+U8LK3n
p2QwMXzso/eOjxKwthZS4EQ8Tw/cMTG6dzf+ChME/VW2bqtWCzOoOlgwGI1d0e8e
SkTjW+zyKPs2fIDcIW5SaRh1tW8TbZyCiyAwUk6x+zAvnpoCcCqpSGPz81VnHhhV
VsqlzhDA4H0Z9Mh27S01aIi72KzVJR8rGt3HMGLjB/61U8RCesOh4+hrpB21OZvn
Wqa9IE1vTnI=
=H+/5
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62623@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62623
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help