[PATCH 0/3] *** Package targets and tarchetypes ***

  • Done
  • quality assurance status badge
Details
2 participants
  • kyle
  • Ricardo Wurmus
Owner
unassigned
Submitted by
kyle
Severity
normal

Debbugs page

kyle wrote 2 years ago
(address . guix-patches@gnu.org)
cover.1680324055.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

*** these packages implement an R-native scientific workflow system ***

Kyle Andrews (3):
gnu: Add r-targets package
gnu: Add r-future-callr
gnu: Add r-tarchetypes

gnu/packages/cran.scm | 109 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 109 insertions(+)


base-commit: 47ea688fd27d0ce0c8ea5481f1f94d0ebc3e37eb
--
2.39.2
kyle wrote 2 years ago
[PATCH 1/3] gnu: Add r-targets package
(address . 62579@debbugs.gnu.org)
5ae044eb9f0e7fd794a0368b736a66d77a7094d9.1680324055.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f2bdd750ca..3e8ec429e1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14456,6 +14456,47 @@ (define-public r-tab
handle data from simple random samples as well as complex surveys.")
(license license:gpl3+)))
+(define-public r-targets
+ (package
+ (name "r-targets")
+ (version "0.14.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "targets" version))
+ (sha256
+ (base32
+ "0mhwvlbxnb4w054pjiw2smss28i90sg52w8v040y7sqy6gq2c8n6"))))
+ (properties `((upstream-name . "targets")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-base64url
+ r-callr
+ r-cli
+ r-codetools
+ r-data-table
+ r-digest
+ r-igraph
+ r-knitr
+ r-r6
+ r-rlang
+ r-tibble
+ r-tidyselect
+ r-vctrs
+ r-withr
+ r-yaml))
+ (native-inputs (list r-knitr))
+ (home-page "https://docs.ropensci.org/targets/")
+ (synopsis "Dynamic Function-Oriented 'Make'-Like Declarative Pipelines")
+ (description
+ "This package provides a pipeline toolkit for Statistics and data science in R,
+the targets package brings function-oriented programming to Make'-like
+declarative pipelines. targets orchestrates a pipeline as a graph of
+dependencies, skips steps that are already up to date, runs the necessary
+computation with optional parallel workers, abstracts files as R objects, and
+provides tangible evidence that the results are reproducible given the
+underlying code and data. The methodology in this package borrows from GNU Make
+(2015, ISBN:978-9881443519) and drake (2018, <doi:10.21105/joss.00550>).")
+ (license license:expat)))
+
(define-public r-dvmisc
(package
(name "r-dvmisc")
--
2.39.2
kyle wrote 2 years ago
[PATCH 2/3] gnu: Add r-future-callr
(address . 62579@debbugs.gnu.org)
1493a333b0fb7ac47df2c273a47f3d77195145dc.1680324055.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e8ec429e1..d2036b0629 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19309,6 +19309,37 @@ (define-public r-future-apply
machine or distributed on a compute cluster.")
(license license:gpl2+)))
+(define-public r-future-callr
+ (package
+ (name "r-future-callr")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "future.callr" version))
+ (sha256
+ (base32
+ "1w7wq2nrvj65a25nsb5h99258p9565qwnlvcc07nyc21gm5zrg9k"))))
+ (properties `((upstream-name . "future.callr")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list r-callr r-future))
+ (native-inputs (list r-r-rsp))
+ (home-page "https://future.callr.futureverse.org")
+ (synopsis "Future API for Parallel Processing using 'callr'")
+ (description
+ "Implementation of the Future API on top of the callr package. This allows you
+to process futures, as defined by the future package, in parallel out of the
+box, on your local (Linux, macOS, Windows, ...) machine. Contrary to backends
+relying on the parallel package (e.g. future::multisession') and socket
+connections, the callr backend provided here can run more than 125 parallel R
+processes.")
+ (license license:lgpl2.1+)))
+
(define-public r-rsvd
(package
(name "r-rsvd")
--
2.39.2
kyle wrote 2 years ago
[PATCH 3/3] gnu: Add r-tarchetypes
(address . 62579@debbugs.gnu.org)
f03956aebaedf052f7d43f3ab4cc8a4ad246914a.1680324055.git.kyle@posteo.net
From: Kyle Andrews <kyle@posteo.net>

---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d2036b0629..56dcf705db 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14456,6 +14456,43 @@ (define-public r-tab
handle data from simple random samples as well as complex surveys.")
(license license:gpl3+)))
+
+(define-public r-tarchetypes
+ (package
+ (name "r-tarchetypes")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tarchetypes" version))
+ (sha256
+ (base32
+ "05yhq8xnrpk37x7fq0yjw4m527ji28s16dskfmljrbrzb064nw2g"))))
+ (properties `((upstream-name . "tarchetypes")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-digest
+ r-dplyr
+ r-fs
+ r-furrr
+ r-future
+ r-future-callr
+ r-rlang
+ r-targets
+ r-tibble
+ r-tidyselect
+ r-vctrs
+ r-withr))
+ (home-page "https://docs.ropensci.org/tarchetypes/")
+ (synopsis "Archetypes for Targets")
+ (description
+ "Function-oriented Make-like declarative pipelines for Statistics and data
+science are supported in the targets R package. As an extension to targets',
+the tarchetypes package provides convenient user-side functions to make targets
+easier to use. By establishing reusable archetypes for common kinds of targets
+and pipelines, these functions help express complicated reproducible pipelines
+concisely and compactly. The methods in this package were influenced by the
+drake R package by Will Landau (2018) <doi:10.21105/joss.00550>.")
+ (license license:expat)))
+
(define-public r-targets
(package
(name "r-targets")
--
2.39.2
Ricardo Wurmus wrote 2 years ago
Re: [PATCH 1/3] gnu: Add r-targets package
(name . kyle)(address . kyle@posteo.net)(address . 62579-done@debbugs.gnu.org)
87jzyra698.fsf@elephly.net
Hi Kyle,

thank you for the patches! I applied them with the commits ending with
4d313b918ec6d2ed05dd16030a860c162e63d8a0.

I slightly adjusted descriptions and indentation (each of the patches
had tabs on the hash line) and added r-markdown where the vignette
builder needed it.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62579@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62579
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help