[PATCH] gnu: Add python-pyoo.

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 31 Mar 2023 12:09
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20230331100913.4046-1-ngraves@ngraves.fr
* gnu/packages/libreoffice.scm (python-pyoo): New variable.
---
gnu/packages/libreoffice.scm | 42 ++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 48689b9342..35074982e4 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1187,3 +1187,45 @@ (define (install-python-script name)
'((release-monitoring-url
. "https://www.libreoffice.org/download/download-libreoffice/")))
(license license:mpl2.0)))
+
+(define-public python-pyoo
+ (package
+ (name "python-pyoo")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyoo" version))
+ (sha256
+ (base32
+ "1bxj24nwrvqra0d18w0lckvm9iw6bvks1fid2b6xrpvfc5xb37ry"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f))
+ (inputs (list libreoffice))
+ (home-page "https://github.com/mila/pyoo")
+ (synopsis "Pythonic interface to Apache OpenOffice API (UNO)")
+ (description "PyOO allows you to control a running OpenOffice or
+LibreOffice program for reading and writing spreadsheet documents. The
+library can be used for generating documents in various formats.
+
+The main advantage of the PyOO library is that it can use almost any
+functionality implemented in OpenOffice / LibreOffice applications. On the
+other hand it needs a running process of a office suite application which is
+significant overhead. It uses the UNO standard interface to a running
+OpenOffice or LibreOffice application.
+
+PyOO wraps a robust Python-UNO bridge to simple and Pythonic interface.
+
+Available features:
+@itemize
+@item Opening and creation of spreadsheet documents
+@item Saving documents to all formats available in OpenOffice
+@item Charts and diagrams
+@item Sheet access and manipulation
+@item Formulas
+@item Cell merging
+@item Number, text, date, and time values
+@item Cell and text formating
+@item Number formating
+@item Locales
+@end itemize")
+ (license license:expat)))
--
2.39.2
L
L
Ludovic Courtès wrote on 18 Jun 2023 23:10
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 62568@debbugs.gnu.org)
87bkhcpjcx.fsf@gnu.org
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (2 lines)
> * gnu/packages/libreoffice.scm (python-pyoo): New variable.

This is failing according to https://qa.guix.gnu.org/issue/62568.

Could you take a look?

Thanks,
Ludo’.
?