[PATCH core-updates 0/6] Various fixes to packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Josselin Poiret
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 30 Mar 2023 23:44
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
cover.1680212316.git.dev@jpoiret.xyz
Hi everyone,

Here are some odds and ends for core-updates. The first three commits should
fix udiskie not building, and probably some other packages! Before this patch,
atk in gtk would conflict with the atk included by at-spi2-core (the newer one),
and sometimes would get precedence. This was because the merge of atk,
at-spi2-core and at-spi2-atk wasn't complete, only the last two were taken care
of. One thing I'm unsure about is giving the newer at-spi2-core as an input to
gtk+-2, but it seemed to build fine. Haven't tested it yet though.

The first gpgme patch lets its dependents build: flatpak wasn't able to pick it
up through pkg-config without, but now fails to build for another reason on my
end (something that's not reproducible unless you have less than 3% free
space!). The second one is just clean-up, since we now have 1.18 as the main
version.

One of zsh's tests was failing because the deprecation warning of egrep was
being added to some output, I replaced only that one with grep -E, upstream has
a more comprehensive patch that only applies to HEAD.

Best,

Josselin Poiret (6):
gnu: Replace all uses of atk by at-spi2-core.
gnu: atkmm: Update to 2.36.2.
gnu: atk: Deprecate in favor of at-spi2-core.
gnu: gpgme: Propagate libassuan.
gnu: Remove gpgme-1.18 and qgpgme-1.18.
gnu: zsh: Patch failing test that uses egrep.

gnu/local.mk | 3 +-
gnu/packages/animation.scm | 2 +-
gnu/packages/chromium.scm | 1 -
gnu/packages/crates-gtk.scm | 8 +--
gnu/packages/gimp.scm | 2 +-
gnu/packages/gnome.scm | 14 ++---
gnu/packages/gnupg.scm | 29 +----------
gnu/packages/graphviz.scm | 2 +-
gnu/packages/gtk.scm | 51 ++++---------------
gnu/packages/kde-pim.scm | 8 +--
gnu/packages/mate.scm | 14 ++---
gnu/packages/messaging.scm | 2 +-
.../patches/zsh-egrep-failing-test.patch | 11 ++++
gnu/packages/qt.scm | 2 +-
gnu/packages/rust-apps.scm | 2 +-
gnu/packages/shells.scm | 3 +-
gnu/packages/vim.scm | 2 +-
gnu/packages/vnc.scm | 2 +-
gnu/packages/web.scm | 2 +-
19 files changed, 57 insertions(+), 103 deletions(-)
create mode 100644 gnu/packages/patches/zsh-egrep-failing-test.patch


base-commit: cdba566261428d8949fcc4f7c7066a578e3009eb
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 2/6] gnu: atkmm: Update to 2.36.2.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
e5ad7f473cfd7a6c51c435e8aa1b09e2cb2fd36c.1680212316.git.dev@jpoiret.xyz
* gnu/packages/gtk.scm (atkmm): Update it.
---
gnu/packages/gtk.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a19c9c372b..48e78146aa 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1760,7 +1760,7 @@ (define-public pangomm-2.46
(define-public atkmm
(package
(name "atkmm")
- (version "2.36.0")
+ (version "2.36.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1768,7 +1768,7 @@ (define-public atkmm
name "-" version ".tar.xz"))
(sha256
(base32
- "0wwr0663jrqx2klsasffd9wpk3kqnwisj1y3ahdkjdk5hzrsjgy9"))))
+ "0yg0v8f0xms2cfj1r9q6yrl4757wrivpb4q56rbmx626yycxsqkg"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 1/6] gnu: Replace all uses of atk by at-spi2-core.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
be0e8089ce803be90cada2cd03569be44384d3cf.1680212316.git.dev@jpoiret.xyz
* gnu/packages/animation.scm (gnash)
* gnu/packages/chromium.scm (ungoogled-chromium)
* gnu/packages/crates-gtk.scm (rust-atk-sys-0.14,
rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14)
* gnu/packages/gimp.scm (gimp)
* gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex):
* gnu/packages/graphviz.scm (xdot)
* gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm)
* gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc,
mate-utils, eom, pluma)
* gnu/packages/messaging.scm (dino)
* gnu/packages/qt.scm (qtwebengine-5)
* gnu/packages/rust-apps.scm (alfis)
* gnu/packages/vim.scm (vim-full)
* gnu/packages/vnc.scm (remmina)
* gnu/packages/web.scm (castor): Replace atk by at-spi2-core.
---
gnu/packages/animation.scm | 2 +-
gnu/packages/chromium.scm | 1 -
gnu/packages/crates-gtk.scm | 8 ++++----
gnu/packages/gimp.scm | 2 +-
gnu/packages/gnome.scm | 14 +++++++-------
gnu/packages/graphviz.scm | 2 +-
gnu/packages/gtk.scm | 9 ++++-----
gnu/packages/mate.scm | 14 +++++++-------
gnu/packages/messaging.scm | 2 +-
gnu/packages/qt.scm | 2 +-
gnu/packages/rust-apps.scm | 2 +-
gnu/packages/vim.scm | 2 +-
gnu/packages/vnc.scm | 2 +-
gnu/packages/web.scm | 2 +-
14 files changed, 31 insertions(+), 33 deletions(-)

Toggle diff (346 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 33fc3fcce9..4c03b78717 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -260,7 +260,7 @@ (define-public gnash
("python" ,python-wrapper)))
(inputs
`(("agg" ,agg)
- ("atk" ,atk)
+ ("at-spi2-core" ,at-spi2-core)
("boost" ,boost)
("curl" ,curl)
("ffmpeg" ,ffmpeg-2.8)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 47153e3531..22e22cdbf8 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -898,7 +898,6 @@ (define-public ungoogled-chromium
wayland))
(inputs
(list alsa-lib
- atk
at-spi2-core
cups
curl
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 403c1f2aef..1c99c87bb6 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -60,7 +60,7 @@ (define-public rust-atk-sys-0.14
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs (list pkg-config))
(inputs
- (list atk glib))
+ (list at-spi2-core glib))
(home-page "https://gtk-rs.org/")
(synopsis "FFI bindings to libatk-1")
(description "FFI bindings to libatk-1")
@@ -90,7 +90,7 @@ (define-public rust-atk-sys-0.10
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs (list pkg-config))
(inputs
- (list atk glib))))
+ (list at-spi2-core glib))))
(define-public rust-atk-sys-0.9
(package
@@ -138,7 +138,7 @@ (define-public rust-atk-0.14
#:cargo-development-inputs
(("rust-gir-format-check" ,rust-gir-format-check-0.1))))
(inputs
- (list atk glib))
+ (list at-spi2-core glib))
(home-page "https://gtk-rs.org/")
(synopsis "Rust bindings for the ATK library")
(description "Rust bindings for the ATK library")
@@ -1469,7 +1469,7 @@ (define-public rust-gtk-0.14
(("rust-gir-format-check" ,rust-gir-format-check-0.1))))
(native-inputs (list pkg-config))
(inputs
- (list atk cairo glib gtk+ pango))
+ (list at-spi2-core cairo glib gtk+ pango))
(home-page "https://gtk-rs.org/")
(synopsis "Rust bindings for the GTK+ 3 library")
(description "This package provides Rust bindings for the GTK+ 3 library.")
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index af5adb8bfd..73102e30cf 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -333,7 +333,7 @@ (define-public gimp
;; ./configure requests not to annoy upstream with packaging bugs.
"--with-bug-report-url=https://bugs.gnu.org/guix")))
(inputs
- (list atk
+ (list at-spi2-core
babl
gegl
gexiv2
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e2ee396819..e81882b181 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2704,7 +2704,7 @@ (define-public evince
libgnome-keyring
adwaita-icon-theme
gdk-pixbuf
- atk
+ at-spi2-core
pango
gtk+
glib
@@ -3299,7 +3299,7 @@ (define-public glade3
'())
(list gtk+ libxml2)))
(native-inputs
- (list atk ;for tests
+ (list at-spi2-core ;for tests
docbook-xml-4.2
docbook-xsl
gettext-minimal
@@ -6357,7 +6357,7 @@ (define-public clutter
libxslt
pkg-config))
(propagated-inputs
- (list atk
+ (list at-spi2-core
cairo
cogl
glib
@@ -6744,7 +6744,7 @@ (define-public totem
(inputs
(list gtk+
gdk-pixbuf
- atk
+ at-spi2-core
cairo
dbus-glib
xorgproto
@@ -6866,7 +6866,7 @@ (define-public rhythmbox
;;clutter-gtk
;;clutter-gst
(list adwaita-icon-theme
- atk
+ at-spi2-core
bash-minimal
brasero
json-glib
@@ -8021,7 +8021,7 @@ (define-public mutter
(list gsettings-desktop-schemas-next ;required by libmutter.pc
gtk+ ;required by libmutter.pc
;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
- atk
+ at-spi2-core
cairo
eudev
gdk-pixbuf
@@ -11646,7 +11646,7 @@ (define-public ghex
pkg-config
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
gtk))
(synopsis "GNOME hexadecimal editor")
(description "The GHex program can view and edit files in two ways:
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index aa3cee6e5b..d98041d73a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -346,7 +346,7 @@ (define-public xdot
`("PATH" ":" prefix
(,(dirname (search-input-file inputs "bin/dot"))))))))))
(inputs
- (list atk
+ (list at-spi2-core
(librsvg-for-system)
harfbuzz
graphviz
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 65854e0ba0..a19c9c372b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -934,7 +934,7 @@ (define-public gtk+-2
(build-system gnu-build-system)
(outputs '("out" "bin" "doc" "debug"))
(propagated-inputs
- (list atk
+ (list at-spi2-core
cairo
glib
(librsvg-for-system)
@@ -1030,8 +1030,7 @@ (define-public gtk+
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(propagated-inputs
- (list atk
- at-spi2-core
+ (list at-spi2-core
cairo
fribidi
fontconfig
@@ -1587,7 +1586,7 @@ (define-public guile-gnome
(build-system gnu-build-system)
(native-inputs
(list pkg-config
- atk
+ at-spi2-core
;;("corba" ,corba) ; not packaged yet
gconf
gobject-introspection
@@ -1797,7 +1796,7 @@ (define-public atkmm
("python" ,python)
("xsltproc" ,libxslt)))
(propagated-inputs
- (list glibmm atk))
+ (list glibmm at-spi2-core))
(synopsis "C++ bindings for ATK")
(description "ATKmm is the C++ binding for the ATK library.")
(home-page "https://wiki.gnome.org/Accessibility")
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 2f38946fe1..4874aaf7f9 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -521,7 +521,7 @@ (define-public mate-applets
docbook-xml
gobject-introspection))
(inputs
- (list atk
+ (list at-spi2-core
dbus
dbus-glib
glib
@@ -732,7 +732,7 @@ (define-public atril
("xmllint" ,libxml2)
("zlib" ,zlib)))
(inputs
- `(("atk" ,atk)
+ `(("at-spi2-core" ,at-spi2-core)
("cairo" ,cairo)
("caja" ,caja)
("dconf" ,dconf)
@@ -921,7 +921,7 @@ (define-public mate-control-center
xmodmap
gobject-introspection))
(inputs
- `(("atk" ,atk)
+ `(("at-spi2-core" ,at-spi2-core)
("cairo" ,cairo)
("caja" ,caja)
("dconf" ,dconf)
@@ -1061,7 +1061,7 @@ (define-public mate-calc
(native-inputs
(list gettext-minimal intltool pkg-config yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
glib
gtk+
libxml2
@@ -1228,7 +1228,7 @@ (define-public mate-utils
xorgproto
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
cairo
glib
gtk+
@@ -1277,7 +1277,7 @@ (define-public eom
pkg-config
yelp-tools))
(inputs
- (list atk
+ (list at-spi2-core
cairo
dconf
dbus
@@ -1382,7 +1382,7 @@ (define-public pluma
("pkg-config" ,pkg-config)
("yelp-tools" ,yelp-tools)))
(inputs
- (list atk
+ (list at-spi2-core
cairo
enchant-1.6
glib
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bbd1743cac..1cef8d4811 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1373,7 +1373,7 @@ (define-public dino
vala))
(inputs
(list adwaita-icon-theme
- atk
+ at-spi2-core
bash-minimal
cairo
librsvg
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0208312bd5..407ae1dd5d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2640,7 +2640,7 @@ (define-public qtwebengine-5
ruby))
(inputs
(list alsa-lib
- atk
+ at-spi2-core
cups-minimal
curl
dbus
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index b8cb06af64..5ec82009af 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -177,7 +177,7 @@ (define-public alfis
(native-inputs
(list pkg-config))
(inputs
- (list atk
+ (list at-spi2-core
gtk
glib
pango
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6baf10915a..d555194d0b 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -243,7 +243,7 @@ (define-public vim-full
(prepend pkg-config xorg-server-for-tests)))
(inputs
`(("acl" ,acl)
- ("atk" ,atk)
+ ("at-spi2-core" ,at-spi2-core)
("attr" ,attr)
("cairo" ,cairo)
("fontconfig" ,fontconfig)
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index fc272ae621..37c9ae0619 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -123,7 +123,7 @@ (define-public remmina
pkg-config))
(inputs
(list libappindicator
- atk
+ at-spi2-core
avahi
cairo
cups
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b1d6e8768b..24f5021889 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6628,7 +6628,7 @@ (define-public castor
(native-inputs
(list pkg-config))
(inputs
- (list atk
+ (list at-spi2-core
cairo
gdk-pixbuf
gtk+
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 3/6] gnu: atk: Deprecate in favor of at-spi2-core.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
2036141189dd221b780af10a59888e27e0fe6dc7.1680212316.git.dev@jpoiret.xyz
* gnu/packages/gtk.scm (atk): Deprecate.
---
gnu/packages/gtk.scm | 38 +++-----------------------------------
1 file changed, 3 insertions(+), 35 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 48e78146aa..93dad032cd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -158,41 +158,6 @@ (define-public appmenu-gtk-module
(home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
(license (list license:lgpl3))))
-(define-public atk
- (package
- (name "atk")
- (version "2.36.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1217cmmykjgkkim0zr1lv5j13733m4w5vipmy4ivw0ll6rz28xpv"))))
- (build-system meson-build-system)
- (arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- ,@(if (%current-target-system)
- `(#:configure-flags
- ;; introspection requires running binaries for the host system
- ;; on the build system.
- '("-Dintrospection=false"))
- '())))
- (propagated-inputs (list glib)) ; required by atk.pc
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ; glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
- ("pkg-config" ,pkg-config)))
- (synopsis "GNOME accessibility toolkit")
- (description
- "ATK provides the set of accessibility interfaces that are implemented
-by other toolkits and applications. Using the ATK interfaces, accessibility
-tools have full access to view and control running applications.")
- (license license:lgpl2.1+)
- (home-page "https://wiki.gnome.org/Accessibility")))
-
(define-public cairo
(package
(name "cairo")
@@ -915,6 +880,9 @@ (define-public at-spi2-core-with-documentation
(define-public at-spi2-atk
(deprecated-package "at-spi2-atk" at-spi2-core))
+(define-public atk
+ (deprecated-package "atk" at-spi2-core))
+
(define-public gtk+-2
(package
(name "gtk+")
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 4/6] gnu: gpgme: Propagate libassuan.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
4c67fee4b6635440e3a43f8bf1cd6ea2a472b2e4.1680212316.git.dev@jpoiret.xyz
* gnu/packages/gnupg.scm (gpgme): Propagate libassuan.
---
gnu/packages/gnupg.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 9b00338178..42013f1b94 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -398,10 +398,8 @@ (define-public gpgme
(native-inputs
(list gnupg))
(propagated-inputs
- ;; Needs to be propagated because gpgme.h includes gpg-error.h.
- (list libgpg-error))
- (inputs
- (list libassuan))
+ ;; As required by the pkg-config's Requires.private.
+ (list libgpg-error libassuan))
(home-page "https://www.gnupg.org/related_software/gpgme/")
(synopsis "Library providing simplified access to GnuPG functionality")
(description
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 5/6] gnu: Remove gpgme-1.18 and qgpgme-1.18.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
d7db00f985dba8634fe00cb5d02d31dee4813e39.1680212316.git.dev@jpoiret.xyz
* gnu/packages/gnupg.scm (gpgme-1.18, qgpgme-1.18): Remove.
* gnu/packages/kde-pim.sm (kleopatra, kmail): Refer to gpgme and qgpgme instead.
---
gnu/packages/gnupg.scm | 23 -----------------------
gnu/packages/kde-pim.scm | 8 ++++----
2 files changed, 4 insertions(+), 27 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 42013f1b94..49d29ed9bd 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -416,19 +416,6 @@ (define-public gpgme
(properties '((ftp-server . "ftp.gnupg.org")
(ftp-directory . "/gcrypt/gpgme")))))
-;; TODO: Merge with gpgme in the next rebuild cycle.
-(define-public gpgme-1.18
- (package
- (inherit gpgme)
- (version "1.18.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnupg/gpgme/gpgme-"
- version ".tar.bz2"))
- (sha256
- (base32
- "17hfigfnq6xz45b5xrp299f68b5mwx0aysd51sx5v4nf8yp4w79n"))))))
-
(define-public qgpgme
(package
(inherit gpgme)
@@ -457,16 +444,6 @@ (define-public qgpgme
gpgpme starting with version 1.7.")
(license license:gpl2+))) ;; Note: this differs from gpgme
-;; TODO: Merge with qgpgme in the next rebuild cycle.
-(define-public qgpgme-1.18
- (package
- (inherit qgpgme)
- (version (package-version gpgme-1.18))
- (source (package-source gpgme-1.18))
- (inputs
- (modify-inputs (package-inputs qgpgme)
- (replace "gpgme" gpgme-1.18)))))
-
(define-public guile-gcrypt
(package
(name "guile-gcrypt")
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 19066fd289..6f3cbf2999 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1139,7 +1139,7 @@ (define-public kleopatra
kdoctools))
(inputs
(list boost
- gpgme-1.18
+ gpgme
kcmutils
kcodecs
kconfig
@@ -1159,7 +1159,7 @@ (define-public kleopatra
libassuan
libkleo
breeze-icons ;; default icon set
- qgpgme-1.18
+ qgpgme
qtbase-5))
(arguments
`(#:phases
@@ -1196,7 +1196,7 @@ (define-public kmail
akonadi-mime
akonadi-search
boost
- gpgme-1.18
+ gpgme
grantlee
grantleetheme
kbookmarks
@@ -1243,7 +1243,7 @@ (define-public kmail
libkleo
libksieve
breeze-icons ; default icon set, required for tests
- qgpgme-1.18
+ qgpgme
qtbase-5
qtdeclarative-5
qtkeychain
--
2.39.2
J
J
Josselin Poiret wrote on 30 Mar 2023 23:48
[PATCH core-updates 6/6] gnu: zsh: Patch failing test that uses egrep.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553@debbugs.gnu.org)
fa4d0810e13159c65aec90b5e7ec8d7506abc5a5.1680212316.git.dev@jpoiret.xyz
* gnu/packages/patches/zsh-egrep-failing-test.patch: New file.
* gnu/packages/shells.scm (zsh): Patch it.
* gnu/local.mk (dist_patch_DATA): Register it.
---
gnu/local.mk | 3 ++-
gnu/packages/patches/zsh-egrep-failing-test.patch | 11 +++++++++++
gnu/packages/shells.scm | 3 ++-
3 files changed, 15 insertions(+), 2 deletions(-)
create mode 100644 gnu/packages/patches/zsh-egrep-failing-test.patch

Toggle diff (47 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 58437b7a0e..21f0993a3f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2040,7 +2040,8 @@ dist_patch_DATA = \
%D%/packages/patches/xterm-370-explicit-xcursor.patch \
%D%/packages/patches/xygrib-fix-finding-data.patch \
%D%/packages/patches/yggdrasil-extra-config.patch \
- %D%/packages/patches/zig-use-system-paths.patch
+ %D%/packages/patches/zig-use-system-paths.patch \
+ %D%/packages/patches/zsh-egrep-failing-test.patch
MISC_DISTRO_FILES = \
%D%/packages/ld-wrapper.in
diff --git a/gnu/packages/patches/zsh-egrep-failing-test.patch b/gnu/packages/patches/zsh-egrep-failing-test.patch
new file mode 100644
index 0000000000..10828ca6bb
--- /dev/null
+++ b/gnu/packages/patches/zsh-egrep-failing-test.patch
@@ -0,0 +1,11 @@
+--- a/Test/E01options.ztst 2023-03-30 21:34:12.372309112 +0200
++++ b/Test/E01options.ztst 2023-03-30 21:34:33.212335339 +0200
+@@ -649,7 +649,7 @@
+ >noktarg1
+ >0 1
+
+- showopt() { setopt | egrep 'localoptions|ksharrays'; }
++ showopt() { setopt | grep -E 'localoptions|ksharrays'; }
+ f1() { setopt localoptions ksharrays; showopt }
+ f2() { setopt ksharrays; showopt }
+ setopt kshoptionprint
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5ca8d842c2..26cbbe67dd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -467,7 +467,8 @@ (define-public zsh
".tar.xz")))
(sha256
(base32
- "06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))))
+ "06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))
+ (patches (search-patches "zsh-egrep-failing-test.patch"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags
`("--with-tcsetpgrp"
--
2.39.2
G
G
Guillaume Le Vaillant wrote on 31 Mar 2023 16:57
Re: [bug#62553] [PATCH core-updates 0/6] Various fixes to packages
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62553-done@debbugs.gnu.org)
87wn2xge79.fsf@kitej
Patches pushed as c000352c27f511dfb5569bef09f9b774d6100117 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZCb1Gg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8TGgD+PpR1M6g2JcRk5pX/7JXPEIUXjPJyKzgAoktK
NSI5lu0BAJYWnxgBg7JklZnk6XNTf24fYJom4v6rvyShiz1GADov
=rd9Y
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62553@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62553
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch