John Kehayias wrote 2 years ago
(address . guix-patches@gnu.org)
Here's a simple package to add texlive-nth. It came from the texlive importer, slight formatting change, checked with guix lint. It builds and does what it is supposed to in a tex file I needed it for.
Thanks!
John
From f7ba0e021b1cd61422a41b3bad01e79ff1db2aab Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 29 Mar 2023 15:57:31 -0400
Subject: [PATCH] gnu: Add texlive-nth.
* gnu/packages/tex.scm (texlive-nth): New variable.
---
gnu/packages/tex.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 087043b06c..60b1892d29 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11354,6 +11355,24 @@ (define-public texlive-xindy
terms and in terms of the collating order of the text being processed.")
(license license:gpl2+)))
+(define-public texlive-nth
+ (package
+ (inherit (simple-texlive-package
+ "texlive-nth"
+ (list "tex/generic/nth/")
+ (base32
+ "0716sd99xjdkplm7jdmg4lx8lpfnnx6mxjp1l1sp2bfqcg73p4hm")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/generic/misc/nth.sty")
+ (synopsis "Generate English ordinal numbers")
+ (description
+ "The command @code{\\nth{<number>}} generates English ordinal numbers of
+the form 1st, 2nd, 3rd, 4th, etc. LaTeX package options may specify that the
+ordinal mark be superscripted, and that negative numbers may be treated; Plain
+TeX users have no access to package options, so need to redefine macros for
+these changes.")
+ (license license:public-domain)))
+
(define-public texlive-fmtcount
(package
(inherit (simple-texlive-package
--
2.39.2