[PATCH] gnu: Add emacs-gptel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Rostislav Svoboda
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal
R
R
Rostislav Svoboda wrote on 29 Mar 2023 14:42
(address . guix-patches@gnu.org)(name . Rostislav Svoboda)(address . Rostislav.Svoboda@gmail.com)
20230329124220.7210-1-Rostislav.Svoboda@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-gptel): New variable.
---
gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index da2856abc8..d5db2ea499 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -418,6 +418,44 @@ (define-public emacs-geiser
e.g. emacs-geiser-guile for Guile.")
(license license:bsd-3)))
+(define-public emacs-gptel
+ (let ((commit "1c07a94e18a914ae69ea0061f81fda4bba29afd5")
+ (revision "0"))
+ (package
+ (name "emacs-gptel")
+ (version (git-version "0.2.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/gptel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "190nrxf6nqmfrsza3vyc51f02hw10wzydi45phkswydjkgsllkmp"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'substitute-gptel-use-curl
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "gptel.el"
+ ("gptel-use-curl" (search-input-file
+ inputs
+ "/bin/curl"))))))))
+ (inputs (list curl))
+ (propagated-inputs (list emacs-map))
+ (home-page "https://github.com/karthink/gptel")
+ (synopsis "GPTel is a simple ChatGPT client for Emacs")
+ (description
+ "GPTel is a simple, no-frills ChatGPT asynchronous client for Emacs
+with no external dependencies. It can interact with ChatGPT from any Emacs
+buffer with ChatGPT responses encoded in Markdown or Org markup. It supports
+conversations, not just one-off queries and multiple independent sessions.
+Requires an OpenAI API key.")
+ (license license:gpl3+))))
+
(define-public emacs-geiser-guile
(package
(name "emacs-geiser-guile")
--
2.39.2
N
N
Nicolas Goaziou wrote on 8 Apr 2023 14:08
(name . Rostislav Svoboda)(address . rostislav.svoboda@gmail.com)(address . 62519-done@debbugs.gnu.org)
87r0sulgpa.fsf@nicolasgoaziou.fr
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-gptel): New variable.

I updated the package to 0.3.0, fixed Curl setting, and applied your
patch. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62519@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62519
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch