[PATCH] gnu: gnucash: Update to 5.0

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • Leo Famulari
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 29 Mar 2023 08:49
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230329064901.13800-1-atai@atai.org
* gnu/packages/gnucash.scm (gnucash): Update to 5.0
---
gnu/packages/gnucash.scm | 31 ++++++++++++++++++-------------
1 file changed, 18 insertions(+), 13 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0386910ce6..dde21aa43d 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -47,6 +47,7 @@ (define-module (gnu packages gnucash)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -64,14 +65,24 @@ (define-public gnucash
;; directory.
(package
(name "gnucash")
- (version "4.11")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-" version ".tar.bz2"))
(sha256
- (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
+ (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; test test-gnc-quotes neeeds perl JSON::Parse
+ ;; not packaged in Guix yet
+ '(begin
+ (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
+ (("gnc_add_test\\(test-gnc-quotes")
+ "#gnc_add_test\\(test-gnc-quotes"))
+ #t))))
+
(outputs '("out" "doc" "debug" "python"))
(build-system cmake-build-system)
(arguments
@@ -95,12 +106,6 @@ (define-public gnucash
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "gnucash/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _
@@ -155,9 +160,7 @@ (define-public gnucash
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
'("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
+ "gnc-fq-update"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -217,7 +220,7 @@ (define gnucash-docs
"mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
- (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
+ (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
(build-system cmake-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
@@ -226,9 +229,11 @@ (define gnucash-docs
;; XML during the tests.
(list docbook-xml
docbook-xsl
+ libsecret
libxml2
libxslt
- scrollkeeper))
+ scrollkeeper
+ texinfo))
(arguments
`(#:tests? #f)) ;no test target
(home-page "https://www.gnucash.org/")

base-commit: c9af27d4ca733b20f09019f1465d3e5fdc1ec724
--
2.39.2
M
M
Maxim Cournoyer wrote on 29 Mar 2023 20:44
(name . Andy Tai)(address . atai@atai.org)(address . 62514@debbugs.gnu.org)
877cuz2y9d.fsf@gmail.com
Hello!

Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/gnucash.scm (gnucash): Update to 5.0

Please expound commit message according to the GNU ChangeLog style;
refer to oher commits or 'info (standards) Change Logs' for more information.

Toggle quote (40 lines)
> ---
> gnu/packages/gnucash.scm | 31 ++++++++++++++++++-------------
> 1 file changed, 18 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
> index 0386910ce6..dde21aa43d 100644
> --- a/gnu/packages/gnucash.scm
> +++ b/gnu/packages/gnucash.scm
> @@ -47,6 +47,7 @@ (define-module (gnu packages gnucash)
> #:use-module (gnu packages pkg-config)
> #:use-module (gnu packages python)
> #:use-module (gnu packages swig)
> + #:use-module (gnu packages texinfo)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages web)
> #:use-module (gnu packages webkit)
> @@ -64,14 +65,24 @@ (define-public gnucash
> ;; directory.
> (package
> (name "gnucash")
> - (version "4.11")
> + (version "5.0")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
> version "/gnucash-" version ".tar.bz2"))
> (sha256
> - (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
> + (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))
> + (modules '((guix build utils)))
> + (snippet
> + ;; test test-gnc-quotes neeeds perl JSON::Parse
> + ;; not packaged in Guix yet
> + '(begin
> + (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
> + (("gnc_add_test\\(test-gnc-quotes")
> + "#gnc_add_test\\(test-gnc-quotes"))
> + #t))))

This should be done in a phase instead; note that returning #t is no
longer needed :-).

Toggle quote (14 lines)
> (outputs '("out" "doc" "debug" "python"))
> (build-system cmake-build-system)
> (arguments
> @@ -95,12 +106,6 @@ (define-public gnucash
> (substitute* "CMakeLists.txt"
> (("set\\(SHELL /bin/bash\\)")
> (string-append "set(SHELL " (which "bash") ")")))))
> - ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
> - ;; execute them with perl, so execute them directly instead.
> - (add-after 'unpack 'fix-finance-quote-check
> - (lambda _
> - (substitute* "gnucash/price-quotes.scm"
> - (("\"perl\" \"-w\" ") ""))))

Why is this no longer needed?

Toggle quote (12 lines)
> ;; The qof test requires the en_US, en_GB, and fr_FR locales.
> (add-before 'check 'install-locales
> (lambda _
> @@ -155,9 +160,7 @@ (define-public gnucash
> (assoc l (package-inputs this-package)))
> '("perl-finance-quote")))))))))
> '("gnucash"
> - "gnc-fq-check"
> - "gnc-fq-helper"
> - "gnc-fq-dump"))))
> + "gnc-fq-update"))))
>
Why is this done?

Toggle quote (23 lines)
> (add-after 'install 'glib-or-gtk-compile-schemas
> (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
> (add-after 'install 'glib-or-gtk-wrap
> @@ -217,7 +220,7 @@ (define gnucash-docs
> "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
> version "/gnucash-docs-" version revision ".tar.gz"))
> (sha256
> - (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
> + (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
> (build-system cmake-build-system)
> ;; These are native-inputs because they are only required for building the
> ;; documentation.
> @@ -226,9 +229,11 @@ (define gnucash-docs
> ;; XML during the tests.
> (list docbook-xml
> docbook-xsl
> + libsecret
> libxml2
> libxslt
> - scrollkeeper))
> + scrollkeeper
> + texinfo))

Is there a Texinfo manual for Gnucash? That'd be neat.

--
Thanks,
Maxim
A
A
Andy Tai wrote on 4 Apr 2023 03:45
Re: [PATCH] gnu: gnucash: Update to 5.0
(address . 62514@debbugs.gnu.org)
CAJsg1E_aP8MhwSWz_DGDaLaFhDs4oFkSYBofNS-biLSPsyXViQ@mail.gmail.com
I will not have time to address this in the next week or so, so feel
free to update the patch in resp. to the comments or if no one come
forward to adores it I will try to get back to this the second half of
April.
C
C
Christopher Baines wrote on 13 Apr 2023 18:33
tag 62514 moreinfo
(address . control@debbugs.gnu.org)
87mt3bhhdk.fsf@cbaines.net
tags 62514 + moreinfo
quit
A
A
Andy Tai wrote on 14 Apr 2023 17:59
[PATCH v2] gnu: gnucash: Update to 5.0
(address . 62514@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230414155929.14547-1-atai@atai.org
* gnu/packages/gnucash.scm (gnucash): Update to 5.0
[source]: Patch out unsupported tests
[arguments]<phase>: Remove references in
patching code to removed source files upstream

* gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0
[native-inputs]: Add texinfo per upstream build doc
---
gnu/packages/gnucash.scm | 31 ++++++++++++++++++-------------
1 file changed, 18 insertions(+), 13 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0386910ce6..dde21aa43d 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -47,6 +47,7 @@ (define-module (gnu packages gnucash)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -64,14 +65,24 @@ (define-public gnucash
;; directory.
(package
(name "gnucash")
- (version "4.11")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-" version ".tar.bz2"))
(sha256
- (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
+ (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; test test-gnc-quotes neeeds perl JSON::Parse
+ ;; not packaged in Guix yet
+ '(begin
+ (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
+ (("gnc_add_test\\(test-gnc-quotes")
+ "#gnc_add_test\\(test-gnc-quotes"))
+ #t))))
+
(outputs '("out" "doc" "debug" "python"))
(build-system cmake-build-system)
(arguments
@@ -95,12 +106,6 @@ (define-public gnucash
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "gnucash/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _
@@ -155,9 +160,7 @@ (define-public gnucash
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
'("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
+ "gnc-fq-update"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -217,7 +220,7 @@ (define gnucash-docs
"mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
- (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
+ (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
(build-system cmake-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
@@ -226,9 +229,11 @@ (define gnucash-docs
;; XML during the tests.
(list docbook-xml
docbook-xsl
+ libsecret
libxml2
libxslt
- scrollkeeper))
+ scrollkeeper
+ texinfo))
(arguments
`(#:tests? #f)) ;no test target
(home-page "https://www.gnucash.org/")

base-commit: fcb9ba2e71ed1e7af1f1c3ee51da639ba9483ec3
--
2.39.2
A
A
Andy Tai wrote on 14 Apr 2023 18:02
(address . control@debbugs.gnu.org)
CAJsg1E_rG5rFiVxwS9GL4N=mUkEeFUtNtWC8+ks8mdLuc_xLtw@mail.gmail.com
tags 62514 - moreinfo
quit
A
A
Andy Tai wrote on 18 Apr 2023 07:17
(address . 62514@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230418051729.12375-1-atai@atai.org
* gnu/packages/gnucash.scm (gnucash): Update to 5.0
[arguments]<phase>: Patch out unsupported tests.
Remove references in patching code to removed source
files upstream

* gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0
[native-inputs]: Add texinfo per upstream build doc
---
gnu/packages/gnucash.scm | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)

Toggle diff (94 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0386910ce6..6fe63f487e 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -47,6 +47,7 @@ (define-module (gnu packages gnucash)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -64,14 +65,14 @@ (define-public gnucash
;; directory.
(package
(name "gnucash")
- (version "4.11")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-" version ".tar.bz2"))
(sha256
- (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
+ (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))))
(outputs '("out" "doc" "debug" "python"))
(build-system cmake-build-system)
(arguments
@@ -87,6 +88,13 @@ (define-public gnucash
(guix build utils))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-unsupported-test
+ ;; test test-gnc-quotes neeeds perl JSON::Parse
+ ;; not packaged in Guix yet
+ (lambda _
+ (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
+ (("gnc_add_test\\(test-gnc-quotes")
+ "#gnc_add_test\\(test-gnc-quotes"))))
(add-after 'unpack 'set-env-vars
(lambda* (#:key inputs #:allow-other-keys)
;; At least one test is time-related and requires this
@@ -95,12 +103,6 @@ (define-public gnucash
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "gnucash/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _
@@ -155,9 +157,7 @@ (define-public gnucash
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
'("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
+ "gnc-fq-update"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -217,7 +217,7 @@ (define gnucash-docs
"mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
- (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
+ (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
(build-system cmake-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
@@ -226,9 +226,11 @@ (define gnucash-docs
;; XML during the tests.
(list docbook-xml
docbook-xsl
+ libsecret
libxml2
libxslt
- scrollkeeper))
+ scrollkeeper
+ texinfo))
(arguments
`(#:tests? #f)) ;no test target
(home-page "https://www.gnucash.org/")

base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
prerequisite-patch-id: 2fe043491619f0182074f836ad7b0c91f725637e
--
2.39.2
A
A
Andy Tai wrote on 18 Apr 2023 07:40
[PATCH v4] gnu: gnucash: Update to 5.0
(address . 62514@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230418054007.29925-1-atai@atai.org
* gnu/packages/gnucash.scm (gnucash): Update to 5.0
[arguments]<phase>: Patch out unsupported tests.
Remove references in patching code to removed source
files upstream

* gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0
---
gnu/packages/gnucash.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0386910ce6..54a7cc0969 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -47,6 +47,7 @@ (define-module (gnu packages gnucash)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -64,14 +65,14 @@ (define-public gnucash
;; directory.
(package
(name "gnucash")
- (version "4.11")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-" version ".tar.bz2"))
(sha256
- (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
+ (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))))
(outputs '("out" "doc" "debug" "python"))
(build-system cmake-build-system)
(arguments
@@ -87,6 +88,13 @@ (define-public gnucash
(guix build utils))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-unsupported-test
+ ;; test test-gnc-quotes neeeds perl JSON::Parse
+ ;; not packaged in Guix yet
+ (lambda _
+ (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
+ (("gnc_add_test\\(test-gnc-quotes")
+ "#gnc_add_test\\(test-gnc-quotes"))))
(add-after 'unpack 'set-env-vars
(lambda* (#:key inputs #:allow-other-keys)
;; At least one test is time-related and requires this
@@ -95,12 +103,6 @@ (define-public gnucash
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "gnucash/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _
@@ -155,9 +157,7 @@ (define-public gnucash
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
'("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
+ "gnc-fq-update"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -217,7 +217,7 @@ (define gnucash-docs
"mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
- (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
+ (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
(build-system cmake-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.

base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
prerequisite-patch-id: 2fe043491619f0182074f836ad7b0c91f725637e
--
2.39.2
A
A
Andy Tai wrote on 18 Apr 2023 07:46
[PATCH v5] gnu: gnucash: Update to 5.0
(address . 62514@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230418054604.30042-1-atai@atai.org
* gnu/packages/gnucash.scm (gnucash): Update to 5.0
[arguments]<phase>: Patch out unsupported tests.
Remove references in patching code to removed source
files upstream

* gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0
---
gnu/packages/gnucash.scm | 23 +++++++++++------------
1 file changed, 11 insertions(+), 12 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0386910ce6..ddc78a655e 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -64,14 +64,14 @@ (define-public gnucash
;; directory.
(package
(name "gnucash")
- (version "4.11")
+ (version "5.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-" version ".tar.bz2"))
(sha256
- (base32 "069b216dkpjs9hp32s4bhi6f76lbc81qvbmjmz0dxq3v1piys57q"))))
+ (base32 "09482f1w4yawrdw5c2wi0jb8hwlp1x9mdvq552bf9n5f66mkphfg"))))
(outputs '("out" "doc" "debug" "python"))
(build-system cmake-build-system)
(arguments
@@ -87,6 +87,13 @@ (define-public gnucash
(guix build utils))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-unsupported-test
+ ;; test test-gnc-quotes neeeds perl JSON::Parse
+ ;; not packaged in Guix yet
+ (lambda _
+ (substitute* "libgnucash/app-utils/test/CMakeLists.txt"
+ (("gnc_add_test\\(test-gnc-quotes")
+ "#gnc_add_test\\(test-gnc-quotes"))))
(add-after 'unpack 'set-env-vars
(lambda* (#:key inputs #:allow-other-keys)
;; At least one test is time-related and requires this
@@ -95,12 +102,6 @@ (define-public gnucash
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
- ;; After wrapping gnc-fq-check and gnc-fq-helper we can no longer
- ;; execute them with perl, so execute them directly instead.
- (add-after 'unpack 'fix-finance-quote-check
- (lambda _
- (substitute* "gnucash/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _
@@ -155,9 +156,7 @@ (define-public gnucash
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
'("gnucash"
- "gnc-fq-check"
- "gnc-fq-helper"
- "gnc-fq-dump"))))
+ "gnc-fq-update"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -217,7 +216,7 @@ (define gnucash-docs
"mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
- (base32 "162qq8p76grczdnsd4qbpxn1d8ap6l2n1a00a601v5hij7rqwfx8"))))
+ (base32 "1cgdb5qrwrx6yf6dsc8zlhi67lbyjs1g82i0n53sw6n6v38dd882"))))
(build-system cmake-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.

base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
prerequisite-patch-id: 2fe043491619f0182074f836ad7b0c91f725637e
--
2.39.2
L
L
Leo Famulari wrote on 23 Apr 2023 17:18
(name . Andy Tai)(address . atai@atai.org)(address . 62514-done@debbugs.gnu.org)
ZEVMXL5d7xklojdl@jasmine.lan
On Mon, Apr 17, 2023 at 10:46:04PM -0700, Andy Tai wrote:
Toggle quote (7 lines)
> * gnu/packages/gnucash.scm (gnucash): Update to 5.0
> [arguments]<phase>: Patch out unsupported tests.
> Remove references in patching code to removed source
> files upstream
>
> * gnu/packages/gnucash.scm (gnucash-doc): Update to 5.0

Thanks! Pushed as 2f18babcd33406d21cc69042c6b0cac42d2c4526
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62514@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62514
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch