[PATCH] gnu: Add avfs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 26 Mar 2023 11:30
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230326093025.18403-1-sarg@sarg.org.ru
* gnu/packages/file-systems.scm (avfs): New variable.
---
gnu/packages/file-systems.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc5bb41fb3..512ed0bdc9 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -260,6 +260,38 @@ (define-public cachefilesd-inotify
@code{dnotify} to monitor file changes.")
(license license:gpl2+)))
+(define-public avfs
+ (package
+ (name "avfs")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/avf/avfs/" version
+ "/avfs-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1kvjaaj2dlps98alpc8rhnzhk4vriw46f3y7b2h0jq2d21j3p7xd"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags ("--enable-library" "--enable-fuse")))
+ (native-inputs (list pkg-config))
+ (inputs (list xz fuse))
+ (synopsis "Virtual filesystem that allows browsing of compressed files")
+ (description
+ "FUSE-based filesystem that allows browsing of compressed files. It provides
+@command{mountavfs} command that starts a small @command{avfsd} daemon. When a
+specially formatted path under @file{~/.avfs} is accessed, the daemon will provide
+listings and content access on the fly. The canonical form of virtual path is:
+[basepath]#handler[options][:parameters][/internalpath]. Example paths:
+@itemize
+@item ~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file
+@item ~/.avfs/#http:localhost|some|path
+@end itemize
+@code{emacs-dired-hacks} has @code{dired-avfs} module which enables seamless
+integration with @code{avfs}.")
+ (home-page "http://avf.sourceforge.net/")
+ (license license:gpl2+)))
+
(define-public davfs2
(package
(name "davfs2")
--
2.39.2
S
S
Sergey Trofimov wrote on 26 Mar 2023 11:39
[PATCH v2] gnu: Add avfs.
(address . 62458@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230326093902.29846-1-sarg@sarg.org.ru
* gnu/packages/file-systems.scm (avfs): New variable.
---
gnu/packages/file-systems.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc5bb41fb3..ec0f7ba44b 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -260,6 +260,38 @@ (define-public cachefilesd-inotify
@code{dnotify} to monitor file changes.")
(license license:gpl2+)))
+(define-public avfs
+ (package
+ (name "avfs")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/avf/avfs/" version
+ "/avfs-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1kvjaaj2dlps98alpc8rhnzhk4vriw46f3y7b2h0jq2d21j3p7xd"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-library" "--enable-fuse")))
+ (native-inputs (list pkg-config))
+ (inputs (list xz fuse))
+ (synopsis "Virtual filesystem that allows browsing of compressed files")
+ (description
+ "FUSE-based filesystem that allows browsing of compressed files. It provides
+@command{mountavfs} command that starts a small @command{avfsd} daemon. When a
+specially formatted path under @file{~/.avfs} is accessed, the daemon will provide
+listings and content access on the fly. The canonical form of virtual path is:
+[basepath]#handler[options][:parameters][/internalpath]. Example paths:
+@itemize
+@item ~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file
+@item ~/.avfs/#http:localhost|some|path
+@end itemize
+@code{emacs-dired-hacks} has @code{dired-avfs} module which enables seamless
+integration with @code{avfs}.")
+ (home-page "http://avf.sourceforge.net/")
+ (license license:gpl2+)))
+
(define-public davfs2
(package
(name "davfs2")
--
2.39.2
L
L
Ludovic Courtès wrote on 6 Apr 2023 16:43
Re: bug#62458: [PATCH] gnu: Add avfs.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62458-done@debbugs.gnu.org)
87ile9jclj.fsf_-_@gnu.org
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

Toggle quote (2 lines)
> * gnu/packages/file-systems.scm (avfs): New variable.

Applied with the cosmetic changes below, thanks!

Ludo’.
Toggle diff (37 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 5ae84ba1d1..d57d407d9c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -276,17 +276,24 @@ (define-public avfs
'(#:configure-flags '("--enable-library" "--enable-fuse")))
(native-inputs (list pkg-config))
(inputs (list xz fuse))
- (synopsis "Virtual filesystem that allows browsing of compressed files")
+ (synopsis "Virtual file system that allows browsing of compressed files")
(description
- "FUSE-based filesystem that allows browsing of compressed files. It provides
-@command{mountavfs} command that starts a small @command{avfsd} daemon. When a
-specially formatted path under @file{~/.avfs} is accessed, the daemon will provide
-listings and content access on the fly. The canonical form of virtual path is:
-[basepath]#handler[options][:parameters][/internalpath]. Example paths:
+ "AVFS is a FUSE-based filesystem that allows browsing of compressed
+files. It provides the @command{mountavfs} command that starts a small
+@command{avfsd} daemon. When a specially formatted path under @file{~/.avfs}
+is accessed, the daemon provides listings and content access on the fly. The
+canonical form of virtual file name is:
+
+@example
+[basepath]#handler[options][:parameters][/internalpath]
+@end example
+
+Example file names:
@itemize
-@item ~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file
-@item ~/.avfs/#http:localhost|some|path
+@item @file{~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file}
+@item @file{~/.avfs/#http:localhost|some|path}
@end itemize
+
@code{emacs-dired-hacks} has @code{dired-avfs} module which enables seamless
integration with @code{avfs}.")
(home-page "http://avf.sourceforge.net/")
Closed
?