[patch] gnu: Add r-ctrialsgov, r-jsonify, r-nodbi, r-ctrdata.

  • Done
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 25 Mar 2023 11:24
(address . guix-patches@gnu.org)
968dbc69-60f7-1d7d-a2f2-9e5b2e2deea1@mdc-berlin.de
* gnu/packages/cran.scm (r-ctrialsgov, r-jsonify, r-nodbi, r-ctrdata):
New variables.
M
M
M?d?lin Ionel Patra?cu wrote on 25 Mar 2023 18:45
[PATCH 3/4] gnu: Add r-nodbi.
(address . 62441@debbugs.gnu.org)
20230325174555.837323-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-nodbi): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 034dd0869a..9b314bae43 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12275,6 +12275,33 @@ (define-public r-sjmisc
tidyverse workflow.")
(license license:gpl3)))
+(define-public r-nodbi
+ (package
+ (name "r-nodbi")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nodbi" version))
+ (sha256
+ (base32 "1hn0wy2ry9l3wwqrshmf82cxigkm16wycwprv458bcvb5k6ayy5m"))))
+ (properties `((upstream-name . "nodbi")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dbi
+ r-jqr
+ r-jsonify
+ r-jsonlite
+ r-stringi
+ r-uuid))
+ (home-page "https://docs.ropensci.org/nodbi/")
+ (synopsis "NoSQL database connector")
+ (description
+ "The nodbi package aims to simplified document database access and
+manipulation, by providing a common API across supported NoSQL databases
+Elasticsearch, CouchDB, MongoDB as well as SQLite/JSON1, PostgreSQL, and DuckDB.")
+ (license license:expat)))
+
(define-public r-nortest
(package
(name "r-nortest")
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 25 Mar 2023 18:45
[PATCH 1/4] gnu: Add r-ctrialsgov.
(address . 62441@debbugs.gnu.org)
20230325174555.837323-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-ctrialsgov): New variable.
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a36c845479..a3590fe9cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -396,6 +396,43 @@ (define-public r-cplm
comparison tool involving zero-inflated and highly skewed distributions.")
(license license:gpl2+)))
+(define-public r-ctrialsgov
+ (package
+ (name "r-ctrialsgov")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ctrialsgov" version))
+ (sha256
+ (base32 "0hdh1fdfaja8amf7fkvk1c6yif703132bvacq0j9pk5jr97czgpw"))))
+ (properties `((upstream-name . "ctrialsgov")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dbi
+ r-dplyr
+ r-ggplot2
+ r-htmlwidgets
+ r-lubridate
+ r-matrix
+ r-plotly
+ r-purrr
+ r-rlang
+ r-stringi
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=ctrialsgov")
+ (synopsis
+ "Query data from U.S. National Library of Medicine's Clinical trials database")
+ (description
+ "The ctrialsgov package implements a series of tools which create and query
+database from the United States National Library of Medicine's Clinical trials
+database @url{https://clinicaltrials.gov/}. Functions provide access a variety
+of techniques for searching the data using range queries, categorical filtering,
+and by searching for full-text keywords. Minimal graphical tools are also
+provided for interactively exploring the constructed data.")
+ (license license:expat)))
+
(define-public r-curry
(package
(name "r-curry")

base-commit: de84b24613afa4020f3f0553dad8e39a78d1f92c
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 25 Mar 2023 18:45
[PATCH 2/4] gnu: Add r-jsonify.
(address . 62441@debbugs.gnu.org)
20230325174555.837323-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-jsonify): New variable.
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3590fe9cd..034dd0869a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3309,6 +3309,27 @@ (define-public r-jsonlite
in systems and applications.")
(license license:expat)))
+(define-public r-jsonify
+ (package
+ (name "r-jsonify")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "jsonify" version))
+ (sha256
+ (base32 "0bxgyj5b1hnijq5315g050giixy4k5mjz2zdx8yil0igb5ifji9p"))))
+ (properties `((upstream-name . "jsonify")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rapidjsonr r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=jsonify")
+ (synopsis "Convert between R objects and Javascript object notation (JSON)")
+ (description
+ "The jsonify package helps with the conversions between R objects and
+@acronym{JSON, Javascript Object Notation} using the rapidjsonr library.")
+ (license license:expat)))
+
(define-public r-servr
(package
(name "r-servr")
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 25 Mar 2023 18:45
[PATCH 4/4] gnu: Add r-ctrdata.
(address . 62441@debbugs.gnu.org)
20230325174555.837323-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-ctrdata): New variable.
---
gnu/packages/cran.scm | 46 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9b314bae43..6e70dd134a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -97,6 +97,7 @@ (define-module (gnu packages cran)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages php)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio) ;libsndfile
#:use-module (gnu packages protobuf)
@@ -396,6 +397,51 @@ (define-public r-cplm
comparison tool involving zero-inflated and highly skewed distributions.")
(license license:gpl2+)))
+(define-public r-ctrdata
+ (package
+ (name "r-ctrdata")
+ (version "1.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ctrdata" version))
+ (sha256
+ (base32 "076v3bll8s6m61wcbwgrgrm34g0wa7gsc90mbwxwap1xfxyzjjsg"))))
+ (properties `((upstream-name . "ctrdata")))
+ (build-system r-build-system)
+ (inputs
+ (list coreutils
+ perl
+ php
+ sed))
+ (propagated-inputs
+ (list r-clipr
+ r-curl
+ r-dplyr
+ r-httr
+ r-jsonlite
+ r-lubridate
+ r-nodbi
+ r-rvest
+ r-stringi
+ r-xml2))
+ (native-inputs (list r-r-rsp))
+ (home-page "https://cran.r-project.org/package=ctrdata")
+ (synopsis "Retrieve and analyze clinical trials in public registers")
+ (description
+ "This package provides a system for querying, retrieving and analyzing
+protocol- and results-related information on clinical trials from three public
+registers, the @acronym{EUCTR, European Union Clinical Trials Register} @url{
+https://www.clinicaltrialsregister.eu/}, @acronym{CTGOV, ClinicalTrials.gov}
+@url{https://clinicaltrials.gov/} and the @acronym{ISRCTN, International Clinical
+Trials Registry Platform} @url{https://www.isrctn.com/}. Trial information is
+downloaded, converted and stored in a database. Functions are included to
+identify deduplicated records, to easily find and extract variables (fields) of
+interest even from complex nesting as used by the registers, and to update
+previous queries. The package can be used for meta-analysis and trend-analysis
+of the design and conduct as well as for results of clinical trials.")
+ (license license:expat)))
+
(define-public r-ctrialsgov
(package
(name "r-ctrialsgov")
--
2.39.2
R
R
Ricardo Wurmus wrote on 26 Mar 2023 19:01
Re: [bug#62441] [PATCH 1/4] gnu: Add r-ctrialsgov.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 62441-done@debbugs.gnu.org)
875yanh2ef.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-ctrialsgov): New variable.

We worked on the same patches at the same time. I pushed this series
yesterday. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62441@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62441
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch