[PATCH 0/6] Update csvkit.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 24 Mar 2023 14:09
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324130952.131621-1-code@greghogan.com
python-leather, python-agate, and csvkit were failing to build for me on
the core-updates branch.

Greg Hogan (6):
gnu: python-leather: Update to 0.3.4.
gnu: python-agate-dbf: Update to 0.2.2.
gnu: python-agate-sql: Update to 0.5.9.
gnu: Add python-agate-locales.
gnu: python-agate: Update to 1.7.1
gnu: csvkit: Update to 1.1.1.

gnu/packages/wireservice.scm | 30 +++++++++++++++++++-----------
1 file changed, 19 insertions(+), 11 deletions(-)

--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 3/6] gnu: python-agate-sql: Update to 0.5.9.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-3-code@greghogan.com
* gnu/packages/wireservices.scm (python-agate-sql): Update to 0.5.9.
---
gnu/packages/wireservice.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index bb2ad85cf8..5878142821 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -124,7 +124,7 @@ (define-public python-agate
(define-public python-agate-sql
(wireservice-package
(name "python-agate-sql")
- (version "0.5.7")
+ (version "0.5.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -133,7 +133,7 @@ (define-public python-agate-sql
(file-name (git-file-name name version))
(sha256
(base32
- "1q6ywm0wzkkwcwk0884k0lycf8k7pzwz94rzb1y5ssm8b1gl0i62"))))
+ "112q523w4jf3k8p4ynvjzfqa4j32ri34h2ppvicialp2lz5drvf0"))))
(native-inputs
`(("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)
--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 6/6] gnu: csvkit: Update to 1.1.1.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-6-code@greghogan.com
* gnu/packages/wireservice.scm (csvkit): Update to 1.1.1.
---
gnu/packages/wireservice.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index ace3c17082..70b4fc0839 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -210,13 +210,13 @@ (define-public python-agate-excel
(define-public csvkit
(package
(name "csvkit")
- (version "1.0.5")
+ (version "1.1.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "csvkit" version))
(sha256
(base32
- "1ffmbzk4rxnl1yhqfl58v7kvl5m9cbvjm8v7xp4mvr00sgs91lvv"))))
+ "08wj0hlmbdmklar12cjzqp91vcxzwifsvmgasszas8kbiyvvgpdy"))))
(build-system python-build-system)
(native-inputs
(list python-psycopg2 ; to test PostgreSQL support
--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 4/6] gnu: Add python-agate-locales.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-4-code@greghogan.com
* gnu/packages/wireservice.scm (python-agate-locales): New variable.
---
gnu/packages/wireservice.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index 5878142821..f18f2b9ee7 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -26,6 +26,7 @@ (define-module (gnu packages wireservice)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages python-web)
@@ -88,6 +89,12 @@ (define-public python-leather
(description "Leather is a Python charting library for those who need
charts now and don't care if they're perfect.")))
+(define python-agate-locales
+ (make-glibc-utf8-locales
+ glibc
+ #:locales (list "ko_KR")
+ #:name "python-agate-locales"))
+
(define-public python-agate
(wireservice-package
(name "python-agate")
--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 2/6] gnu: python-agate-dbf: Update to 0.2.2.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-2-code@greghogan.com
* gnu/packages/wireservices.scm (python-agate-dbf): Update to 0.2.2.
---
gnu/packages/wireservice.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index b8b2cff3f7..bb2ad85cf8 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -150,7 +150,7 @@ (define-public python-agate-sql
(define-public python-agate-dbf
(wireservice-package
(name "python-agate-dbf")
- (version "0.2.1")
+ (version "0.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -159,7 +159,7 @@ (define-public python-agate-dbf
(file-name (git-file-name name version))
(sha256
(base32
- "1y49fi6pmm7gzhajvqmfpcca2sqnwj24fqnsvzwk7r1hg2iaa2gi"))))
+ "03l3qlyw7588jhjjsiy15valqlzs8gjai8f74v18zv2za0zjqbzl"))))
(native-inputs
`(("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)
--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 5/6] gnu: python-agate: Update to 1.7.1
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-5-code@greghogan.com
* gnu/packages/wireservices.scm (python-agate): Update to 1.7.1.
[native-inputs]: Add python-agate-locales.
---
gnu/packages/wireservice.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index f18f2b9ee7..ace3c17082 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -98,7 +98,7 @@ (define python-agate-locales
(define-public python-agate
(wireservice-package
(name "python-agate")
- (version "1.6.1")
+ (version "1.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -107,9 +107,10 @@ (define-public python-agate
(file-name (git-file-name name version))
(sha256
(base32
- "077zj8xad8hsa3nqywvf7ircirmx3krxdipl8wr3dynv3l3khcpl"))))
+ "1wqyml7f70hr7zhgwvwqy4bdshlbcmp4jmyc5y12jyx10xp3sk7c"))))
(native-inputs
- `(("python-nose" ,python-nose)
+ `(("locales" ,python-agate-locales)
+ ("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)
("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
("python-csselect" ,python-cssselect)
--
2.40.0
G
G
Greg Hogan wrote on 24 Mar 2023 14:23
[PATCH 1/6] gnu: python-leather: Update to 0.3.4.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230324132331.135677-1-code@greghogan.com
* gnu/packages/wireservices.scm (python-leather): Update to 0.3.4.
---
gnu/packages/wireservice.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index d315bc2d74..b8b2cff3f7 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -65,7 +65,7 @@ (define-syntax-rule (wireservice-package extra-fields ...)
(define-public python-leather
(wireservice-package
(name "python-leather")
- (version "0.3.3")
+ (version "0.3.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -74,7 +74,7 @@ (define-public python-leather
(file-name (git-file-name name version))
(sha256
(base32
- "1ck3dplni99sv4s117cbm07ydwwjsrxkhdy19rnk0iglia1d4s5i"))))
+ "00cg4cidl15q1xv2pmxdkia5brig7x0xy9hwf2mlf9cq39bpj1w6"))))
(native-inputs
`(("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)
--
2.40.0
G
G
Greg Hogan wrote on 7 Apr 2023 21:37
[PATCH] gnu: Update to 13.1.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230407193738.268958-1-code@greghogan.com
* gnu/packages/gdb.scm (gdb-12): Rename to ...
(gdb-13): ... and update to 13.1.
(avr-gdb): Inherit from GDB-13.
---
gnu/packages/gdb.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index fd0bc80e44..6f7b3929e3 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -149,17 +149,17 @@ (define-public gdb-11
written in C, C++, Ada, Objective-C, Pascal and more.")
(license gpl3+)))
-(define-public gdb-12
+(define-public gdb-13
(package
(inherit gdb-11)
- (version "12.1")
+ (version "13.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdb/gdb-"
version ".tar.xz"))
(sha256
(base32
- "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))))
+ "184m5rp5gfkf5i8b707l2hf238m2vmjx70jqn4mbx9k9ip0xanhi"))))))
(define-public gdb
;; This is the fixed version that packages depend on. Update it rarely
@@ -173,7 +173,7 @@ (define-public gdb-minimal
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
(define-public avr-gdb
- (package/inherit gdb-12
+ (package/inherit gdb-13
(name "avr-gdb")
(arguments
`(#:configure-flags
@@ -182,7 +182,7 @@ (define-public avr-gdb
"--enable-languages=c,c++"
"--with-system-readline"
"--enable-source-highlight")
- ,@(package-arguments gdb-12)))
+ ,@(package-arguments gdb-13)))
(synopsis "The GNU Debugger for AVR")
(description
"GDB is the GNU debugger. With it, you can monitor what a program is
--
2.40.0
S
S
Simon Tournier wrote on 8 Apr 2023 11:40
(name . Greg Hogan)(address . code@greghogan.com)
86zg7i67ax.fsf@gmail.com
Hi,

THe commit header line is:

gnu: Update to 13.1.

and ’gdb’ seems missing.


On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
Toggle quote (4 lines)
> * gnu/packages/gdb.scm (gdb-12): Rename to ...
> (gdb-13): ... and update to 13.1.
> (avr-gdb): Inherit from GDB-13.

Naive question, why GDB@12 is removed and not instead GDB@11?

Cheers,
simon
G
G
Greg Hogan wrote on 10 Apr 2023 20:36
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 62418@debbugs.gnu.org)
CA+3U0ZkUbBQv1cxz6khfLEnemjJc+-sEDNLpzWCMyUXd=bbddw@mail.gmail.com
On Sat, Apr 8, 2023 at 5:41?AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (9 lines)
>
> Hi,
>
> THe commit header line is:
>
> gnu: Update to 13.1.
>
> and ’gdb’ seems missing.

Good observation. Will submit a second version of the patch.

Toggle quote (7 lines)
> On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
> > * gnu/packages/gdb.scm (gdb-12): Rename to ...
> > (gdb-13): ... and update to 13.1.
> > (avr-gdb): Inherit from GDB-13.
>
> Naive question, why GDB@12 is removed and not instead GDB@11?

gdb@11 has 6811 dependent packages.
S
S
Simon Tournier wrote on 11 Apr 2023 10:07
(name . Greg Hogan)(address . code@greghogan.com)(address . 62418@debbugs.gnu.org)
86leiy6dv7.fsf@gmail.com
Hi,

On Mon, 10 Apr 2023 at 14:36, Greg Hogan <code@greghogan.com> wrote:

Toggle quote (9 lines)
>> On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
>> > * gnu/packages/gdb.scm (gdb-12): Rename to ...
>> > (gdb-13): ... and update to 13.1.
>> > (avr-gdb): Inherit from GDB-13.
>>
>> Naive question, why GDB@12 is removed and not instead GDB@11?
>
> gdb@11 has 6811 dependent packages.

Well, the usual way when several versions are around and when one is
used by many is to name the other with the suffix ’-next’.

See python-numpy-next, emacs-next, etc.


Cheers,
simon
G
G
Greg Hogan wrote on 11 Apr 2023 15:43
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 62418@debbugs.gnu.org)
CA+3U0Z=8+VZA0eeP14tEmuJGp1z_Y=2u70aiODSw8R+C14M03A@mail.gmail.com
On Tue, Apr 11, 2023 at 4:37?AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (8 lines)
>
> > gdb@11 has 6811 dependent packages.
>
> Well, the usual way when several versions are around and when one is
> used by many is to name the other with the suffix ’-next’.
>
> See python-numpy-next, emacs-next, etc.

I had thought the preferred way was to suffix the internal version
with '/pinned' rather than suffixing and reverting the user-facing
package name, but hopefully the need to do this is significantly
reduced with the switch from core-updates and staging to feature
branches.

If it's an issue of stability or compatibility then '-next' is the
sensible approach.
G
G
Greg Hogan wrote on 18 Apr 2023 22:43
[PATCH] gnu: gdb: Update to 13.1.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230418204319.729894-1-code@greghogan.com
Fix the patch summary / subject line.

* gnu/packages/gdb.scm (gdb-12): Rename to ...
(gdb-13): ... and update to 13.1.
(avr-gdb): Inherit from GDB-13.
---
gnu/packages/gdb.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index fd0bc80e44..6f7b3929e3 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -149,17 +149,17 @@ (define-public gdb-11
written in C, C++, Ada, Objective-C, Pascal and more.")
(license gpl3+)))
-(define-public gdb-12
+(define-public gdb-13
(package
(inherit gdb-11)
- (version "12.1")
+ (version "13.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdb/gdb-"
version ".tar.xz"))
(sha256
(base32
- "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))))
+ "184m5rp5gfkf5i8b707l2hf238m2vmjx70jqn4mbx9k9ip0xanhi"))))))
(define-public gdb
;; This is the fixed version that packages depend on. Update it rarely
@@ -173,7 +173,7 @@ (define-public gdb-minimal
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
(define-public avr-gdb
- (package/inherit gdb-12
+ (package/inherit gdb-13
(name "avr-gdb")
(arguments
`(#:configure-flags
@@ -182,7 +182,7 @@ (define-public avr-gdb
"--enable-languages=c,c++"
"--with-system-readline"
"--enable-source-highlight")
- ,@(package-arguments gdb-12)))
+ ,@(package-arguments gdb-13)))
(synopsis "The GNU Debugger for AVR")
(description
"GDB is the GNU debugger. With it, you can monitor what a program is
--
2.40.0
G
G
Greg Hogan wrote on 18 Apr 2023 22:43
Re: [bug#62418] [PATCH] gnu: Update to 13.1.
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 62418@debbugs.gnu.org)
CA+3U0Zn4u7DQ0ErAY6TRaN07vy=nnp0RRmx4NUYS0m4uUg43Yg@mail.gmail.com
On Tue, Apr 11, 2023 at 9:43?AM Greg Hogan <code@greghogan.com> wrote:
Toggle quote (19 lines)
>
> On Tue, Apr 11, 2023 at 4:37?AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
> >
> > > gdb@11 has 6811 dependent packages.
> >
> > Well, the usual way when several versions are around and when one is
> > used by many is to name the other with the suffix ’-next’.
> >
> > See python-numpy-next, emacs-next, etc.
>
> I had thought the preferred way was to suffix the internal version
> with '/pinned' rather than suffixing and reverting the user-facing
> package name, but hopefully the need to do this is significantly
> reduced with the switch from core-updates and staging to feature
> branches.
>
> If it's an issue of stability or compatibility then '-next' is the
> sensible approach.

I see that Ludo' added the '/pinned' suffix in core-updates 6b5c21e0.

This patch is successfully building on QA.
L
L
Ludovic Courtès wrote on 14 May 2023 23:00
Re: bug#62418: [PATCH 0/6] Update csvkit.
(name . Greg Hogan)(address . code@greghogan.com)
878rdqwrv0.fsf@gnu.org
Hi Greg and Alice,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (11 lines)
> python-leather, python-agate, and csvkit were failing to build for me on
> the core-updates branch.
>
> Greg Hogan (6):
> gnu: python-leather: Update to 0.3.4.
> gnu: python-agate-dbf: Update to 0.2.2.
> gnu: python-agate-sql: Update to 0.5.9.
> gnu: Add python-agate-locales.
> gnu: python-agate: Update to 1.7.1
> gnu: csvkit: Update to 1.1.1.

It’s been two months but I’ve finally applies this patch series.
Apologies for the delay!

Alice, if you see any further changes that should be made, please send
them as a separate patch on top of this.

Thank you!

Ludo’.
Closed
G
G
Greg Hogan wrote on 18 Jul 2023 21:32
unarchive 62418
(address . control@debbugs.gnu.org)
CA+3U0ZmFqa2LOCObi89sDZNoV5TCm1p7UcBoX+EDLKoz0fn3gw@mail.gmail.com
unarchive 62418
G
G
Greg Hogan wrote on 18 Jul 2023 21:33
[PATCH v2] gnu: gdb: Update to 13.2.
(address . 62418@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230718193401.2604-1-code@greghogan.com
* gnu/packages/gdb.scm (gdb-12): Rename to ...
(gdb-13): ... and update to 13.2.
(avr-gdb): Inherit from GDB-13.
---
gnu/packages/gdb.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 34d081dc9e..6ab89d12a0 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -145,31 +145,31 @@ (define-public gdb/pinned
(properties `((hidden? . #t)))
(license gpl3+)))
-(define-public gdb-12
+(define-public gdb-13
(package
(inherit gdb/pinned)
- (version "12.1")
+ (version "13.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdb/gdb-"
version ".tar.xz"))
(sha256
(base32
- "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))
+ "02izi7msnnwiv0imbl7r3ll9hi1mi94jyg02dvdsncqqpsvynnzx"))))
(properties '())))
(define-public gdb
;; The "default" version.
- gdb-12)
+ gdb-13)
(define-public gdb-minimal
- (package/inherit gdb-12
+ (package/inherit gdb-13
(name "gdb-minimal")
(inputs (fold alist-delete (package-inputs gdb)
'("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
(define-public avr-gdb
- (package/inherit gdb-12
+ (package/inherit gdb-13
(name "avr-gdb")
(arguments
`(#:configure-flags
@@ -178,7 +178,7 @@ (define-public avr-gdb
"--enable-languages=c,c++"
"--with-system-readline"
"--enable-source-highlight")
- ,@(package-arguments gdb-12)))
+ ,@(package-arguments gdb-13)))
(synopsis "The GNU Debugger for AVR")
(description
"GDB is the GNU debugger. With it, you can monitor what a program is
--
2.41.0
?