“! failing-command” pattern in shell tests is wrong
(address . bug-guix@gnu.org)
In https://issues.guix.gnu.org/43616 (commit
d8934360d2453a403b5433e71d09188e4ed23b57), we changed:
if command that should fail; then false; else true; fi
to:
! command that should fail
I had reservations back then, and now I know why: :-)
Toggle snippet (12 lines)
$ bash -xe -c '! true; true'
+ true
+ true
$ echo $?
0
$ bash -xe -c '! false; true'
+ false
+ true
$ echo $?
0
Whether or not the command following the exclamation mark succeeds, the
statement succeeds. Bummer.
The Bash manual (info "(bash) Pipelines") reads:
If the reserved word '!' precedes the pipeline, the exit status is the
logical negation of the exit status as described above. The shell
waits for all commands in the pipeline to terminate before returning a
value.
To me, that means it should work as we thought, but it’s a fact that it
doesn’t.
Thoughts?
Ludo’.