[PATCH 0/3] Update supported-systems.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Christopher Baines
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 22 Mar 2023 13:47
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230322124757.26651-1-code@greghogan.com
Greg Hogan (3):
gnu: b2sum: Limit to x86_64-linux.
gnu: tokyocabinet: Limit to x86_64-linux and i686-linux.
gnu: libx86emu: Limit to x86_64-linux and i686-linux.

gnu/packages/crypto.scm | 2 ++
gnu/packages/databases.scm | 2 ++
gnu/packages/virtualization.scm | 2 ++
3 files changed, 6 insertions(+)

--
2.40.0
G
G
Greg Hogan wrote on 22 Mar 2023 13:52
[PATCH 1/3] gnu: b2sum: Limit to x86_64-linux.
(address . 62378@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230322125230.39886-1-code@greghogan.com
* gnu/packages/crypto.scm (b2sum)[supported-systems]: New field.
---
gnu/packages/crypto.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index b4bef33b06..1ed14d9092 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -868,6 +868,8 @@ (define-public b2sum
(file-name (git-file-name name version))
(sha256
(base32 "04z631v0vzl52g73v390ask5fnzi5wg83lcjkjhpmmymaz0jn152"))))
+ ;; "This code requires at least SSE2".
+ (supported-systems '("x86_64-linux"))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "CC=" ,(cc-for-target))
--
2.40.0
G
G
Greg Hogan wrote on 22 Mar 2023 13:52
[PATCH 2/3] gnu: tokyocabinet: Limit to x86_64-linux and i686-linux.
(address . 62378@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230322125230.39886-2-code@greghogan.com
* gnu/packages/databases.scm (tokyocabinet)[supported-systems]: New field.
---
gnu/packages/databases.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e51ddd5bf2..89ccf6c4fc 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2630,6 +2630,8 @@ (define-public tokyocabinet
(sha256
(base32
"140zvr0n8kvsl0fbn2qn3f2kh3yynfwnizn4dgbj47m975yg80x0"))))
+ ;; "gcc: error: unrecognized command-line option ?-minline-all-stringops?".
+ (supported-systems '("i686-linux" "x86_64-linux"))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
--
2.40.0
G
G
Greg Hogan wrote on 22 Mar 2023 13:52
[PATCH 3/3] gnu: libx86emu: Limit to x86_64-linux and i686-linux.
(address . 62378@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230322125230.39886-3-code@greghogan.com
* gnu/packages/virtualization.scm (libx86emu)[supported-systems]: New field.
---
gnu/packages/virtualization.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 1c1b06d271..b61d8e3766 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -617,6 +617,8 @@ (define-public libx86emu
(("GIT2LOG.*=.*$") "")
(("GITDEPS.*=.*$") "")
(("BRANCH.*=.*$") ""))))))
+ ;; "fatal error: sys/io.h: No such file or directory".
+ (supported-systems '("i686-linux" "x86_64-linux"))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
--
2.40.0
C
C
Christopher Baines wrote on 24 Mar 2023 15:47
Re: [bug#62378] [PATCH 0/3] Update supported-systems.
(name . Greg Hogan)(address . code@greghogan.com)
87zg82cih9.fsf@cbaines.net
Greg Hogan <code@greghogan.com> writes:

Toggle quote (5 lines)
> Greg Hogan (3):
> gnu: b2sum: Limit to x86_64-linux.
> gnu: tokyocabinet: Limit to x86_64-linux and i686-linux.
> gnu: libx86emu: Limit to x86_64-linux and i686-linux.

Hi Greg,

Thanks for these patches.

I've pushed the b2sum one to master as
e0cb344b18034bfb41905c627d2b3b9dbf2e65fb.

I held back on the other two since they seem to successfully build on
systems beyond the ones you've specified. I was checking the builds
using data.guix.gnu.org.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQduHJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdeDw/+NChddFvHlJWkqKenVQFRmfVhHNHcoh90
/2hihqQg8HVJV6h49Wb0qenqf+HRNeFQYpngTfRGSW4DP9ipsQEy6daZhlsv+yBx
r93/mjMCPS6qUNt0UKS59FtTyPiS3LY5nbrbkKBs8QNt3OEnAkr/VA6EvK6p3oxf
8No2hIDFt2vtSY9u03li56qyeiL92MYa5EFKcX2PAsCtiHh9HYRhkhXo2iPyTeYW
zqbZXkV2wEEEJoJtekim4mtVV4r81t75E9hl04jEEGmQJA2LgVfu9xx8s9MFlaqo
XmVSgwuZALN9nmNYQbGxHjBceO2TTVS+QccCQzgj2Ami5fALq8/vVZczb4UvHBAl
iKpZ9G4JT9yDt/Ee3VWr+H4fsHUHUfEmzWY5djzvnzWQuc9LwwhwQUg1EyvYq5AG
ocSC7Zs3N5KNva61pTlv0gSwTEInFZG57R4sUlyfAXjTfbDpCFtt+vXoXDfZcDO7
ifAYAjlys/lp5hpB9AZn8NDTmVd2cr2KNVxdNjdi1jMLAzRaug/qgeuyfGwon9hQ
jy5pBrtxFpr3MNGX8N+1LcTlEZrml3lD3kP+DwNbgfV5ALDLqIgGDJKw1FZvEi/M
T3Lm1DwnhtvgnwgrM3AyezEif7haliEnB/ENU2mM04CVWcvZ5bmIQxmguvzNTnDd
2dyiLHI/Pyo=
=kxeJ
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 27 Mar 2023 17:39
tag 62378 moreinfo
(address . control@debbugs.gnu.org)
87leji8aqd.fsf@cbaines.net
tags 62378 + moreinfo
quit
G
G
Greg Hogan wrote on 11 May 2023 22:20
Re: [bug#62378] [PATCH 0/3] Update supported-systems.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 62378-done@debbugs.gnu.org)
CA+3U0Z=8uozxs1rEv5m+U5LM=p3A0bhZEJAQRw1-PXjMStXMNw@mail.gmail.com
On Fri, Mar 24, 2023 at 10:49?AM Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (19 lines)
>
> Greg Hogan <code@greghogan.com> writes:
>
> > Greg Hogan (3):
> > gnu: b2sum: Limit to x86_64-linux.
> > gnu: tokyocabinet: Limit to x86_64-linux and i686-linux.
> > gnu: libx86emu: Limit to x86_64-linux and i686-linux.
>
> Hi Greg,
>
> Thanks for these patches.
>
> I've pushed the b2sum one to master as
> e0cb344b18034bfb41905c627d2b3b9dbf2e65fb.
>
> I held back on the other two since they seem to successfully build on
> systems beyond the ones you've specified. I was checking the builds
> using data.guix.gnu.org.

I see that Debian has these two packages available for additional
architectures, but within Guix tokyocabinet fails with "gcc: error:
unrecognized command-line option ‘-minline-all-stringops’" on both
option looks to be x86 online
I don't see anything apropos in the list of Debian patches
Closed
?