[PATCH] gnu: borgmatic: Update to 1.7.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230322081136.1155-1-sarg@sarg.org.ru
* gnu/packages/backup.scm (borgmatic): Update to 1.7.9.
Set absolute store path to borg in commands.py.
---
gnu/packages/backup.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index cf47ac9c80..97a4c36696 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1255,13 +1255,13 @@ (define-public disarchive
(define-public borgmatic
(package
(name "borgmatic")
- (version "1.5.22")
+ (version "1.7.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgmatic" version))
(sha256
- (base32 "0pvqlj17vp81i7saxqh5hsaxqz29ldrjd7bcssh4g1h0ikmnaf2r"))))
+ (base32 "1scfh90qgv8xhafnnpl3pa9d8m4rg9xgvf21yybvmsnm5v1k2x5z"))))
(build-system python-build-system)
(arguments
(list #:phases
@@ -1270,10 +1270,15 @@ (define-public borgmatic
(lambda* (#:key inputs #:allow-other-keys)
;; Set absolute store path to borg.
(substitute* "borgmatic/commands/borgmatic.py"
- (("location\\.get\\('local_path', 'borg'\\)")
- (string-append "location.get('local_path', '"
+ (("\\.get\\('local_path', 'borg'\\)")
+ (string-append ".get('local_path', '"
(search-input-file inputs "bin/borg")
- "')")))))
+ "')")))
+ (substitute* "tests/unit/commands/test_borgmatic.py"
+ (("(module.get_local_path.+ == )'borg'" all start)
+ (string-append start "'"
+ (search-input-file inputs "bin/borg")
+ "'")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
--
2.39.2
Leo Famulari wrote 2 years ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62372-done@debbugs.gnu.org)
ZBsyR795gIFQosHL@jasmine.lan
On Wed, Mar 22, 2023 at 09:11:36AM +0100, Sergey Trofimov wrote:
Toggle quote (3 lines)
> * gnu/packages/backup.scm (borgmatic): Update to 1.7.9.
> Set absolute store path to borg in commands.py.

Thanks! Pushed as afb1373fce0aa169fea6595cfba7a00d63fd4e8f
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62372@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62372
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help