Spencer Skylar Chan wrote 2 years ago
(address . guix-patches@gnu.org)
From 2e9152dcb83edc785e5b3c878011e2dcbccda4db Mon Sep 17 00:00:00 2001
From: Skylar Chan <schan12@umd.edu>
Date: Tue, 21 Mar 2023 14:33:51 -0400
Subject: [PATCH] gnu: ddcutil: Update to 1.4.1.
* gnu/packages/hardware.scm (ddcutil): Update to 1.4.1.
[arguments](phases): Remove them. i2c group access is no longer strictly
required. See https://github.com/rockowitz/ddcutil/issues/275
---
gnu/packages/hardware.scm | 20 ++------------------
1 file changed, 2 insertions(+), 18 deletions(-)
Toggle diff (43 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index c00a6e2d91..f7eb814d04 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -482,31 +482,15 @@ (define-public ckb-next
(define-public ddcutil
(package
(name "ddcutil")
- (version "1.3.2")
+ (version "1.4.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.ddcutil.com/tarballs/"
"ddcutil-" version ".tar.gz"))
(sha256
- (base32 "0hm0cm4m4hk1jjy7kddg613mynvwlii3kp8al0j9v3c6mcx3p4mx"))))
+ (base32 "14svdjpw9xn1czl4vff4jg2i9bp83lxcbzxj7hxn63z3gzacaj4k"))))
(build-system gnu-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'install-udev-rules
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Move the udev rules to their expected location in Guix
- ;; System, so they can be more easily used.
- (let ((rules.d (string-append #$output "/lib/udev/rules.d")))
- (mkdir-p (dirname rules.d))
- (rename-file (string-append #$output "/share/ddcutil/data")
- rules.d)
- ;; Patch a reference to the ddcutil command.
- (substitute* (string-append rules.d
"/45-ddcutil-usb.rules")
- (("/usr/bin/ddcutil")
- (search-input-file outputs "bin/ddcutil")))))))))
(native-inputs
(list pkg-config))
(inputs
base-commit: 43e4e52dfd320b3922108fbdd8d0e6c8e12bccf8
--
2.40.0