[PATCH 0/2] Update python-numpy-next.

  • Done
  • quality assurance status badge
Details
One participant
  • Greg Hogan
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 21 Mar 2023 20:04
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230321190445.56256-1-code@greghogan.com
Greg Hogan (2):
gnu: python-typing-extensions: Update to 4.5.0.
gnu: python-numpy-next: Update to 1.24.2.

gnu/packages/python-xyz.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

--
2.40.0
G
G
Greg Hogan wrote on 21 Mar 2023 20:20
[PATCH 1/2] gnu: python-typing-extensions: Update to 4.5.0.
(address . 62350@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230321192025.101040-1-code@greghogan.com
notice about repository change.

* gnu/packages/python-xyz.scm (python-typing-extensions): Update to 4.5.0.
[source]: Update repository URL.
[arguments](%standard-phases): Remove 'enter-source-directory'.
---
gnu/packages/python-xyz.scm | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac10290237..e3778b0a44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22533,26 +22533,23 @@ (define-public python-typeguard
(define-public python-typing-extensions
(package
(name "python-typing-extensions")
- (version "4.0.1")
+ (version "4.5.0")
(source (origin
;; The test script is missing from the PyPI archive.
(method git-fetch)
(uri (git-reference
- (url "https://github.com/python/typing")
+ (url "https://github.com/python/typing_extensions")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0a35fh5wk9s538x0w3dz95y0avnhd2srzyv9s1a372711n8hdl4p"))))
+ "1fymg0hirbmv51avwv17s426hi8bwg0pq8yjci1n7qzr2p3dp3my"))))
(build-system python-build-system)
(arguments
(list
#:tests? #f ;requires Python's test module, not available in Guix
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'enter-source-directory
- (lambda _
- (chdir "typing_extensions")))
;; XXX: PEP 517 manual build copied from python-isort.
(replace 'build
(lambda _
--
2.40.0
G
G
Greg Hogan wrote on 21 Mar 2023 20:20
[PATCH 2/2] gnu: python-numpy-next: Update to 1.24.2.
(address . 62350@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230321192025.101040-2-code@greghogan.com
* gnu/packages/python-xyz.scm (python-numpy-next): Update to 1.24.2.
[native-inputs]: Add python-typing-extensions.
---
gnu/packages/python-xyz.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e3778b0a44..79c68d4ee5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6304,7 +6304,7 @@ (define-public python-numpy-next
(package
(inherit python-numpy)
(name "python-numpy-next")
- (version "1.22.3")
+ (version "1.24.2")
(source
(origin
(inherit (package-source python-numpy))
@@ -6314,7 +6314,10 @@ (define-public python-numpy-next
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "19dw91pqbqcniw2z57kiyqs1qp56g7kqy1bdyv664g8s62sc01m9"))))))
+ "08ibxgknpvn35wmgqjlwxwns96hb4bvimfkw2z6v43481r9ryfh0"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs python-numpy)
+ (append python-typing-extensions)))))
(define-public python-numpy-documentation
(package
--
2.40.0
G
G
Greg Hogan wrote on 11 May 2023 22:54
Re: bug#62350: Acknowledgement ([PATCH 0/2] Update python-numpy-next.)
(address . 62350-done@debbugs.gnu.org)
CA+3U0Zk282OqJbBR5_ObTvHDS73vs1Wpdp7ijzi+QGp5ot0PCg@mail.gmail.com
python-typing-extensions has already been updated with a different
commit. Closing this issue as I will simply update python-numpy in my
manifest.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62350@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62350
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch