[PATCH 0/2] Update usbutils description & use G-Expression.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 21 Mar 2023 17:02
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1679414158.git.mirai@makinata.eu
* Modernize with G-Expressions.
* Rebase #34829 [1] patch to resolve merge-conflict.
* Applied minor texinfo tweaks and adjustments to commit message.




Bruno Victal (1):
gnu: usbutils: Use G-Expressions.

mikadoZero (1):
gnu: usbutils: Make package description different from synopsis.

gnu/packages/linux.scm | 39 ++++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 19 deletions(-)

--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 17:05
[PATCH 2/2] gnu: usbutils: Use G-Expressions.
(address . 62347@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
e51915c372259b35266ea6e276fd5bdabde47d7f.1679414688.git.mirai@makinata.eu
* gnu/packages/linux.scm (usbutils): Use G-Expressions.
---
gnu/packages/linux.scm | 33 ++++++++++++++++-----------------
1 file changed, 16 insertions(+), 17 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f0a590104b..240c62bb14 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2377,23 +2377,22 @@ (define-public usbutils
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap-scripts
- (lambda _
- (substitute* "usbhid-dump/bootstrap"
- (("/bin/sh") (which "sh")))))
- (add-after 'install 'separate-python-output
- ;; Separating one Python script shaves more than 106 MiB from :out.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (out:python (assoc-ref outputs "python")))
- (for-each (lambda (file)
- (let ((old (string-append out "/" file))
- (new (string-append out:python "/" file)))
- (mkdir-p (dirname new))
- (rename-file old new)))
- (list "bin/lsusb.py"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'patch-bootstrap-scripts
+ (lambda _
+ (substitute* "usbhid-dump/bootstrap"
+ (("/bin/sh") (which "sh")))))
+ (add-after 'install 'separate-python-output
+ ;; Separating one Python script shaves more than 106 MiB from :out.
+ (lambda _
+ (for-each (lambda (file)
+ (let ((old (string-append #$output "/" file))
+ (new (string-append #$output:python "/" file)))
+ (mkdir-p (dirname new))
+ (rename-file old new)))
+ (list "bin/lsusb.py")))))))
(inputs
(list eudev libusb python))
(native-inputs
--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 17:05
[PATCH 1/2] gnu: usbutils: Make package description different from synopsis.
(address . 62347@debbugs.gnu.org)(name . mikadoZero)(address . mikadozero@yandex.com)
184fdda5f2b71b7f7643d394713af788ecf11656.1679414688.git.mirai@makinata.eu
From: mikadoZero <mikadozero@yandex.com>

* gnu/packages/linux.scm (usbutils)[description]: Change package description.
---
gnu/packages/linux.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ef05e77ec8..f0a590104b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanovi? <stefanx2ovic@gmail.com>
;;; Copyright © 2019-2022 Brice Waegeneire <brice@waegenei.re>
@@ -2399,9 +2400,10 @@ (define-public usbutils
(list autoconf automake libtool pkg-config))
(home-page "http://www.linux-usb.org/")
(synopsis
- "Tools for working with USB devices, such as lsusb")
+ "Tools for working with USB devices")
(description
- "Tools for working with USB devices, such as lsusb.")
+ "Collection of tools to query what type of USB devices are connected to the
+system, including @command{lsusb}.")
(license license:gpl2+)))
(define-public usbip-utils

base-commit: d377cfbd11a96b98fd07a7ceb7e79590e1cee336
--
2.39.1
L
L
Ludovic Courtès wrote on 17 Apr 2023 23:34
Re: bug#62347: [PATCH 0/2] Update usbutils description & use G-Expression.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 62347-done@debbugs.gnu.org)
87o7nmb3c3.fsf@gnu.org
Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (6 lines)
> Bruno Victal (1):
> gnu: usbutils: Use G-Expressions.
>
> mikadoZero (1):
> gnu: usbutils: Make package description different from synopsis.

Applied, thanks!
Closed
?