[PATCH 0/4] gnu: fdroidcl: Update to 0.7.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 20 Mar 2023 23:47
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230320224730.23970-1-sarg@sarg.org.ru
This is a series of patches to update fdroidcl to 0.7.0. I have built it
locally (x86_64) and verified that the application works correctly.

Sergey Trofimov (4):
gnu: Add go-github-com-schollz-progressbar-v3.
gnu: Add go-github-com-mitchellh-colorstring.
gnu: Add go-github-com-k0kubun-go-ansi.
gnu: fdroidcl: Update to 0.7.0.

gnu/packages/android.scm | 14 ++++----
gnu/packages/golang.scm | 76 ++++++++++++++++++++++++++++++++++++++++
2 files changed, 83 insertions(+), 7 deletions(-)

--
2.39.2
S
S
Sergey Trofimov wrote on 20 Mar 2023 23:51
[PATCH 1/4] gnu: Add go-github-com-schollz-progressbar-v3.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230320225133.24860-1-sarg@sarg.org.ru
* gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3):
New variable.
---
gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c75fdb4a31..e9187a14e9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11304,6 +11304,38 @@ (define-public go-sigs-k8s-io-yaml
@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
(license (list license:expat license:bsd-3))))
+(define-public go-github-com-schollz-progressbar-v3
+ (package
+ (name "go-github-com-schollz-progressbar-v3")
+ (version "3.13.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schollz/progressbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/schollz/progressbar/v3"
+ #:tests? #f))
+ (propagated-inputs (list go-golang-org-x-term
+ go-github-com-stretchr-testify
+ go-github-com-mitchellh-colorstring
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-k0kubun-go-ansi
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/schollz/progressbar")
+ (synopsis "Simple cross-platform progress bar.")
+ (description
+ "This package provides a very simple thread-safe progress bar which should work
+on every OS without problems. In order to be OS agnostic support of multi-line
+outputs is not provided.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")
--
2.39.2
S
S
Sergey Trofimov wrote on 20 Mar 2023 23:51
[PATCH 2/4] gnu: Add go-github-com-mitchellh-colorstring.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230320225133.24860-2-sarg@sarg.org.ru
* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring):
New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e9187a14e9..002475093a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11336,6 +11336,28 @@ (define-public go-github-com-schollz-progressbar-v3
outputs is not provided.")
(license license:expat)))
+(define-public go-github-com-mitchellh-colorstring
+ (package
+ (name "go-github-com-mitchellh-colorstring")
+ (version "0.0.0-20190213212951-d06e56a500db")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/colorstring")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mitchellh/colorstring"))
+ (home-page "https://github.com/mitchellh/colorstring")
+ (synopsis "Functions to colorize strings for terminal output.")
+ (description
+ "Colorstring provides functions for colorizing strings for terminal output.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")
--
2.39.2
S
S
Sergey Trofimov wrote on 20 Mar 2023 23:51
[PATCH 3/4] gnu: Add go-github-com-k0kubun-go-ansi.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230320225133.24860-3-sarg@sarg.org.ru
* gnu/packages/golang.scm (go-github-com-k0kubun-go-ansi):
New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 002475093a..b831a89872 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11358,6 +11358,28 @@ (define-public go-github-com-mitchellh-colorstring
"Colorstring provides functions for colorizing strings for terminal output.")
(license license:expat)))
+(define-public go-github-com-k0kubun-go-ansi
+ (package
+ (name "go-github-com-k0kubun-go-ansi")
+ (version "0.0.0-20180517002512-3bf9e2903213")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k0kubun/go-ansi")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/k0kubun/go-ansi"))
+ (home-page "https://github.com/k0kubun/go-ansi")
+ (synopsis "Go library for ANSI escape sequences.")
+ (description
+ "Windows-portable ANSI escape sequence utility for Go language")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")
--
2.39.2
S
S
Sergey Trofimov wrote on 20 Mar 2023 23:51
[PATCH] gnu: fdroidcl: Update to 0.7.0.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230320225133.24860-4-sarg@sarg.org.ru
* gnu/packages/android.scm (fdroidcl): Update to 0.7.0.
---
gnu/packages/android.scm | 20 ++++++++++----------
1 file changed, 10 insertions(+), 10 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..9d67dca0cd 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1195,25 +1195,25 @@ (define-public fdroidserver
(define-public fdroidcl
(package
(name "fdroidcl")
- (version "0.5.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mvdan/fdroidcl")
- (commit (string-append "v" version))))
+ (url "https://github.com/mvdan/fdroidcl")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+ (base32
+ "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
(build-system go-build-system)
(arguments
`(#:import-path "mvdan.cc/fdroidcl"
- #:tests? #f ; TODO: Inputs missing.
+ #:tests? #f ;requires internet access
#:install-source? #f))
- (inputs
- (list go-github-com-kr-pretty))
- ;(native-inputs
- ; `(("go-github-com-rogpeppe-go-internal-testscript"
- ; ,go-github-com-rogpeppe-go-internal-testscript)))
+ (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
+ ;; these are for tests, but the tests are disabled
+ ;; (native-inputs
+ ;; (list go-github-com-rogpeppe-go-internal go-gopkg-in-check-v1))
(synopsis "F-Droid desktop client")
(description
"While the Android client integrates with the system with regular update
--
2.39.2
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:43
Re: bug#62310: [PATCH 0/4] gnu: fdroidcl: Update to 0.7.0.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310@debbugs.gnu.org)
87edpi3mle.fsf_-_@gmail.com
Hi!

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (32 lines)
> * gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3):
> New variable.
> ---
> gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index c75fdb4a31..e9187a14e9 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11304,6 +11304,38 @@ (define-public go-sigs-k8s-io-yaml
> @url{https://github.com/ghodss/yaml,ghodss/yaml}.")
> (license (list license:expat license:bsd-3))))
>
> +(define-public go-github-com-schollz-progressbar-v3
> + (package
> + (name "go-github-com-schollz-progressbar-v3")
> + (version "3.13.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/schollz/progressbar")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/schollz/progressbar/v3"
> + #:tests? #f))

There seems to be a simple test included; it'd be preferable to run it.
If there are reasons against running it, they should be explained in a
comment.

Toggle quote (15 lines)
> + (propagated-inputs (list go-golang-org-x-term
> + go-github-com-stretchr-testify
> + go-github-com-mitchellh-colorstring
> + go-github-com-mattn-go-runewidth
> + go-github-com-mattn-go-isatty
> + go-github-com-k0kubun-go-ansi
> + go-github-com-davecgh-go-spew))
> + (home-page "https://github.com/schollz/progressbar")
> + (synopsis "Simple cross-platform progress bar.")
> + (description
> + "This package provides a very simple thread-safe progress bar which should work
> +on every OS without problems. In order to be OS agnostic support of multi-line
> +outputs is not provided.")
> + (license license:expat)))

Cross-platform or Windows-compatible or this kind of qualities are not
useful information for Guix users, as Guix can only run on top of
GNU(/Linux) systems anyway, so I'd remove such text from the
description.

Could you please send a v2?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:46
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310@debbugs.gnu.org)
87a6063mgg.fsf_-_@gmail.com
Hi,

Sorry, I forgot a couple comments;

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (3 lines)
> * gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3):
> New variable.

Nitpick; but it'd be more conventional to break the line this:

* gnu/packages/golang.scm
(go-github-com-schollz-progressbar-v3): New variable.

The essence of it is explained in info '(standards) Style of Change
Logs'.

Toggle quote (39 lines)
> ---
> gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index c75fdb4a31..e9187a14e9 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11304,6 +11304,38 @@ (define-public go-sigs-k8s-io-yaml
> @url{https://github.com/ghodss/yaml,ghodss/yaml}.")
> (license (list license:expat license:bsd-3))))
>
> +(define-public go-github-com-schollz-progressbar-v3
> + (package
> + (name "go-github-com-schollz-progressbar-v3")
> + (version "3.13.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/schollz/progressbar")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/schollz/progressbar/v3"
> + #:tests? #f))
> + (propagated-inputs (list go-golang-org-x-term
> + go-github-com-stretchr-testify
> + go-github-com-mitchellh-colorstring
> + go-github-com-mattn-go-runewidth
> + go-github-com-mattn-go-isatty
> + go-github-com-k0kubun-go-ansi
> + go-github-com-davecgh-go-spew))
> + (home-page "https://github.com/schollz/progressbar")
> + (synopsis "Simple cross-platform progress bar.")

synopsis should not end with a trailing period (they are not complete
sentence). I think 'guix lint' should complain about that.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:47
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310@debbugs.gnu.org)
875yau3mf5.fsf_-_@gmail.com
Hi!

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (33 lines)
> * gnu/packages/golang.scm (go-github-com-mitchellh-colorstring):
> New variable.
> ---
> gnu/packages/golang.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index e9187a14e9..002475093a 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11336,6 +11336,28 @@ (define-public go-github-com-schollz-progressbar-v3
> outputs is not provided.")
> (license license:expat)))
>
> +(define-public go-github-com-mitchellh-colorstring
> + (package
> + (name "go-github-com-mitchellh-colorstring")
> + (version "0.0.0-20190213212951-d06e56a500db")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mitchellh/colorstring")
> + (commit (go-version->git-ref version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/mitchellh/colorstring"))
> + (home-page "https://github.com/mitchellh/colorstring")
> + (synopsis "Functions to colorize strings for terminal output.")

Here also, the trailing period can be removed.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:55
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310@debbugs.gnu.org)
871qli3m2q.fsf_-_@gmail.com
Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (33 lines)
> * gnu/packages/golang.scm (go-github-com-k0kubun-go-ansi):
> New variable.
> ---
> gnu/packages/golang.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 002475093a..b831a89872 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11358,6 +11358,28 @@ (define-public go-github-com-mitchellh-colorstring
> "Colorstring provides functions for colorizing strings for terminal output.")
> (license license:expat)))
>
> +(define-public go-github-com-k0kubun-go-ansi
> + (package
> + (name "go-github-com-k0kubun-go-ansi")
> + (version "0.0.0-20180517002512-3bf9e2903213")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/k0kubun/go-ansi")
> + (commit (go-version->git-ref version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/k0kubun/go-ansi"))
> + (home-page "https://github.com/k0kubun/go-ansi")
> + (synopsis "Go library for ANSI escape sequences.")

No trailing period for synopsis,

Toggle quote (3 lines)
> + (description
> + "Windows-portable ANSI escape sequence utility for Go language")

But you need one for the description. The project page projects a
better one, which reads "This library converts ANSI escape sequences to
Windows API calls on Windows environments." -- I'd use it for the
description. It makes me wonder though, if it's of any use to Guix
users, since Guix is not going to produce Windows Go binaries that could
run natively on Windows... Could you test if the package that wants this
can be built without it? It may well be optional.

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:58
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310@debbugs.gnu.org)
87wn3a27cm.fsf_-_@gmail.com
Hi!

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (33 lines)
> * gnu/packages/android.scm (fdroidcl): Update to 0.7.0.
> ---
> gnu/packages/android.scm | 20 ++++++++++----------
> 1 file changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
> index 881b75d763..9d67dca0cd 100644
> --- a/gnu/packages/android.scm
> +++ b/gnu/packages/android.scm
> @@ -1195,25 +1195,25 @@ (define-public fdroidserver
> (define-public fdroidcl
> (package
> (name "fdroidcl")
> - (version "0.5.0")
> + (version "0.7.0")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> - (url "https://github.com/mvdan/fdroidcl")
> - (commit (string-append "v" version))))
> + (url "https://github.com/mvdan/fdroidcl")
> + (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
> + (base32
> + "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
> (build-system go-build-system)
> (arguments
> `(#:import-path "mvdan.cc/fdroidcl"
> - #:tests? #f ; TODO: Inputs missing.
> + #:tests? #f ;requires internet access

Perhaps, ";tests require internet access"

Toggle quote (11 lines)
> #:install-source? #f))
> - (inputs
> - (list go-github-com-kr-pretty))
> - ;(native-inputs
> - ; `(("go-github-com-rogpeppe-go-internal-testscript"
> - ; ,go-github-com-rogpeppe-go-internal-testscript)))
> + (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
> + ;; these are for tests, but the tests are disabled
> + ;; (native-inputs
> + ;; (list go-github-com-rogpeppe-go-internal go-gopkg-in-check-v1))

I think I'd remove the native-inputs completely instead of keeping dead
code around.

Thanks for the contribution! I look forward to v2.

--
Maxim
S
S
Sergey Trofimov wrote on 21 Mar 2023 09:04
[PATCH v2 0/4] gnu: fdroidcl: Update to 0.7.0.
(address . 62310@debbugs.gnu.org)
20230321080457.12236-1-sarg@sarg.org.ru
I have addressed Maxim's comments and made the following changes:
* enabled tests.short for progressbar-v3 (full suite requires internet access)
* removed optional go-ansi dependency
* reworded synopsysises/descriptions, fixed formatting
* moved check-synopsis-style to %local-checkers, as I usually `lint -n` because of a very slow CVE linter

Sergey Trofimov (4):
gnu: Add go-github-com-schollz-progressbar-v3.
gnu: Add go-github-com-mitchellh-colorstring.
gnu: fdroidcl: Update to 0.7.0.
guix: Put check-synopsis-style to the local checkers list.

gnu/packages/android.scm | 17 +++++------
gnu/packages/golang.scm | 63 ++++++++++++++++++++++++++++++++++++++++
guix/lint.scm | 9 +++---
3 files changed, 75 insertions(+), 14 deletions(-)

--
2.39.2
S
S
Sergey Trofimov wrote on 21 Mar 2023 09:15
[PATCH v2 1/4] gnu: Add go-github-com-mitchellh-colorstring.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230321081520.15830-1-sarg@sarg.org.ru
* gnu/packages/golang.scm
(go-github-com-mitchellh-colorstring): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c75fdb4a31..3ac4863e85 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11304,6 +11304,28 @@ (define-public go-sigs-k8s-io-yaml
@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
(license (list license:expat license:bsd-3))))
+(define-public go-github-com-mitchellh-colorstring
+ (package
+ (name "go-github-com-mitchellh-colorstring")
+ (version "0.0.0-20190213212951-d06e56a500db")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/colorstring")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mitchellh/colorstring"))
+ (home-page "https://github.com/mitchellh/colorstring")
+ (synopsis "Functions to colorize strings for terminal output")
+ (description
+ "Colorstring provides functions for colorizing strings for terminal output.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")
--
2.39.2
S
S
Sergey Trofimov wrote on 21 Mar 2023 09:16
[PATCH v2 2/4] gnu: Add go-github-com-schollz-progressbar-v3.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230321081640.16012-1-sarg@sarg.org.ru
* gnu/packages/golang.scm
(go-github-com-schollz-progressbar-v3): New variable.
---
gnu/packages/golang.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ac4863e85..8f0e202d71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11326,6 +11326,47 @@ (define-public go-github-com-mitchellh-colorstring
"Colorstring provides functions for colorizing strings for terminal output.")
(license license:expat)))
+(define-public go-github-com-schollz-progressbar-v3
+ (package
+ (name "go-github-com-schollz-progressbar-v3")
+ (version "3.13.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schollz/progressbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/schollz/progressbar/v3"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ ;; tests in the full suite require internet access
+ (invoke "go" "test" "-test.short" import-path))
+ #t)))))
+ (propagated-inputs
+ (list go-golang-org-x-term
+ go-github-com-stretchr-testify
+ go-github-com-mitchellh-colorstring
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/schollz/progressbar")
+ (synopsis "Simple CLI progress bar")
+ (description
+ "This package provides a very simple thread-safe progress bar. The
+@code{progressbar} implements an @code{io.Writer} so it can automatically detect the
+number of bytes written to a stream, so you can use it as a progressbar for an
+@code{io.Reader}. When progressbar length is undetermined a customizable spinner is
+shown.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")
--
2.39.2
S
S
Sergey Trofimov wrote on 21 Mar 2023 09:16
[PATCH v2 3/4] gnu: fdroidcl: Update to 0.7.0.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230321081640.16012-2-sarg@sarg.org.ru
* gnu/packages/android.scm (fdroidcl): Update to 0.7.0.
---
gnu/packages/android.scm | 17 +++++++----------
1 file changed, 7 insertions(+), 10 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..a960a73683 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1195,25 +1195,22 @@ (define-public fdroidserver
(define-public fdroidcl
(package
(name "fdroidcl")
- (version "0.5.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mvdan/fdroidcl")
- (commit (string-append "v" version))))
+ (url "https://github.com/mvdan/fdroidcl")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+ (base32
+ "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
(build-system go-build-system)
(arguments
`(#:import-path "mvdan.cc/fdroidcl"
- #:tests? #f ; TODO: Inputs missing.
+ #:tests? #f ;requires internet access
#:install-source? #f))
- (inputs
- (list go-github-com-kr-pretty))
- ;(native-inputs
- ; `(("go-github-com-rogpeppe-go-internal-testscript"
- ; ,go-github-com-rogpeppe-go-internal-testscript)))
+ (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
(synopsis "F-Droid desktop client")
(description
"While the Android client integrates with the system with regular update
--
2.39.2
S
S
Sergey Trofimov wrote on 21 Mar 2023 09:16
[PATCH v2 4/4] guix: Put check-synopsis-style to the local checkers list.
(address . 62310@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20230321081640.16012-3-sarg@sarg.org.ru
* guix/lint.scm (check-synopsis-style): Move to %local-checkers.
---
guix/lint.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (29 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index a1a27873d9..3ed7fd6e4d 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1862,6 +1862,10 @@ (define %local-checkers
(name 'description)
(description "Validate package descriptions")
(check check-description-style))
+ (lint-checker
+ (name 'synopsis)
+ (description "Validate package synopses")
+ (check check-synopsis-style))
(lint-checker
(name 'inputs-should-be-native)
(description "Identify inputs that should be native inputs")
@@ -1926,10 +1930,7 @@ (define %local-checkers
(define %network-dependent-checkers
(list
- (lint-checker
- (name 'synopsis)
- (description "Validate package synopses")
- (check check-synopsis-style))
+
(lint-checker
(name 'gnu-description)
(description "Validate synopsis & description of GNU packages")
--
2.39.2
M
M
Maxim Cournoyer wrote on 21 Mar 2023 19:09
Re: [PATCH v2 0/4] gnu: fdroidcl: Update to 0.7.0.
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 62310-done@debbugs.gnu.org)
87jzzanfgw.fsf@gmail.com
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (6 lines)
> I have addressed Maxim's comments and made the following changes:
> * enabled tests.short for progressbar-v3 (full suite requires internet access)
> * removed optional go-ansi dependency
> * reworded synopsysises/descriptions, fixed formatting
> * moved check-synopsis-style to %local-checkers, as I usually `lint -n` because of a very slow CVE lin

Thanks for the lightning fast response!

I've retouched progressbar-v3 cosmetics a tiny bit:

Toggle snippet (19 lines)
@@ -11358,13 +11358,13 @@ (define-public go-github-com-schollz-progressbar-v3
go-github-com-mattn-go-isatty
go-github-com-davecgh-go-spew))
(home-page "https://github.com/schollz/progressbar")
- (synopsis "Simple CLI progress bar")
+ (synopsis "Simple command-line interface (CLI) progress bar")
(description
"This package provides a very simple thread-safe progress bar. The
-@code{progressbar} implements an @code{io.Writer} so it can automatically detect the
-number of bytes written to a stream, so you can use it as a progressbar for an
-@code{io.Reader}. When progressbar length is undetermined a customizable spinner is
-shown.")
+@code{progressbar} implements an @code{io.Writer} so it can automatically
+detect the number of bytes written to a stream, so you can use it as a
+@code{progressbar} for an @code{io.Reader}. When @code{progressbar}'s length
+is undetermined, a customizable spinner is shown.")
(license license:expat)))

And installed the series.

Thank you!

--
Maxim
Closed
?