[PATCH] gnu: Add ctrlr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 20 Mar 2023 22:38
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
20230320213819.26608-1-rekado@elephly.net
* gnu/packages/music.scm (ctrlr): New variable.
---
gnu/packages/music.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (85 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index acedfd4a26..489c5ba74c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -122,6 +122,7 @@ (define-module (gnu packages music)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages game-development)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
@@ -478,6 +479,70 @@ (define-public clementine
;; qocoa is under MIT and CC by-sa for the icons.
license:cc-by-sa3.0))))
+(define-public ctrlr
+ ;; The latest release from 2021 does not have a build system.
+ (let ((commit "8aa00d82127acda42ad9ac9b7b479461e9436aa4")
+ (revision "1"))
+ (package
+ (name "ctrlr")
+ (version (git-version "5.5.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RomanKubiak/ctrlr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lpfkjp9y0wh2kj02isv8ixnxn3wyvrxhkx0rybwzswfiz5kqdlm"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:cmake cmake ;needs 3.25
+ #:tests? #false ;there are none
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'pre-configure
+ (lambda _
+ ;; Override default location of fonts.conf. Without this no
+ ;; fonts will be rendered at all.
+ (substitute* "JUCE/modules/juce_graphics/native/juce_linux_Fonts.cpp"
+ (("/usr/share/fonts/fonts.conf")
+ "/run/current-system/profile/etc/fonts/fonts.conf"))
+ ;; Do not build the VST or AU plugins, because these require
+ ;; external proprietary SDKs.
+ (substitute* "CMakeLists.txt"
+ (("juce_set_vst2_sdk_path.*") "")
+ (("FORMATS VST3 VST AU Standalone")
+ "FORMATS Standalone")
+ ;; BFD also need -liberty.
+ (("list\\(APPEND ctrlrLibs \"bfd\"\\)" m)
+ (string-append m "
+list(APPEND ctrlrLibs \"iberty\")")))))
+ ;; The install target doesn't install ctrlr but JUCE helpers.
+ (replace 'install
+ (lambda _
+ (install-file "ctrlr_artefacts/RelWithDebInfo/Standalone/ctrlr"
+ (string-append #$output "/bin")))))))
+ (inputs
+ (list alsa-lib
+ boost
+ eudev
+ freetype
+ libiberty
+ libx11
+ webkitgtk))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://ctrlr.org/")
+ (synopsis "Control any MIDI-enabled hardware")
+ (description "Control any MIDI-enabled hardware: synthesizers, drum
+machines, samplers, effects. Create custom user interfaces for your MIDI
+hardware.")
+ (license (list license:gpl2+
+ license:gpl3 ;JUCE
+ license:bsd-3)))))
+
(define-public strawberry
(package
(name "strawberry")
--
2.39.2
N
N
Nicolas Goaziou wrote on 20 Mar 2023 23:20
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 62304@debbugs.gnu.org)
87jzzb2hgb.fsf@nicolasgoaziou.fr
Hello,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (2 lines)
> * gnu/packages/music.scm (ctrlr): New variable.

Thank you.

Toggle quote (4 lines)
> + (description "Control any MIDI-enabled hardware: synthesizers, drum
> +machines, samplers, effects. Create custom user interfaces for your MIDI
> +hardware.")

The description should consist of complete sentences only. Otherwise
LGTM (but I didn't built it.)

Regards,
--
Nicolas Goaziou
R
R
Ricardo Wurmus wrote on 20 Mar 2023 23:46
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 62304@debbugs.gnu.org)
87fs9zjazg.fsf@elephly.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (12 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * gnu/packages/music.scm (ctrlr): New variable.
>
> Thank you.
>
>> + (description "Control any MIDI-enabled hardware: synthesizers, drum
>> +machines, samplers, effects. Create custom user interfaces for your MIDI
>> +hardware.")
>
> The description should consist of complete sentences only.

Are they not? These are full sentences of encouragement.

Thanks for the review!

--
Ricardo
R
R
Ricardo Wurmus wrote on 21 Mar 2023 00:03
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 62304-done@debbugs.gnu.org)
87bkknja8d.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (16 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>
>> Ricardo Wurmus <rekado@elephly.net> writes:
>>
>>> * gnu/packages/music.scm (ctrlr): New variable.
>>
>> Thank you.
>>
>>> + (description "Control any MIDI-enabled hardware: synthesizers, drum
>>> +machines, samplers, effects. Create custom user interfaces for your MIDI
>>> +hardware.")
>>
>> The description should consist of complete sentences only.
>
> Are they not? These are full sentences of encouragement.

I’ve expanded the description a bit, replacing the exhortations with
more descriptive language.

--
Ricardo
Closed
?