[PATCH] gnu: Add r-affyilm, r-affyplm, r-affylmgui, r-annotationhubdata and r-tkrplot.

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 20 Mar 2023 16:57
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
be51027a78d6463a8fa3e56ebe066fb8@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-affyilm, r-affyplm, r-affylmgui, r-annotationhubdata): New variables.
* gnu/packages/cran.scm (r-tkrplot): New variable.
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 20 Mar 2023 17:00
[PATCH 2/5] gnu: Add r-affyplm.
(address . 62297@debbugs.gnu.org)
20230320160005.1594550-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-affyplm): New variable.
---
gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 48aa426574..1e3753b2ec 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2124,6 +2124,36 @@ (define-public r-affyilm
of the Langmuir model.")
(license license:gpl3)))
+(define-public r-affyplm
+ (package
+ (name "r-affyplm")
+ (version "1.74.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affyPLM" version))
+ (sha256
+ (base32 "0f0faxjzlg0znhjfvf1490yc54npkx659jx76cddm5hk7q0blv3v"))))
+ (properties `((upstream-name . "affyPLM")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-gcrma
+ r-preprocesscore
+ r-zlibbioc))
+ (home-page "https://github.com/bmbolstad/affyPLM")
+ (synopsis "Methods for fitting probe-level models")
+ (description
+ "The affyPLM provides a package that extends and improves the functionality
+of the base affy package. For speeding up the runs, it includes routines that make
+heavy use of compiled code. The central focus is on implementation of methods for
+fitting probe-level models and tools using these models. @acronym{PLM, Product
+Lifecycle Management} based quality assessment tools are also provided.")
+ (license license:gpl2+)))
+
(define-public r-affyrnadegradation
(package
(name "r-affyrnadegradation")
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 20 Mar 2023 17:00
[PATCH 5/5] gnu: Add r-annotationhubdata.
(address . 62297@debbugs.gnu.org)
20230320160005.1594550-5-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-annotationhubdata): New variable.
---
gnu/packages/bioconductor.scm | 53 +++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 78ce740c2c..8ebdcc3706 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2704,6 +2704,59 @@ (define-public r-animalcules
to understand their data better and discover new insights.")
(license license:artistic2.0)))
+(define-public r-annotationhubdata
+ (package
+ (name "r-annotationhubdata")
+ (version "1.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnnotationHubData" version))
+ (sha256
+ (base32 "0mcx09kcxccw2gkf4c3w7sxgb7v3gwbvahvx9wgq8f93q85yzg95"))))
+ (properties `((upstream-name . "AnnotationHubData")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'change-home-dir
+ (lambda _
+ ;; Change from /homeless-shelter to /tmp for write permission.
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list r-annotationdbi
+ r-annotationforge
+ r-annotationhub
+ r-biobase
+ r-bioccheck
+ r-biocgenerics
+ r-biocmanager
+ r-biocviews
+ r-biostrings
+ r-dbi
+ r-futile-logger
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-graph
+ r-iranges
+ r-jsonlite
+ r-organismdbi
+ r-rcurl
+ r-rsamtools
+ r-rsqlite
+ r-rtracklayer
+ r-s4vectors
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AnnotationHubData")
+ (synopsis "Transform public data resources into Bioconductor data structures")
+ (description
+ "These recipes convert a wide variety and a growing number of public bioinformatic
+data sets into easily-used standard Bioconductor data structures.")
+ (license license:artistic2.0)))
+
(define-public r-anvil
(package
(name "r-anvil")
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 20 Mar 2023 17:00
[PATCH 1/5] gnu: Add r-affyilm.
(address . 62297@debbugs.gnu.org)
20230320160005.1594550-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-affyilm): New variable.
---
gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e54c9ccf2b..48aa426574 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2098,6 +2098,32 @@ (define-public r-affixcan
expression values are known.")
(license license:gpl3)))
+(define-public r-affyilm
+ (package
+ (name "r-affyilm")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affyILM" version))
+ (sha256
+ (base32 "0i2hjaqjz06ym5kbw5da1h3cahc630mjwljsji1l2ks0gjcipll0"))))
+ (properties `((upstream-name . "affyILM")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affxparser
+ r-affy
+ r-biobase
+ r-gcrma))
+ (home-page "https://bioconductor.org/packages/affyILM")
+ (synopsis "Linear model of background subtraction and the Langmuir isotherm")
+ (description
+ "The affyILM package is a preprocessing tool which estimates gene expression
+levels for Affymetrix Gene Chips. Input from physical chemistry is employed to
+first background subtract intensities before calculating concentrations on behal
+of the Langmuir model.")
+ (license license:gpl3)))
+
(define-public r-affyrnadegradation
(package
(name "r-affyrnadegradation")

base-commit: 1f36534c7e8f2325bff4df5d37ecc811dc63fc38
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 20 Mar 2023 17:00
[PATCH 3/5] gnu: Add r-tkrplot.
(address . 62297@debbugs.gnu.org)
20230320160005.1594550-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-tkrplot): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 39e692fc6c..909943fdcc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2818,6 +2818,30 @@ (define-public r-tidyverse
single step.")
(license license:gpl3)))
+(define-public r-tkrplot
+ (package
+ (name "r-tkrplot")
+ (version "0.0-27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tkrplot" version))
+ (sha256
+ (base32 "19bj4wn1fs4wrx5k4gakhpz4q59fgx0584wyaw7hnh0ljj8i34n9"))))
+ (properties `((upstream-name . "tkrplot")))
+ (build-system r-build-system)
+ (inputs (list libx11))
+ (home-page "https://cran.r-project.org/package=tkrplot")
+ (synopsis "Simple mechanism for placing R graphics in a Tk widget")
+ (description
+ "The tkrplot package creates and returns a @dfn{Tk, cross-platform graphical
+user interface toolkit} label widget containing a Tk image of type Rplot. The plot
+is created by calling fun with a special device used create the image. The function
+@code{tkrreplot} calls fun to place a new plot in the Rplot widget lab. @code{
+tkpersp} is called like @code{persp} but produces a plot in which some of the
+parameters of persp are controlled graphically.")
+ (license (list license:gpl2+ license:gpl3+)))) ;; expanded from GPL
+
(define-public r-rvest
(package
(name "r-rvest")
--
2.39.2
M
M
M?d?lin Ionel Patra?cu wrote on 20 Mar 2023 17:00
[PATCH 4/5] gnu: Add r-affylmgui.
(address . 62297@debbugs.gnu.org)
20230320160005.1594550-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-affylmgui): New variable.
---
gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e3753b2ec..78ce740c2c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2124,6 +2124,37 @@ (define-public r-affyilm
of the Langmuir model.")
(license license:gpl3)))
+(define-public r-affylmgui
+ (package
+ (name "r-affylmgui")
+ (version "1.72.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affylmGUI" version))
+ (sha256
+ (base32 "0jds73pxqf522wcg8qd4b4k1qbhn51av5md1nhgcdnb6is0lzvxi"))))
+ (properties `((upstream-name . "affylmGUI")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-affyio
+ r-affyplm
+ r-annotationdbi
+ r-biocgenerics
+ r-biocmanager
+ r-gcrma
+ r-limma
+ r-r2html
+ r-tkrplot
+ r-xtable))
+ (home-page "http://bioinf.wehi.edu.au/affylmGUI/")
+ (synopsis "GUI for limma package with Affymetrix microarrays")
+ (description
+ "This package provides a @acronym{GUI, Graphical User Interface} for analysis
+of Affymetrix microarray gene expression data using the affy and limma packages.")
+ (license license:gpl2+)))
+
(define-public r-affyplm
(package
(name "r-affyplm")
--
2.39.2
R
R
Ricardo Wurmus wrote on 20 Mar 2023 19:33
Re: [bug#62297] [PATCH 1/5] gnu: Add r-affyilm.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 62297-done@debbugs.gnu.org)
87o7onjmpg.fsf@elephly.net
Thanks for the patches. I edited the formatting (M-q in Emacs) and
edited some of the descriptions.

Applied!

--
Ricardo
Closed
?