[PATCH 0/3]: gnu: Add cl-kons-9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230319142259.21692-1-sharlatanus@gmail.com
Hi Guix!

This patch series adds 3D modeling engine written in Common Lisp. It may be
used as IDE or as an library.

Sharlatan Hellseher (3):
gnu: Add cl-confidence.
gnu: Add cl-clobber
gnu: Add cl-kons-9.

gnu/packages/lisp-check.scm | 34 ++++++++++++++++
gnu/packages/lisp-xyz.scm | 80 +++++++++++++++++++++++++++++++++++++
2 files changed, 114 insertions(+)


base-commit: 34fed18169a5eae3169ff5fd2c43fe3af79e3b70
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/3] gnu: Add cl-confidence.
(address . 62273@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230319142441.21789-1-sharlatanus@gmail.com
* gnu/packages/lisp-check.scm (cl-confidence, ecl-confidence,
sbcl-confidence): New variables.
---
gnu/packages/lisp-check.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 172f5b3873..ed9c4ef568 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -378,6 +378,40 @@ (define-public cl-clunit2
(define-public ecl-clunit2
(sbcl-package->ecl-package sbcl-clunit2))
+(define-public sbcl-confidence
+ (let ((commit "5cbc74715348e12e689afb2d459dcb216c640a44")
+ (revision "0"))
+ (package
+ (name "sbcl-confidence")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/melusina-org/cl-confidence")
+ (commit commit)))
+ (file-name (git-file-name "cl-confidence" version))
+ (sha256
+ (base32 "0zc135rvq2valrw15bh8k6i53v7kk5l7x0kccb1bf7pglc8zgivs"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("org.melusina.confidence"
+ "org.melusina.confidence/testsuite")))
+ (inputs (list sbcl-alexandria))
+ (home-page "https://github.com/melusina-org/cl-confidence")
+ (synopsis "Interactive Test Framework for Common Lisp")
+ (description
+ "Confidence is a test framework for Common Lisp that focuses on simplicty. It
+avoids bureacracy and makes it easy to work interactively, without a complicated
+setup, and with explicit functions and decisions.")
+ (license license:expat))))
+
+(define-public ecl-confidence
+ (sbcl-package->ecl-package sbcl-confidence))
+
+(define-public cl-confidence
+ (sbcl-package->cl-source-package sbcl-confidence))
+
(define-public sbcl-eos
(let ((commit "b4413bccc4d142cbe1bf49516c3a0a22c9d99243")
(revision "2"))
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/3] gnu: Add cl-clobber
(address . 62273@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230319142441.21789-2-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (cl-clobber, ecl-clobber, sbcl-clobber):
New variables.
---
gnu/packages/lisp-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a1b291be20..ce8af93a8f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4612,6 +4612,36 @@ (define-public cl-ucons
(define-public ecl-ucons
(sbcl-package->ecl-package sbcl-ucons))
+(define-public sbcl-clobber
+ (let ((commit "212721c24a8bb792714314ba52dfe818641f2e98")
+ (revision "0"))
+ (package
+ (name "sbcl-clobber")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/robert-strandh/Clobber")
+ (commit commit)))
+ (file-name (git-file-name "clobber" version))
+ (sha256
+ (base32 "0pqzfn2wqbzzwlwc3l84iv3i3wa9zfgnh14mq67h9qkib8wjzx3n"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/robert-strandh/Clobber")
+ (synopsis "Common Lisp Library for transaction-oriented data bases")
+ (description
+ "CLOBER is an alternative to so-called \"object prevalence\", and in
+particular to @code{cl-prevalence}. Clobber is both simpler, more flexible, and
+more robust than systems based on object prevalence.")
+ (license license:bsd-3))))
+
+(define-public cl-clobber
+ (sbcl-package->cl-source-package sbcl-clobber))
+
+(define-public ecl-clobber
+ (sbcl-package->ecl-package sbcl-clobber))
+
(define-public sbcl-closer-mop
(let ((commit "7b86f2add029208ebc74ec6a41c2ccfd3c382dbc")
(revision "3"))
--
2.39.2
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/3] gnu: Add cl-kons-9.
(address . 62273@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230319142441.21789-3-sharlatanus@gmail.com
* gnu/packages/lisp-lisp.scm (cl-kons-9, sbcl-kons-9): New variables.
---
gnu/packages/lisp-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ce8af93a8f..4cd1f050c6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5450,6 +5450,56 @@ (define-public ecl-cl+ssl
(substitute-keyword-arguments (package-arguments pkg)
((#:tests? _ #f) #f))))))
+(define-public sbcl-kons-9
+ (let ((commit "fe0b3228ca28c316457d35f9e7c67edc83b2a4cc")
+ (revision "0"))
+ (package
+ (name "sbcl-kons-9")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kaveh808/kons-9")
+ (commit commit)))
+ (file-name (git-file-name "kons-9" version))
+ (sha256
+ (base32 "1kdwva4qj1s5vmbv6gbmpnk56ahaf8n2kvij5xjlfyk7nriy4bbi"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-systems '("kons-9" "kons-9/testsuite")))
+ (native-inputs
+ (list sbcl-alexandria sbcl-confidence))
+ (inputs
+ (list sbcl-closer-mop
+ sbcl-cffi
+ sbcl-cl-glfw3
+ sbcl-cl-opengl
+ sbcl-cl-vectors
+ sbcl-clobber
+ sbcl-origin
+ sbcl-trivial-backtrace
+ sbcl-trivial-main-thread
+ sbcl-zpb-ttf))
+ (home-page "https://github.com/kaveh808/kons-9")
+ (synopsis "Common Lisp 3D Graphics System")
+ (description
+ "This package provides KONS-9 which can be considered as a traditional user
+interface driven 3D application for general artists, or as a REPL-based
+development environment for technical artists and software developers. These two
+approaches can be seamlessly combined into a flexible and powerful workflow,
+where non-technical users can immediately benefit from software tools and
+extensions developed by technical users.")
+ (license license:expat))))
+
+(define-public cl-kons-9
+ (sbcl-package->cl-source-package sbcl-kons-9))
+
+;; TODO: (Sharlatan-20221110T230620+0000): ECL is not supported yet.
+;; https://github.com/kaveh808/kons-9/issues/176
+;; (deinfe-public ecl-kons-9
+;; (sbcl-package->ecl-package sbcl-kons-9))
+
(define-public sbcl-kmrcl
(let ((version "1.111")
(commit "4a27407aad9deb607ffb8847630cde3d041ea25a")
--
2.39.2
Guillaume Le Vaillant wrote 2 years ago
Re: [bug#62273] [PATCH 0/3]: gnu: Add cl-kons-9.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 62273-done@debbugs.gnu.org)
87o7oldsxo.fsf@kitej
Patches pushed as bad546939f3668610c173f931d905176e26c59c4 and following
with a few fixes.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZBrNQw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+IdAD+PpKspRqQLD7jzRCyJCAgCQsHpMsmFYWBZdV3
f7qBSfsA/2qHPdVM65PkqbTgmDO5bSEC5tgIum8NGzqleeDBqb1U
=V3Lc
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62273@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62273
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help