[PATCH] guix: Shorten URL for home page in texlive importer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 18 Mar 2023 14:13
(address . guix-patches@gnu.org)
20230318131319.272034-1-mail@nicolasgoaziou.fr
* guix/import/texlive.scm (tlpdb->package): Use short URL for home page.
---
guix/import/texlive.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (22 lines)
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index 82014ee568..e77b2a3f9a 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -286,9 +286,10 @@ (define (tlpdb->package name version package-database)
(string->symbol name)))
inputs))))))
'())
- ,@(or (and=> (assoc-ref data 'catalogue-ctan)
- (lambda (url)
- `((home-page ,(string-append "https://ctan.org" url)))))
+ ,@(or (and=> (assoc-ref data 'name)
+ (lambda (name)
+ `((home-page ,(string-append "https://www.ctan.org/pkg/"
+ name)))))
'((home-page "https://www.tug.org/texlive/")))
(synopsis ,(assoc-ref data 'shortdesc))
(description ,(beautify-description

base-commit: 3893758dac76fc30b23d4715e849e262306f268d
--
2.39.2
L
L
Ludovic Courtès wrote on 26 Mar 2023 16:19
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 62254@debbugs.gnu.org)
87mt3zbnna.fsf@gnu.org
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (2 lines)
> * guix/import/texlive.scm (tlpdb->package): Use short URL for home page.

[...]

Toggle quote (5 lines)
> + ,@(or (and=> (assoc-ref data 'name)
> + (lambda (name)
> + `((home-page ,(string-append "https://www.ctan.org/pkg/"
> + name)))))

Are there cases where ‘data’ might be missing ‘name’?

If not, please push!

Thanks,
Ludo’.
N
N
Nicolas Goaziou wrote on 30 Mar 2023 18:22
Re: [bug#62254] [PATCH] guix: Shorten URL for home page in texlive importer.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 62254-done@debbugs.gnu.org)
87o7oaky3j.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (7 lines)
>> + ,@(or (and=> (assoc-ref data 'name)
>> + (lambda (name)
>> + `((home-page ,(string-append "https://www.ctan.org/pkg/"
>> + name)))))
>
> Are there cases where ‘data’ might be missing ‘name’?

I don't think so. And even if assoc-ref returns #false, the template
would get the default home page.

Toggle quote (2 lines)
> If not, please push!

Done. Thanks for the feedback

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62254@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62254
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch