(address . guix-patches@gnu.org)
* guix/import/texlive.scm (tlpdb->package): Use short URL for home page.
---
guix/import/texlive.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
Toggle diff (22 lines)
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index 82014ee568..e77b2a3f9a 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -286,9 +286,10 @@ (define (tlpdb->package name version package-database)
(string->symbol name)))
inputs))))))
'())
- ,@(or (and=> (assoc-ref data 'catalogue-ctan)
- (lambda (url)
- `((home-page ,(string-append "https://ctan.org" url)))))
+ ,@(or (and=> (assoc-ref data 'name)
+ (lambda (name)
+ `((home-page ,(string-append "https://www.ctan.org/pkg/"
+ name)))))
'((home-page "https://www.tug.org/texlive/")))
(synopsis ,(assoc-ref data 'shortdesc))
(description ,(beautify-description
base-commit: 3893758dac76fc30b23d4715e849e262306f268d
--
2.39.2