Exception within (guix store) process-stderr when using suspendable ports

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
important
C
C
Christopher Baines wrote on 17 Mar 2023 12:04
(address . bug-guix@gnu.org)
87h6ujwrvx.fsf@cbaines.net
I'm seeing this in the build coordinator agent, but it can be reproduced
by tweaking the guix build script as below. The build coordinator uses
suspendable ports as this is required to set timeouts for some I/O
operations.

I'm guessing this is maybe a bug within Guile, but I thought I'd start
reporting it here anyway.


→ git diff
Toggle diff (98 lines)
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index 72a24f91ac..874108e482 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -64,6 +64,9 @@ (define-module (guix scripts build)
register-root
register-root*))
+(use-modules (ice-9 suspendable-ports))
+(install-suspendable-ports!)
+
(define %default-log-urls
;; Default base URLs for build logs.
'("http://ci.guix.gnu.org/log"))


→ ./pre-inst-env guix build --check /gnu/store/jz8nxdv8hx7d80vban2qq1a08pf1ilws-anthy-9100h.drv
The following derivation will be built:
/gnu/store/jz8nxdv8hx7d80vban2qq1a08pf1ilws-anthy-9100h.drv
building /gnu/store/jz8nxdv8hx7d80vban2qq1a08pf1ilws-anthy-9100h.drv...

...

starting phase `check'
./test_anthy --help to print usage.
ANTHY_ENABLE_DEBUG_PRINT=()
ANTHY_SPLITTER_PRINT=()
SRCDIR=(.)
anthy-9100h Fri Mar 17 10:59:29 2023
1:(???Τ??????)
|????|???????
????(???:(,1000,Nk,72089)223,026 ,????:(1N,1000,Nk,72089)222,744 ,???:(,1000,Nk,71001)210,785 ,????:(g,1000,Nk,71001)197,472 ,??:(1,1000,N,64031)196,095 ,?¤?:(,1000,Nk,71001)190,816 ,???:(,1000,Nk,71001)190,538 ,??:(1,1000,N,64031)177,837 ,???:(,1000,Nk,71001)166,409 ,¶??:(1,1000,TM,72089)112,640 ,¶??:(1,1000,TM,72089)112,358 ,??:(1,1000,N,72089)58,573 ,??:(1,1000,N,72089)51,814 ,??:(1,1000,N,7208)8,335 ,????:(1,1000,N,7208)8,307 ,????:(N,0,-)1 ,):
???????(?????:(,1000,Nk,72089)205,004 ,???????:(N,0,-)2 ,???????:(g,0,-)2 ,???????:(N,0,-)1 ,):

2:(??????Τ???????????ä????????????)
|??????|????|??????????|?????ä?????|????????
??????(????:(1,1000,Nk,6553)2500,001 ,????:(1,1000,N,66951)131,810 ,??????:(N,0,-)2 ,??????:(N,0,-)1 ,):
????(???:(,1000,Nk,6553)2500,001 ,???:(,1000,Nk,72089)218,520 ,???:(,1000,Nk,72089)216,268 ,????:(N,1000,Nk,72089)193,740 ,???:(,1000,Nk,72089)193,176 ,???:(,1000,Nk,72089)191,487 ,???:(,1000,Nk,72089)166,706 ,???:(,1000,Nk,6553)15,154 ,5??:(,1000,Nk,6553)7,168 ,????:(,1000,Nk,6553)7,142 ,???:(,1000,Nk,6553)7,117 ,????:(g,0,-)2 ,????:(N,0,-)1 ,):
??????????(?????:(,1000,Nk,48773)149,368 ,????:(,1000,Nk,70474)138,746 ,?????:(,1000,Nk,48773)96,022 ,??????????:(N,0,-)2 ,??????????:(g,0,-)2 ,??????????:(N,0,-)1 ,):
?????ä?????(??ä?????:(,1000,Vy,72089)225,279 ,??ä?????:(,1000,Vy,72089)216,268 ,?????ä?????:(N,1000,Vy,72089)195,992 ,??ä?????:(,1000,Vy,6553)19,455 ,?????å?????:(g,0,-)2 ,?????å?????:(N,0,-)1 ,):
????????(??????:(,1000,Ve,6553)20,479 ,??????:(,1000,Ve,6553)20,274 ,????????:(N,1000,Ve,6553)19,660 ,????????:(N,0,-)1 ,):

3:(???????????)
|??????|????????
??????(???:(1,1000,N,72089)218,520 ,???:(1,1000,N,7208)11,038 ,??????:(N,0,-)2 ,??????:(N,0,-)1 ,):
????????(????:(1,1000,N,7208)13,290 ,????????:(N,0,-)2 ,????????:(N,0,-)1 ,):

4:(?????Τ??ä?????????????)
|??????|???ä???|??????????
??????(???:(,1000,Nk,68423)213,822 ,???:(,1000,Nk,68423)211,684 ,???:(,1000,Nk,68423)211,417 ,??????:(N,1000,Nk,68423)186,026 ,???:(,1000,Nk,68423)185,758 ,???:(,1000,Nk,68423)181,749 ,???:(,1000,Nk,68423)153,952 ,??????:(g,0,-)2 ,??????:(N,0,-)1 ,):
???ä???(???ä???:(N,1000,Nk,62560)191,591 ,??????:(,1000,Nk,62560)142,716 ,???å???:(g,0,-)2 ,???å???:(N,0,-)1 ,):
??????????(??????????:(,1000,Ne,6553)20,479 ,?¤????????:(,1000,Ne,6553)20,274 ,??????????:(N,1000,Ne,6553)20,069 ,??????????:(,1000,Ne,6553)18,636 ,??????????:(,1000,Ne,655)1,986 ,??????????:(,1000,Ne,655)1,638 ,?????????:(,1000,Ne,655)1,618 ,??????????:(,1000,Ne,655)1,065 ,???Τ???????:(,1000,Ne,655)799 ,??????????:(N,0,-)1 ,):

5:(????????ä???????)
|????????|??ä???????
???????(???????:(1N,1000,N,57866)177,215 ,???????:(N,0,-)2 ,???????:(g,0,-)2 ,):
??ä???????(??ä???????:(N,1000,Ne,72089)225,279 ,??ä???????:(,1000,Ne,72089)223,026 ,???ä???????:(,1000,Ne,72089)222,744 ,?Τä???????:(,1000,Ne,72089)222,463 ,å?ä???????:(,1000,Ne,72089)222,181 ,??ä???????:(,1000,Ne,72089)218,520 ,??ä???????:(,1000,Ne,72089)216,268 ,??ä???????:(,1000,Ne,72089)214,015 ,??ä???????:(,1000,Ne,72089)213,733 ,???ä???????:(,1000,Ne,72089)202,751 ,??ä???????:(,1000,Ne,72089)202,469 ,??ü?????:(,1000,Ne,7208)17,345 ,??å???????:(N,0,-)1 ,):

6:(???ä??????????????????)
|???ä?????|??????????????
???ä?????(?????:(,1000,Nk,70285)215,248 ,???ä?????:(N,0,-)2 ,???å?????:(g,0,-)2 ,???å?????:(N,0,-)1 ,):
Backtrace:
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In unknown file:
17 (apply-smob/0 #<thunk 7f7723f4d2e0>)
In ice-9/boot-9.scm:
724:2 16 (call-with-prompt _ _ #<procedure default-prompt-handler (k proc)>)
In ice-9/eval.scm:
619:8 15 (_ #(#(#<directory (guile-user) 7f7723f52c80>)))
In guix/ui.scm:
2300:7 14 (run-guix . _)
2263:10 13 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 12 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/status.scm:
830:4 11 (call-with-status-report _ _)
In ice-9/boot-9.scm:
1752:10 10 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
659:37 9 (thunk)
1298:8 8 (call-with-build-handler _ _)
1298:8 7 (call-with-build-handler #<procedure 7f77219ebde0 at guix/ui.scm:1196:2 (continue store things mode)> _)
In guix/scripts/build.scm:
805:27 6 (_)
In guix/store.scm:
1417:15 5 (_ #<store-connection 256.99 7f7723ee8780> _ _)
736:20 4 (process-stderr _ _)
In ice-9/rdelim.scm:
160:18 3 (read-string _)
In ice-9/suspendable-ports.scm:
604:9 2 (read-char _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure integer->char: Argument 1 out of range: 1199972
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQUS9JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf9zw/+Prv0wzOwZrablwHmEmgsFfTnWDxp6gq+
triiqWRMdUnqp5s82BFrcAN97pkJUyk2CkAtJROv6+QP/LDjHedhCDexypBDlChL
mdTXJ3LKJJCmcTUsD3CEU1pSIpuOaTFNTn6fg8vNaBQYrryfCSOp4kKDUWbJuhcB
wJWZkEwVSGCiaiu4LDe2hN8tygmx//4GDYsswkrCU0lpyRA/wlCKQ11UAtRk2qT9
178UYdHAroFOs7Xs19yGoYYi8Iz4luk0gWVaW9YDdsPScSHBXXb6TxP0bk/gwmFf
WdRyKGiIlawqPmXqbpo8mDGh7BvQFvJ/EJgJDun6rQwTeB2mkHJF/O2zvi9CFz1P
gv8U+c5dWd8Y2YT9jZYhG3vwVLOiwPDzOdiBqbIxXgcLmXThVP52C40T8B3gEHnZ
3ezCseYe9LIsY8SD1G8SP3NYJRK2zvSz7nmFDlwsACTMo2awgCPLkDDilqcvQuCn
nwTjYqYkRppdwL/QXrltsTKON4QGk0VzXZ0dSs5hQk/B495QZbbCrdCZvycy4g+Q
WO6QhScPop6kH9Ta5eD63uFLnuMnQ1RLKd7+9uY4a+qDaSpdMk4dWako2EFYs9iw
/jAYVHYLpjSi0JeYBKO89Huri9QBAUDCvTE1PBaaSRt71ATDxAdvx8OU1ydLgx9M
TfX55EO4Mjo=
=ipFc
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 17 Mar 2023 12:19
control message for bug #62240
(address . control@debbugs.gnu.org)
87edpny69a.fsf@gnu.org
severity 62240 important
quit
C
C
Christopher Baines wrote on 17 Mar 2023 14:34
Re: bug#62240: Exception within (guix store) process-stderr when using suspendable ports
(name . Christopher Baines)(address . mail@cbaines.net)(address . 62240@debbugs.gnu.org)
878rfvwlet.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (8 lines)
> I'm seeing this in the build coordinator agent, but it can be reproduced
> by tweaking the guix build script as below. The build coordinator uses
> suspendable ports as this is required to set timeouts for some I/O
> operations.
>
> I'm guessing this is maybe a bug within Guile, but I thought I'd start
> reporting it here anyway.

I've sent a patch now to guile-devel that should fix this issue
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQUbJpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfklA/7BChUn+pqSFNpvbXpyRAHDVBx3gyUepKU
gftp38mDS7JKVCIibGCSMs2rHd8+5y4pPfckIZrKWY8gtxnAkqMf85/k9AbpTEVU
JJVGRCzobqg0MrZPh4URT9HnsvysbFxPk4nQVjPtOk7y6Mtwh2cdlujGo13NP0j+
wHDoAOmfrayis/6tVK9ROlou5bo7+ssu5Ode5sUcmqQ/MpSAdPUFVaKKLUkPY1fq
Zj+w1EO1ueq4c54TSmv0WWDtZ7ljjlZoDIA7LeJ9gThj/coR3ltoaIE5yv9V+hpR
/BdP5+oWH5a4pfM0VhOF0olj19xFOPSVvDVQp49LGUVSofs0C+EM08NjyfOq703o
LteaSPPTjzmKaJKeCzDDpBpn/YdbCYa3oQXjoAHoLjmcjBflk72bJpIEMg0WA+gk
vbDDufz7hBEoZCIrsPHoTgkna/gG0cNiA5FlfuxFXK90h9qsW/jZYKyxqc9JmVGH
rgXAIxL2OQQ4CgCp7PMLX+5BEp1zrNCY2LKyHBTPyfQFiZWrVL6P5TaZULwLl/Ra
vbYtneSZXVCbB63B6xdmW0VeKBNqONzeN4Y4+h8OVIvrwFoNcsjV8flsgMQ85Ndi
me2twBBeOO8maQ8v+jywAPQOk0RytA+GDn93M+PjdUGzIneZMj1Y965iGWxjgdMs
YjadOiCl4W0=
=Bhm1
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 17 Mar 2023 23:29
(address . 62240@debbugs.gnu.org)
87wn3fui37.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (13 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> I'm seeing this in the build coordinator agent, but it can be reproduced
>> by tweaking the guix build script as below. The build coordinator uses
>> suspendable ports as this is required to set timeouts for some I/O
>> operations.
>>
>> I'm guessing this is maybe a bug within Guile, but I thought I'd start
>> reporting it here anyway.
>
> I've sent a patch now to guile-devel that should fix this issue
> https://lists.gnu.org/archive/html/guile-devel/2023-03/msg00014.html

I've also now sent an update to the Guile package used by guix and the
guix-build-coordinator to include the patch sent upstream:

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQU6exfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd68BAAo+cIZIJrQEW6NrbCoW/2H7gYUm8AoY79
buyNa+kFoEq30znl+nRE4MudkQ3G3DYf3zd3683+Jal5iB/mOCC+sfO9s0xvtIwE
AHN8w02h4iAeU57P5AE5HwRkN5vfP73d2orJ1BSGRcVo8qBn8NWXFePqKIHyD8Ne
K5s2zqe3kiv1SWdzCVsmp6wJcVFsOg2lYZtAQDO/lpcZXMp4mjbCOEpQUGWSAgUK
UXJTfcXSl32zBRtdYdXrZWqNCaQgO86mRbaNpzMnKt3yF0eYkVv4JVPTgVNuDDfl
wDtgm60+c+T0NeuIBfgrHPVH8fV+IVmcIu9tAoxZLIwJn+t+ucPnigOO+NqhHrUo
hzhi+n7Q3P/cl+7k0Lls6NW1KGjKduQOd/cp5xmKPabetQDZgBB+5ZrxR5mJ9Sa/
GYSgUQEUUl/uQvbLVm2C8mah8fxxmBVdD+Id75TEwj97WN0clBqVM1I50OcLd3MV
L9DOnX/unIPygJ0wgL3hbS7Tdct93ub43F2j07v8bgNaDanhGUbs5MSEMVX26gXe
ScP0RZlzIxuJu4f3lhNvThChktKL5qqDpD6e1Y8Ut2vYkipJpA/djg6MgOGawd/N
z9zSdqyLmvTg7RD0JmHWohLYiiydUclenpTiLL32oQ9dj7vVzWC+L6dELFqTROxv
6UE3aZfZ0K8=
=yoce
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 2 Sep 2023 12:29
(address . 62240-done@debbugs.gnu.org)
87ttsceuk2.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (20 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> Christopher Baines <mail@cbaines.net> writes:
>>
>>> I'm seeing this in the build coordinator agent, but it can be reproduced
>>> by tweaking the guix build script as below. The build coordinator uses
>>> suspendable ports as this is required to set timeouts for some I/O
>>> operations.
>>>
>>> I'm guessing this is maybe a bug within Guile, but I thought I'd start
>>> reporting it here anyway.
>>
>> I've sent a patch now to guile-devel that should fix this issue
>> https://lists.gnu.org/archive/html/guile-devel/2023-03/msg00014.html
>
> I've also now sent an update to the Guile package used by guix and the
> guix-build-coordinator to include the patch sent upstream:
>
> https://issues.guix.gnu.org/62243

Delayed marking as done.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmTzDs1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf5iA/+M8TwI9L7EOOol/RQ4Iupq3fCxXTTy52X
/ybfWSs+nQ80qQ0Oy8q3mzYKVkXuivKTlEVvI6BDrZmZFkb9IlsN+2HccJTz01a1
XZs3NZm+UM63Ci8wUWhy0FQbHbqGR1mhoE7o21NrJeQt7YFzWTKDQKS8o8+ZA380
S274ejkCjTq3K8JNnFt7VAP4JrIifFBNX6Q6Wlhd2UbK5jWZioGsXJAL3gc0+c3A
tntctDiE0zsQcYKdS8tCAahz3ktknKE8XiVcR4mCE4lWuuj0xu+gxCk2U+XjO4k9
aam5FlOGLNQFNYdr6HgHcfOT6oNQTv8vs56b8fBL5loLYE1Ct7Hi64AV74CVjf7g
qSVBb7GXNyXxV/cmEtsNTuvTB177OZHkdXtl1nQ6QBq93faSQJsImFQu8KYpwYcS
1H2wv7Fq8oZTm+XUZoQRRBcLLJEQWEiAmm4Y7QvoJoTribXuhQuGEo/3iCi1NZZt
KWWEWglcpWTHw7IZkABX0SpClBvV0pKGPBPwrKtM1xdz+kgizu2jjq+WDzPvpODf
ONxWO01ZcRnGOe0AJtm/tYaVrG0GEm8HOiHxlWSY50u2uCBgQV8w4PuUDxzPY0rP
2DtWls33iECOTde1dGPGA3u8pytNcus9U+5j1dueAjVZHNeIQlOSoQsRWPmp61C3
aa161QiuA9c=
=KRGH
-----END PGP SIGNATURE-----

Closed
?