[PATCH 0/5] gnu: reuse: Update to 1.1.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 14 Mar 2023 19:23
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1678818100.git.mirai@makinata.eu
Bruno Victal (5):
gnu: python-debian: Patch using snippet. Drop workaround.
gnu: python-debian: Update to 0.1.49.
gnu: python-boolean.py: Update to 4.0.
gnu: python-license-expression: Update to 30.1.0.
gnu: reuse: Update to 1.1.2.

gnu/packages/license.scm | 12 ++++----
gnu/packages/python-xyz.scm | 56 ++++++++++++++++++-------------------
2 files changed, 33 insertions(+), 35 deletions(-)

--
2.39.1
B
B
Bruno Victal wrote on 14 Mar 2023 19:27
[PATCH 2/5] gnu: python-debian: Update to 0.1.49.
(address . 62191@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
95f5bac48bde535caee2e07bf7f0ab405359eb7c.1678818381.git.mirai@makinata.eu
* gnu/packages/python-xyz.scm (python-debian): Update to 0.1.49.
[native-inputs]: Add python-pytest.
---
gnu/packages/python-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4fe84e1eec..f6da4ae9b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13631,7 +13631,7 @@ (define-public python-debian
(package
(name "python-debian")
(home-page "https://salsa.debian.org/python-debian-team/python-debian")
- (version "0.1.36")
+ (version "0.1.49")
(source
(origin
;; Use git-fetch, as pypi doesn't include test suite.
@@ -13642,7 +13642,7 @@ (define-public python-debian
(file-name (git-file-name name version))
(sha256
(base32
- "0qy6x28bj6yfikhjww932v5xq4mf5bm1iczl7acy4c7zm6mwhqfa"))
+ "190vy2ns0650icpwvv4qp6kr3c3i9jszy1vkdwpigxb96fs1bqf3"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -13658,6 +13658,8 @@ (define-public python-debian
(substitute* "lib/debian/_version.py"
(("__CHANGELOG_VERSION__") #$version))))))
(build-system python-build-system)
+ (native-inputs
+ (list python-pytest))
(propagated-inputs
(list python-six python-chardet))
(synopsis "Debian package related modules")
--
2.39.1
B
B
Bruno Victal wrote on 14 Mar 2023 19:27
[PATCH 3/5] gnu: python-boolean.py: Update to 4.0.
(address . 62191@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
be176d7e64f87404546efda8d06561d579820001.1678818381.git.mirai@makinata.eu
* gnu/packages/python-xyz.scm (python-boolean.py): Update to 4.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f6da4ae9b2..6232393864 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1732,7 +1732,7 @@ (define-public python-bitarray
(define-public python-boolean.py
(package
(name "python-boolean.py")
- (version "3.6")
+ (version "4.0")
(source
(origin
;; There's no source tarball on PyPI.
@@ -1742,7 +1742,7 @@ (define-public python-boolean.py
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1wc89y73va58cj7dsx6c199zpxsy9q53dsffsdj6zmc90inqz6qs"))))
+ (base32 "1s4mrgqf1phwvda81dpnlkdadcbjgpl8mjvmc1yjlrp1c368v9lb"))))
(build-system python-build-system)
(home-page "https://github.com/bastikr/boolean.py")
(synopsis "Boolean algebra in one Python module")
--
2.39.1
B
B
Bruno Victal wrote on 14 Mar 2023 19:27
[PATCH 5/5] gnu: reuse: Update to 1.1.2.
(address . 62191@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
acb998549e27f61a00b10090fb5e832f97e30477.1678818382.git.mirai@makinata.eu
* gnu/packages/license.scm (reuse): Update to 1.1.2.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-poetry-core. Remove python-setuptools-scm.
[inputs]: Remove python-requests.
---
gnu/packages/license.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 3146f38c1c..ca8375d19d 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages license)
#:use-module (gnu packages python-xyz)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix licenses)
@@ -169,23 +170,22 @@ (define-public licensecheck
(define-public reuse
(package
(name "reuse")
- (version "1.0.0")
+ (version "1.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "reuse" version))
(sha256
- (base32 "1m78q5x19xvhywi1xl0prrag89ihvqiq14lba27rrxl75nz24c6v"))))
- (build-system python-build-system)
+ (base32 "0ij2mpdnawjabnsy291157wzci9050dfclwib95phg7pnmd6xsw0"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-setuptools-scm))
+ (list python-poetry-core python-pytest))
(inputs
(list python-binaryornot
python-boolean.py
python-debian
python-jinja2
- python-license-expression
- python-requests))
+ python-license-expression))
(home-page "https://reuse.software/")
(synopsis "Provide and verify copyright and licensing information")
(description
--
2.39.1
B
B
Bruno Victal wrote on 14 Mar 2023 19:27
[PATCH 4/5] gnu: python-license-expression: Update to 30.1.0.
(address . 62191@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
624ae4f8b56812e77f422fa18410af57b6b2a5cd.1678818381.git.mirai@makinata.eu
* gnu/packages/python-xyz.scm (python-license-expression): Update to 30.1.0.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-setuptools-scm and python-pytest.
---
gnu/packages/python-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6232393864..c769157040 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2089,14 +2089,16 @@ (define-public python-ncls
(define-public python-license-expression
(package
(name "python-license-expression")
- (version "1.2")
+ (version "30.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "license-expression" version))
(sha256
- (base32 "1g0sgphss8hbi1rpl4avy1nmbixmy9v194xdbvkjgl90vzgy2q3r"))))
- (build-system python-build-system)
+ (base32 "0lvshl2fhwa568d3y3vmx45hdp8gk5w9yl3b2q5d66r5vqn1sfwl"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools-scm python-pytest))
(propagated-inputs
(list python-boolean.py))
(home-page "https://github.com/nexB/license-expression")
--
2.39.1
B
B
Bruno Victal wrote on 14 Mar 2023 19:27
[PATCH 1/5] gnu: python-debian: Patch using snippet. Drop workaround.
(address . 62191@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
2886a0ae8e95dc077ebc545e2d7e224f1fe133d4.1678818381.git.mirai@makinata.eu
* gnu/packages/python-xyz.scm (python-debian)
[source]: Prefer patching using snippet to modify-phases.
[arguments]: Remove, logic was moved into source.
[description]: Drop obsolete workaround.
---
gnu/packages/python-xyz.scm | 40 ++++++++++++++++---------------------
1 file changed, 17 insertions(+), 23 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 81c9d93c9c..4fe84e1eec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13642,34 +13642,29 @@ (define-public python-debian
(file-name (git-file-name name version))
(sha256
(base32
- "0qy6x28bj6yfikhjww932v5xq4mf5bm1iczl7acy4c7zm6mwhqfa"))))
+ "0qy6x28bj6yfikhjww932v5xq4mf5bm1iczl7acy4c7zm6mwhqfa"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; python-apt, apt and dpkg are not yet available in guix,
+ ;; and these tests heavily depend on them.
+ (for-each delete-file
+ '("lib/debian/tests/test_deb822.py"
+ "lib/debian/tests/test_debfile.py"))
+
+ ;; for reproducible builds, otherwise python-debian
+ ;; generates a _version.py including the date
+ (copy-file "lib/debian/_version.py.in" "lib/debian/_version.py")
+ (substitute* "lib/debian/_version.py"
+ (("__CHANGELOG_VERSION__") #$version))))))
(build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'set-version
- ;; for reproducible builds, otherwise python-debian
- ;; generates a _version.py including the date
- (lambda _
- (copy-file "lib/debian/_version.py.in" "lib/debian/_version.py")
- (substitute* "lib/debian/_version.py"
- (("__CHANGELOG_VERSION__") ,version))))
- (add-after 'unpack 'remove-debian-specific-tests
- ;; python-apt, apt and dpkg are not yet available in guix,
- ;; and these tests heavily depend on them.
- (lambda _
- (delete-file "lib/debian/tests/test_deb822.py")
- (delete-file "lib/debian/tests/test_debfile.py")
- #t)))))
(propagated-inputs
(list python-six python-chardet))
(synopsis "Debian package related modules")
(description
- ;; XXX: Use @enumerate instead of @itemize to work around
- ;; <http://bugs.gnu.org/21772>.
"This package provides Python modules that abstract many formats of
Debian-related files, such as:
-
-@enumerate
+@itemize
@item Debtags information;
@item @file{debian/changelog} files;
@item packages files, pdiffs;
@@ -13677,8 +13672,7 @@ (define-public python-debian
@file{debian/control}, @file{.changes}, @file{.dsc};
@item Raw @file{.deb} and @file{.ar} files, with (read-only) access to
contained files and meta-information.
-@end enumerate\n")
-
+@end itemize")
;; Modules are either GPLv2+ or GPLv3+.
(license license:gpl3+)))
--
2.39.1
N
N
Nicolas Goaziou wrote on 3 Apr 2023 20:58
Re: [bug#62191] [PATCH 0/5] gnu: reuse: Update to 1.1.2.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 62191-done@debbugs.gnu.org)
87ilecoksi.fsf@nicolasgoaziou.fr
Hello,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (7 lines)
> Bruno Victal (5):
> gnu: python-debian: Patch using snippet. Drop workaround.
> gnu: python-debian: Update to 0.1.49.
> gnu: python-boolean.py: Update to 4.0.
> gnu: python-license-expression: Update to 30.1.0.
> gnu: reuse: Update to 1.1.2.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?