[PATCH 1/2] gnu: Add r-premessa.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230314150130.39995-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-premessa): New variable.
---
gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 06f9eb8ee3..7025ccd93d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8803,6 +8803,43 @@ (define-public r-pando
regions for each transcription factor.")
(license license:expat)))
+(define-public r-premessa
+ (let ((commit "68b42bb984637d0f3ad6a0ecc83e9278994afc85")
+ (revision "1"))
+ (package
+ (name "r-premessa")
+ (version (git-version "0.3.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ParkerICI/premessa")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l0q431zk0lvg22130nx84gdqi7cpl05yah4am63lbx6m4c769pb"))))
+ (properties `((upstream-name . "premessa")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table
+ r-flowcore
+ r-ggplot2
+ r-gridextra
+ r-hexbin
+ r-jsonlite
+ r-reshape
+ r-rhandsontable
+ r-shiny
+ r-shinyjqui))
+ (native-inputs (list esbuild))
+ (home-page "https://github.com/ParkerICI/premessa")
+ (synopsis
+ "This package is for pre-processing of flow and mass cytometry data")
+ (description
+ "This is an R package for pre-processing of flow and mass cytometry data.
+This package includes panel editing or renaming for FCS files, bead-based
+normalization and debarcoding.")
+ (license license:gpl3))))
+
(define-public r-presto
(let ((commit "052085db9c88aa70a28d11cc58ebc807999bf0ad")
(revision "0"))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 62187-done@debbugs.gnu.org)
875yb342wc.fsf@elephly.net
Pushed with commit 204c51cac44809dc352c86bb33332fc75e2b0056.
I had to replace the bundled d3.min.js with a variant built from source.

Note that this is why the importer added esbuild (a JS compiler/bundler)
to the native inputs.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62187@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62187
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help