* (rust-1.66): New variable.
---
gnu/packages/rust.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
Toggle diff (31 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 133c46fb7c..eb3721a0c3 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
;;; Copyright © 2020, 2021 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2020, 2023 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
@@ -653,6 +653,15 @@ (define rust-1.65
(patches '())
(patch-flags '("-p1")))))))
+(define rust-1.66
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.64. e.g.:
+ ;; * error[E0718]: `transmute_trait` language item must be applied to a trait with 6 generic arguments
+ ;; * error[E0522]: definition of an unknown language item: `transmute_opts`
+ ;; * error[E0093]: unrecognized intrinsic function: `ptr_mask`
+ ;; * error[E0232]: this attribute must have a valid value
+ rust-1.65 "1.66.1" "1fjr94gsicsxd2ypz4zm8aad1zdbiccr7qjfbmq8f8f7jhx96g2v"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
--
2.39.1