[PATCH 0/3] Package recent Rust versions

  • Open
  • quality assurance status badge
Details
2 participants
  • Matthew James Kraai
  • Simon Tournier
Owner
unassigned
Submitted by
Matthew James Kraai
Severity
normal
M
M
Matthew James Kraai wrote on 14 Mar 2023 13:14
(address . guix-patches@gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20230314121451.2003-1-kraai@ftbfs.org
Package recent versions of Rust.

Matthew James Kraai (3):
gnu: Add rust-1.66.
gnu: Add rust-1.67.
gnu: Add rust-1.68.

gnu/packages/rust.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

--
2.39.1
M
M
Matthew James Kraai wrote on 14 Mar 2023 13:21
[PATCH 1/3] gnu: Add rust-1.66.
(address . 62184@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20230314122120.2073-1-kraai@ftbfs.org
* (rust-1.66): New variable.
---
gnu/packages/rust.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 133c46fb7c..eb3721a0c3 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
;;; Copyright © 2020, 2021 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2020, 2023 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
@@ -653,6 +653,15 @@ (define rust-1.65
(patches '())
(patch-flags '("-p1")))))))
+(define rust-1.66
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.64. e.g.:
+ ;; * error[E0718]: `transmute_trait` language item must be applied to a trait with 6 generic arguments
+ ;; * error[E0522]: definition of an unknown language item: `transmute_opts`
+ ;; * error[E0093]: unrecognized intrinsic function: `ptr_mask`
+ ;; * error[E0232]: this attribute must have a valid value
+ rust-1.65 "1.66.1" "1fjr94gsicsxd2ypz4zm8aad1zdbiccr7qjfbmq8f8f7jhx96g2v"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
--
2.39.1
M
M
Matthew James Kraai wrote on 14 Mar 2023 13:21
[PATCH 2/3] gnu: Add rust-1.67.
(address . 62184@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20230314122120.2073-2-kraai@ftbfs.org
* (rust-1.67): New variable.
---
gnu/packages/rust.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index eb3721a0c3..a4d9fa1593 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -662,6 +662,12 @@ (define rust-1.66
;; * error[E0232]: this attribute must have a valid value
rust-1.65 "1.66.1" "1fjr94gsicsxd2ypz4zm8aad1zdbiccr7qjfbmq8f8f7jhx96g2v"))
+(define rust-1.67
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.65. e.g.:
+ ;; * error[E0277]: the trait bound `T: ~const Deref` is not satisfied
+ rust-1.66 "1.67.1" "0vpzv6rm3w1wbni17ryvcw83k5klhghklylfdza3nnp8blz3sj26"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
--
2.39.1
M
M
Matthew James Kraai wrote on 14 Mar 2023 13:21
[PATCH 3/3] gnu: Add rust-1.68.
(address . 62184@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20230314122120.2073-3-kraai@ftbfs.org
* (rust-1.68): New variable.
---
gnu/packages/rust.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a4d9fa1593..18f6ea9096 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -668,6 +668,12 @@ (define rust-1.67
;; * error[E0277]: the trait bound `T: ~const Deref` is not satisfied
rust-1.66 "1.67.1" "0vpzv6rm3w1wbni17ryvcw83k5klhghklylfdza3nnp8blz3sj26"))
+(define rust-1.68
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.66. e.g.:
+ ;; * error: cannot find a built-in macro with name `derive_const`
+ rust-1.67 "1.68.0" "0qkdm4naj729bl72pl513p0xxpmcwyskmd8gfyj358i3kyqxix7a"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
--
2.39.1
M
M
Matthew James Kraai wrote on 25 Mar 2023 22:07
[PATCH] gnu: Add rust-1.68.
(address . 62184@debbugs.gnu.org)(name . Matthew James Kraai)(address . kraai@ftbfs.org)
20230325210701.22214-1-kraai@ftbfs.org
* (rust-1.68): New variable.
---
gnu/packages/rust.scm | 6 ++++++
1 file changed, 6 insertions(+)

Here's an updated third patch that packages 1.68.1 instead of 1.68.0.

Toggle diff (19 lines)
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a4d9fa1593..b0b940f517 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -668,6 +668,12 @@ (define rust-1.67
;; * error[E0277]: the trait bound `T: ~const Deref` is not satisfied
rust-1.66 "1.67.1" "0vpzv6rm3w1wbni17ryvcw83k5klhghklylfdza3nnp8blz3sj26"))
+(define rust-1.68
+ (rust-bootstrapped-package
+ ;; Verified that it *doesn't* build with 1.66. e.g.:
+ ;; * error: cannot find a built-in macro with name `derive_const`
+ rust-1.67 "1.68.1" "00sxlakbhbfx74zanp8nkc5flziywy1qymfhwf4cbm01azgm3c6c"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
--
2.39.2
S
S
Simon Tournier wrote on 4 Apr 2023 13:29
Re: [bug#62184] [PATCH 0/3] Package recent Rust versions
86wn2rubqd.fsf@gmail.com
Hi,

On Tue, 14 Mar 2023 at 05:14, Matthew James Kraai <kraai@ftbfs.org> wrote:
Toggle quote (7 lines)
> Package recent versions of Rust.
>
> Matthew James Kraai (3):
> gnu: Add rust-1.66.
> gnu: Add rust-1.67.
> gnu: Add rust-1.68.

What is the point to add these packages? Are they functional? Because
as written elsewhere,

rust != rust-1.60

because all the ’arguments’ field part of rust.

If the aim is to upgrade the Rust ecosystem, then it appears to me
better to do that in a dedicated branch instead of a work in progress
directly in the branch master.

Closing?


Cheers,
simon
?