[PATCH core-updates 0/4] gnu: inetutils: Update to 2.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 Mar 2023 02:19
[PATCH 0/4] gnu: inetutils: Update to 2.4.
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cover.1678669618.git.felix.lechner@lease-up.com
Below please find a patch to update GNU Inetutils to the latest version.

There are some remaining 'lint' warnings.

Toggle quote (2 lines)
> gnu/packages/admin.scm:937:12: inetutils@2.4: label 'coreutils*' does not match package name 'coreutils'

I was unable to convert the regular inputs due to the asterisk in coreutils.

Toggle quote (4 lines)
> gnu/packages/admin.scm:948:5: inetutils@2.4: proposed description:
> "Inetutils is a collection of common network programs, such as an ftp
> client and server, a telnet client and server, and an rsh client and server."

The suggested description leaves out the 'hostname' command.

Toggle quote (2 lines)
> gnu/packages/admin.scm:900:12: inetutils@2.4: source not archived on Software Heritage and missing from the Disarchive database

We could pull the sources from Git, but Guix seems to prefer tarballs.

Finally, there is a compilation warning related to the ordering of
(define-public ...). 'shadow' follows immediately below.

Toggle quote (3 lines)
> guix build: error: gnu/packages/admin.scm:897:2: package `inetutils@2.4' has an invalid input: #<package shadow@4.9
> gnu/packages/admin.scm:955 7f15cd722c60>"

Felix Lechner (4):
gnu: Update inetutils to 2.4; use tar.xz.
gnu: inetutils: Convert to gexp.
gnu: inetutils: Use new-style inputs.
gnu: inetutils: Apply formatting rules (non-functional change).

gnu/packages/admin.scm | 68 ++++++++++++++++++++++--------------------
1 file changed, 35 insertions(+), 33 deletions(-)


base-commit: 9584b1daa687d1212550841d1c5f62e7ffa44ffc
--
2.39.1
F
F
Felix Lechner wrote on 13 Mar 2023 02:21
[PATCH 1/4] gnu: Update inetutils to 2.4; use tar.xz.
(address . 62154@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
95cba5e657bdc5dbef058764043726cb5ed078ab.1678669618.git.felix.lechner@lease-up.com
* gnu/packages/admin.scm (inetutils): Update to 2.4; use tar.xz
---
gnu/packages/admin.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index eba4378cf8..77c7577cfa 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -896,14 +896,14 @@ (define-public pies
(define-public inetutils
(package
(name "inetutils")
- (version "2.0")
+ (version "2.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/inetutils/inetutils-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "0j1nb69bhg29cm4xkqqjh2ln1zqcj2lnpm92v638lpwrs11dypxl"))))
+ "1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/var"
--
2.39.1
F
F
Felix Lechner wrote on 13 Mar 2023 02:21
[PATCH 2/4] gnu: inetutils: Convert to gexp.
(address . 62154@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
9068daeaf9a19703a1be22178c0e34cbf1d54cef.1678669618.git.felix.lechner@lease-up.com
* gnu/packages/admin.scm (inetutils): Convert to gexp.
---
gnu/packages/admin.scm | 52 ++++++++++++++++++++++--------------------
1 file changed, 27 insertions(+), 25 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 77c7577cfa..8147274b77 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -906,32 +906,34 @@ (define-public inetutils
"1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--localstatedir=/var"
+ (list
+ #:configure-flags
+ #~(list "--localstatedir=/var"
- ;; Make sure 'PATH_PROCNET_DEV' gets defined when
- ;; cross-compiling (by default it does not.)
- ,@(if (%current-target-system)
- '("--with-path-procnet-dev=/proc/net/dev")
- '())
- ,@(if (hurd-target?)
- '("--disable-rcp"
- "--disable-rexec"
- "--disable-rexecd"
- "--disable-rlogin"
- "--disable-rlogind"
- "--disable-rsh"
- "--disable-rshd"
- "--disable-uucpd"
- "--disable-whois")
- '()))
- ;; Make sure that canonical "coreutils" package is not referred.
- #:make-flags
- (list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
- (assoc-ref %build-inputs "coreutils*")
- "/bin/cp\\\""))
- ;; On some systems, 'libls.sh' may fail with an error such as:
- ;; "Failed to tell switch -a apart from -A".
- #:parallel-tests? #f))
+ ;; Make sure 'PATH_PROCNET_DEV' gets defined when
+ ;; cross-compiling (by default it does not.)
+ #$@(if (%current-target-system)
+ '("--with-path-procnet-dev=/proc/net/dev")
+ '())
+ #$@(if (hurd-target?)
+ '("--disable-rcp"
+ "--disable-rexec"
+ "--disable-rexecd"
+ "--disable-rlogin"
+ "--disable-rlogind"
+ "--disable-rsh"
+ "--disable-rshd"
+ "--disable-uucpd"
+ "--disable-whois")
+ '()))
+ ;; Make sure that canonical "coreutils" package is not referred.
+ #:make-flags
+ #~(list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
+ #$(this-package-input "coreutils*")
+ "/bin/cp\\\""))
+ ;; On some systems, 'libls.sh' may fail with an error such as:
+ ;; "Failed to tell switch -a apart from -A".
+ #:parallel-tests? #f))
(inputs `(("coreutils*" ,coreutils)
("shadow" ,shadow) ;for login (used in telnetd and rlogind)
("ncurses" ,ncurses)
--
2.39.1
F
F
Felix Lechner wrote on 13 Mar 2023 02:21
[PATCH 3/4] gnu: inetutils: Use new-style inputs.
(address . 62154@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cfb948c1c2daa5966db0c57b8e57304a7fbea0f3.1678669618.git.felix.lechner@lease-up.com
* gnu/packages/admin.scm (inetutils): Use new-style inputs.
---
gnu/packages/admin.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8147274b77..6c1c1aca1e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -940,7 +940,7 @@ (define-public inetutils
("readline" ,readline))) ;for 'ftp'
(native-inputs (if (member (%current-system)
(package-supported-systems net-tools))
- `(("netstat" ,net-tools)) ;for tests
+ (list net-tools) ;for tests
'()))
(home-page "https://www.gnu.org/software/inetutils/")
(synopsis "Basic networking utilities")
--
2.39.1
F
F
Felix Lechner wrote on 13 Mar 2023 02:21
[PATCH 4/4] gnu: inetutils: Apply formatting rules (non-functional change).
(address . 62154@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cc423505b091f3764828e9e8b75e3006364f6b55.1678669618.git.felix.lechner@lease-up.com
* gnu/packages/admin.scm (inetutils): Apply formatting rules (non-functional
change).
---
gnu/packages/admin.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6c1c1aca1e..5a0e12d05c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -898,12 +898,12 @@ (define-public inetutils
(name "inetutils")
(version "2.4")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/inetutils/inetutils-"
- version ".tar.xz"))
- (sha256
- (base32
- "1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/inetutils/inetutils-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
(build-system gnu-build-system)
(arguments
(list
--
2.39.1
F
F
Felix Lechner wrote on 14 Mar 2023 17:27
(address . control@debbugs.gnu.org)
CAFHYt55Suaq4=a9cWf0=APvEtf2ypP8Kh0KEBn9Kn3TQQPf1nQ@mail.gmail.com
retitle 62154 [PATCH wip-inetutils 0/4] gnu: inetutils: Update to 2.4.
thanks
F
F
Felix Lechner wrote on 16 Mar 2023 21:33
(address . control@debbugs.gnu.org)
CAFHYt54h7i3yT8OptPXXQX5nFWO2Z7r=nKGop+Cszv+3hU7NiA@mail.gmail.com
retitle 62154 [PATCH core-updates 0/4] gnu: inetutils: Update to 2.4.
thanks
M
M
Maxim Cournoyer wrote on 20 Jan 20:50 +0100
Re: [bug#62154] [PATCH 4/4] gnu: inetutils: Apply formatting rules (non-functional change).
(name . Felix Lechner)(address . felix.lechner@lease-up.com)(address . 62154-done@debbugs.gnu.org)
87a5ozg4xo.fsf@gmail.com
Hi Felix,

Felix Lechner <felix.lechner@lease-up.com> writes:

Toggle quote (30 lines)
> * gnu/packages/admin.scm (inetutils): Apply formatting rules (non-functional
> change).
> ---
> gnu/packages/admin.scm | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 6c1c1aca1e..5a0e12d05c 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -898,12 +898,12 @@ (define-public inetutils
> (name "inetutils")
> (version "2.4")
> (source (origin
> - (method url-fetch)
> - (uri (string-append "mirror://gnu/inetutils/inetutils-"
> - version ".tar.xz"))
> - (sha256
> - (base32
> - "1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
> + (method url-fetch)
> + (uri (string-append "mirror://gnu/inetutils/inetutils-"
> + version ".tar.xz"))
> + (sha256
> + (base32
> + "1ck81y6x0bk1qaripfsrbfzrrzaxkzp37ddpg8mgwzd5n6qxd28p"))))
> (build-system gnu-build-system)
> (arguments
> (list

I've applied the parts that hadn't been made already to core-updates,
except the "this-package-input" change in the configure flags, which I
think is best suited for a search-input-file (it provides better error
reporting in case something is wrong).

--
Thanks,
Maxim
Closed
?