[PATCH] gnu: Add cyanrip.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • simon
  • mio
Owner
unassigned
Submitted by
simon
Severity
normal
S
(address . guix-patches@gnu.org)(name . Simon Streit)(address . simon@netpanic.org)
f5976557a40b431949c1813593b390aa35431b2e.1678573776.git.simon@netpanic.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/audio.scm (cyanrip): New variable.
---
gnu/packages/audio.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6f3fa2a580..966a0b96f9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
-;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2022, 2023 Simon Streit <simon@netpanic.org>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
@@ -68,6 +68,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages cdrom)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -124,6 +125,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages linux)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
#:use-module (gnu packages web)
@@ -6316,3 +6318,29 @@ (define-public cubeb
(description "Cubeb is Mozilla's cross-platform audio library.")
(home-page "https://github.com/mozilla/cubeb")
(license license:isc))))
+
+(define-public cyanrip
+ (package
+ (name "cyanrip")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cyanreg/cyanrip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pf381qmqr3p3xk26w8v4gfv5cyi5siljs4gv485spsq6icynzw0"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config))
+ (propagated-inputs
+ (list curl ffmpeg libcdio-paranoia libmusicbrainz libxml2 neon))
+ (synopsis "Fully featured CD ripping program")
+ (description "Console CD ripper with automatic tagging through integration
+with MusicBrainz , error detection, log generation, many formats, HDCD
+decoding, covert art automatic download.")
+ (home-page "https://github.com/cyanreg/cyanrip")
+ (license license:lgpl2.1+)))
--
2.39.1
L
L
Liliana Marie Prikler wrote on 13 Mar 2023 21:42
6a0ba9b42f98d0cf7efc7f16ae21ac05088e80b8.camel@gmail.com
Am Samstag, dem 11.03.2023 um 23:30 +0100 schrieb simon@netpanic.org:
Toggle quote (62 lines)
> From: Simon Streit <simon@netpanic.org>
>
> * gnu/packages/audio.scm (cyanrip): New variable.
> ---
>  gnu/packages/audio.scm | 30 +++++++++++++++++++++++++++++-
>  1 file changed, 29 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 6f3fa2a580..966a0b96f9 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -38,7 +38,7 @@
>  ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
>  ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
>  ;;; Copyright © 2022 Juliana Sims <jtsims@protonmail.com>
> -;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
> +;;; Copyright © 2022, 2023 Simon Streit <simon@netpanic.org>
>  ;;; Copyright © 2022 Andy Tai <atai@atai.org>
>  ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
>  ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
> @@ -68,6 +68,7 @@ (define-module (gnu packages audio)
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages build-tools)
>    #:use-module (gnu packages boost)
> +  #:use-module (gnu packages cdrom)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages curl)
> @@ -124,6 +125,7 @@ (define-module (gnu packages audio)
>    #:use-module (gnu packages linux)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages valgrind)
> +  #:use-module (gnu packages version-control)
>    #:use-module (gnu packages video)
>    #:use-module (gnu packages vim) ;xxd
>    #:use-module (gnu packages web)
> @@ -6316,3 +6318,29 @@ (define-public cubeb
>        (description "Cubeb is Mozilla's cross-platform audio
> library.")
>        (home-page "https://github.com/mozilla/cubeb")
>        (license license:isc))))
> +
> +(define-public cyanrip
> +  (package
> +    (name "cyanrip")
> +    (version "0.9.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/cyanreg/cyanrip")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1pf381qmqr3p3xk26w8v4gfv5cyi5siljs4gv485spsq6icynzw0"))))
> +    (build-system meson-build-system)
> +    (native-inputs
> +     (list pkg-config))
> +    (propagated-inputs
> +     (list curl ffmpeg libcdio-paranoia libmusicbrainz libxml2
> neon))
Propagated inputs are not that great, prefer normal ones. Also don't
let the lines get too long.
Toggle quote (1 lines)
> +    (synopsis "Fully featured CD ripping program")
Avoid marketing buzzwords; perhaps use "Console CD ripper" instead?
Toggle quote (5 lines)
> +    (description "Console CD ripper with automatic tagging through
> integration
> +with MusicBrainz , error detection, log generation, many formats,
> HDCD
> +decoding, covert art automatic download.")
Please use complete sentences for the description.

Cheers
M
[PATCH v2 0/1] gnu: Add cyanrip.
(address . 62132@debbugs.gnu.org)
cover.1722168257.git.stigma@disroot.org
Toggle quote (7 lines)
> Propagated inputs are not that great, prefer normal ones. Also don't
> let the lines get too long.
> [...]
> Avoid marketing buzzwords; perhaps use "Console CD ripper" instead?
> [...]
> Please use complete sentences for the description.

Hey, I hope you don't mind but I updated the package definition to use the
latest version of cyanrip (0.9.3.1) and modified the synopsis and description
to be more complete and neutral.

Simon Streit (1):
gnu: Add cyanrip.

gnu/packages/audio.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)


base-commit: 46a64c7fdd057283063aae6df058579bb07c4b6a
--
2.39.2
M
[PATCH v2 1/1] gnu: Add cyanrip.
(address . 62132@debbugs.gnu.org)
a54d44c0c6a949b0ae781873928b1a110a31f5c1.1722168257.git.stigma@disroot.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/audio.scm (cyanrip): New variable.

Signed-off-by: mio <stigma@disroot.org>
Change-Id: If7059b47e5a9f968570af8617f28bbe9a8b30b93
---
gnu/packages/audio.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b728220e1f..0aea78b117 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2022, 2023 Juliana Sims <juli@incana.org>
-;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2022, 2023 Simon Streit <simon@netpanic.org>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
@@ -47,6 +47,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2024 hapster <o.rojon@posteo.net>
+;;; Copyright © 2024 mio <stigma@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,6 +75,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cdrom)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
@@ -137,6 +139,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages telephony)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
#:use-module (gnu packages web)
@@ -6537,6 +6540,38 @@ (define-public cubeb
(home-page "https://github.com/mozilla/cubeb")
(license license:isc))))
+(define-public cyanrip
+ (package
+ (name "cyanrip")
+ (version "0.9.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cyanreg/cyanrip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13v6gjbxw6ybviq802wmgwlwy846ma4yw94aay0h698qhjqwf0qq"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list curl
+ ffmpeg
+ libcdio-paranoia
+ libmusicbrainz
+ libxml2
+ neon))
+ (synopsis "Command line CD ripper and encoder")
+ (description
+ "cyanrip is a command line tool for ripping CDs. It uses
+MusicBrainz to name and tag each track, and to download and embed cover art.
+cyanrip supports encoding tracks to multiple formats in parallel, and can
+save files in FLAC, Opus, MP3, TTA (True Audio), WavPac, ALAC, Vorbis, and
+AAC formats. Checksums for ripped tracks are automatically verified using
+the Exact Audio Copy CRC32 and AccurateRip V1 and V2 databases.")
+ (home-page "https://github.com/cyanreg/cyanrip")
+ (license license:lgpl2.1+)))
+
(define-public easyeffects
(package
(name "easyeffects")
--
2.39.2
L
L
Liliana Marie Prikler wrote on 28 Jul 20:46 +0200
(name . Simon Streit)(address . simon@netpanic.org)
9e72715d5965e1a76ffa50a247651e212cafbc93.camel@gmail.com
Am Sonntag, dem 28.07.2024 um 22:10 +1000 schrieb mio:
Toggle quote (82 lines)
> From: Simon Streit <simon@netpanic.org>
>
> * gnu/packages/audio.scm (cyanrip): New variable.
>
> Signed-off-by: mio <stigma@disroot.org>
> Change-Id: If7059b47e5a9f968570af8617f28bbe9a8b30b93
> ---
>  gnu/packages/audio.scm | 37 ++++++++++++++++++++++++++++++++++++-
>  1 file changed, 36 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index b728220e1f..0aea78b117 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -38,7 +38,7 @@
>  ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
>  ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
>  ;;; Copyright © 2022, 2023 Juliana Sims <juli@incana.org>
> -;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
> +;;; Copyright © 2022, 2023 Simon Streit <simon@netpanic.org>
>  ;;; Copyright © 2022 Andy Tai <atai@atai.org>
>  ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
>  ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
> @@ -47,6 +47,7 @@
>  ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
>  ;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
>  ;;; Copyright © 2024 hapster <o.rojon@posteo.net>
> +;;; Copyright © 2024 mio <stigma@disroot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -74,6 +75,7 @@ (define-module (gnu packages audio)
>    #:use-module (gnu packages boost)
>    #:use-module (gnu packages build-tools)
>    #:use-module (gnu packages check)
> +  #:use-module (gnu packages cdrom)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages cpp)
>    #:use-module (gnu packages curl)
> @@ -137,6 +139,7 @@ (define-module (gnu packages audio)
>    #:use-module (gnu packages telephony)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages valgrind)
> +  #:use-module (gnu packages version-control)
>    #:use-module (gnu packages video)
>    #:use-module (gnu packages vim) ;xxd
>    #:use-module (gnu packages web)
> @@ -6537,6 +6540,38 @@ (define-public cubeb
>        (home-page "https://github.com/mozilla/cubeb")
>        (license license:isc))))
>  
> +(define-public cyanrip
> +  (package
> +    (name "cyanrip")
> +    (version "0.9.3.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/cyanreg/cyanrip")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "13v6gjbxw6ybviq802wmgwlwy846ma4yw94aay0h698qhjqwf0qq"))))
> +    (build-system meson-build-system)
> +    (native-inputs (list pkg-config))
> +    (inputs (list curl
> +                  ffmpeg
> +                  libcdio-paranoia
> +                  libmusicbrainz
> +                  libxml2
> +                  neon))
> +    (synopsis "Command line CD ripper and encoder")
> +    (description
> +     "cyanrip is a command line tool for ripping CDs.  It uses
> +MusicBrainz to name and tag each track, and to download and embed
> cover art.
> +cyanrip supports encoding tracks to multiple formats in parallel,
> and can
> +save files in FLAC, Opus, MP3, TTA (True Audio), WavPac, ALAC,
> Vorbis, and
Perhaps we can shorten that to just "multiple formats in parallel"?
Toggle quote (3 lines)
> +AAC formats.  Checksums for ripped tracks are automatically verified
> using
> +the Exact Audio Copy CRC32 and AccurateRip V1 and V2 databases.")
Perhaps shorten this to "Checksums are automatically verified"?
Toggle quote (2 lines)
> +    (license license:lgpl2.1+)))
Otherwise LGTM.

Cheers
M
[PATCH v3] gnu: Add cyanrip.
(address . 62132@debbugs.gnu.org)
a53a507ea98d652194230766934beca2f4ee0c7a.1722250654.git.stigma@disroot.org
From: Simon Streit <simon@netpanic.org>

* gnu/packages/audio.scm (cyanrip): New variable.

Signed-off-by: mio <stigma@disroot.org>
Change-Id: If7059b47e5a9f968570af8617f28bbe9a8b30b93
---
gnu/packages/audio.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b728220e1f..1e7ee55bfc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -38,7 +38,7 @@
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2022, 2023 Juliana Sims <juli@incana.org>
-;;; Copyright © 2022 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2022, 2023 Simon Streit <simon@netpanic.org>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
@@ -47,6 +47,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2024 hapster <o.rojon@posteo.net>
+;;; Copyright © 2024 mio <stigma@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,6 +75,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cdrom)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
@@ -137,6 +139,7 @@ (define-module (gnu packages audio)
#:use-module (gnu packages telephony)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
#:use-module (gnu packages web)
@@ -6537,6 +6540,36 @@ (define-public cubeb
(home-page "https://github.com/mozilla/cubeb")
(license license:isc))))
+(define-public cyanrip
+ (package
+ (name "cyanrip")
+ (version "0.9.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cyanreg/cyanrip")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13v6gjbxw6ybviq802wmgwlwy846ma4yw94aay0h698qhjqwf0qq"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list curl
+ ffmpeg
+ libcdio-paranoia
+ libmusicbrainz
+ libxml2
+ neon))
+ (synopsis "Command line CD ripper and encoder")
+ (description
+ "cyanrip is a command line tool for ripping CDs. It uses
+MusicBrainz to name and tag each track, and to download and embed cover art.
+cyanrip supports encoding tracks to multiple formats in parallel and automatically
+verifies checksums.")
+ (home-page "https://github.com/cyanreg/cyanrip")
+ (license license:lgpl2.1+)))
+
(define-public easyeffects
(package
(name "easyeffects")
--
2.39.2
L
L
Liliana Marie Prikler wrote on 4 Aug 08:01 +0200
(name . Simon Streit)(address . simon@netpanic.org)
2a6a552c73b3ee9dde2db96b2c23512bc33a2656.camel@gmail.com
Am Montag, dem 29.07.2024 um 20:58 +1000 schrieb mio:
Toggle quote (6 lines)
> From: Simon Streit <simon@netpanic.org>
>
> * gnu/packages/audio.scm (cyanrip): New variable.
>
> Signed-off-by: mio <stigma@disroot.org>
> Change-Id: If7059b47e5a9f968570af8617f28bbe9a8b30b93
Pushed as 4e9c5c601905eb281f2304d0a0d35992c51054cd.

Heads-up, I just now noticed that you used Signed-off-by: instead of
Co-authored-by: to signal co-authorship. Let's avoid that next time ;)

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62132@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62132
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch