conses wrote 2 years ago
(address . guix-patches@gnu.org)(address . contact@conses.eu)
* gnu/home/services/xdisorg.scm: New file.
---
gnu/home/services/xdisorg.scm | 72 +++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)
create mode 100644 gnu/home/services/xdisorg.scm
Toggle diff (86 lines)
diff --git a/gnu/home/services/xdisorg.scm b/gnu/home/services/xdisorg.scm
new file mode 100644
index 0000000000..02c538ff9f
--- /dev/null
+++ b/gnu/home/services/xdisorg.scm
@@ -0,0 +1,72 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 conses <contact@conses.eu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services xdisorg)
+ #:use-module (gnu home services)
+ #:use-module (gnu home services shepherd)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu services configuration)
+ #:use-module (guix packages)
+ #:use-module (guix gexp)
+ #:export (home-unclutter-configuration
+ home-unclutter-service-type))
+
+(define-configuration/no-serialization home-unclutter-configuration
+ (unclutter
+ (package unclutter)
+ "The @code{unclutter} package to use.")
+ (seconds
+ (integer 5)
+ "The number of idle seconds to wait to remove the cursor."))
+
+(define (home-unclutter-shepherd-service config)
+ (list
+ (shepherd-service
+ (provision '(unclutter))
+ (requirement '())
+ (one-shot? #t)
+ (start #~(make-forkexec-constructor
+ (list
+ #$(file-append
+ (home-unclutter-configuration-unclutter config)
+ "/bin/unclutter")
+ "-idle"
+ (number->string
+ #$(home-unclutter-configuration-seconds config)))
+ #:log-file (string-append
+ (or (getenv "XDG_LOG_HOME")
+ (format #f "~a/.local/var/log"
+ (getenv "HOME")))
+ "/unclutter.log"))))))
+
+(define (home-unclutter-profile-service config)
+ (list (home-unclutter-configuration-unclutter config)))
+
+(define home-unclutter-service-type
+ (service-type
+ (name 'home-unclutter)
+ (extensions
+ (list
+ (service-extension
+ home-profile-service-type
+ home-unclutter-profile-service)
+ (service-extension
+ home-shepherd-service-type
+ home-unclutter-shepherd-service)))
+ (default-value (home-unclutter-configuration))
+ (description "Set up an unclutter daemon.")))
--
2.39.1
--
Best regards,
conses