Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioconductor.scm (r-hdcytodata): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d603bd42c1..1cf33501d6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -560,6 +560,46 @@ (define-public r-hdo-db
https://github.com/DiseaseOntology/HumanDiseaseOntology/tree/main/src/ontology}.")
(license license:artistic2.0)))
+(define-public r-hdcytodata
+ (package
+ (name "r-hdcytodata")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "HDCytoData" version
+ 'experiment))
+ (sha256
+ (base32
+ "1fn8q6ds10z3ymdarkfyh88pcqnrry9yhzammp84vf86f0bl8mrc"))))
+ (properties `((upstream-name . "HDCytoData")))
+ (build-system r-build-system)
+ (arguments
+ (list #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'unpack 'avoid-internet-access
+ (lambda _
+ (setenv "GUIX_BUILD" "yes")
+ (substitute* "R/zzz.R"
+ (("createHubAccessors.*" m)
+ (string-append
+ "if (Sys.getenv(\"GUIX_BUILD\") == \"\") {" m
+ "}"))))))))
+ (propagated-inputs (list r-experimenthub r-flowcore r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/lmweber/HDCytoData")
+ (synopsis
+ "Set of high-dimensional flow cytometry and mass cytometry benchmark datasets")
+ (description
+ "HDCytoData contains a set of high-dimensional cytometry benchmark datasets.
+These datasets are formatted into SummarizedExperiment and flowSet
+Bioconductor object formats, including all required metadata. Row metadata
+includes sample IDs, group IDs, patient IDs, reference cell population or
+cluster labels and labels identifying spiked in cells. Column metadata
+includes channel names, protein marker names, and protein marker classes.")
+ (license license:expat)))
+
(define-public r-homo-sapiens
(package
(name "r-homo-sapiens")
--
2.34.1