[PATCH] gnu: Add r-hdcytodata.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Navid Afkhami
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
20230310161612.26795-1-navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-hdcytodata): New variable.
---
gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d603bd42c1..1cf33501d6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -560,6 +560,46 @@ (define-public r-hdo-db
https://github.com/DiseaseOntology/HumanDiseaseOntology/tree/main/src/ontology}.")
(license license:artistic2.0)))
+(define-public r-hdcytodata
+ (package
+ (name "r-hdcytodata")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "HDCytoData" version
+ 'experiment))
+ (sha256
+ (base32
+ "1fn8q6ds10z3ymdarkfyh88pcqnrry9yhzammp84vf86f0bl8mrc"))))
+ (properties `((upstream-name . "HDCytoData")))
+ (build-system r-build-system)
+ (arguments
+ (list #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'unpack 'avoid-internet-access
+ (lambda _
+ (setenv "GUIX_BUILD" "yes")
+ (substitute* "R/zzz.R"
+ (("createHubAccessors.*" m)
+ (string-append
+ "if (Sys.getenv(\"GUIX_BUILD\") == \"\") {" m
+ "}"))))))))
+ (propagated-inputs (list r-experimenthub r-flowcore r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/lmweber/HDCytoData")
+ (synopsis
+ "Set of high-dimensional flow cytometry and mass cytometry benchmark datasets")
+ (description
+ "HDCytoData contains a set of high-dimensional cytometry benchmark datasets.
+These datasets are formatted into SummarizedExperiment and flowSet
+Bioconductor object formats, including all required metadata. Row metadata
+includes sample IDs, group IDs, patient IDs, reference cell population or
+cluster labels and labels identifying spiked in cells. Column metadata
+includes channel names, protein marker names, and protein marker classes.")
+ (license license:expat)))
+
(define-public r-homo-sapiens
(package
(name "r-homo-sapiens")
--
2.34.1
Christopher Baines wrote 2 years ago
(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)(address . 62098-done@debbugs.gnu.org)
87o7lw6bla.fsf@cbaines.net
Navid Afkhami <navid.afkhami@mdc-berlin.de> writes:

Toggle quote (13 lines)
> * gnu/packages/bioconductor.scm (r-hdcytodata): New variable.
> ---
> gnu/packages/bioconductor.scm | 40 +++++++++++++++++++++++++++++++++++
> 1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
> index d603bd42c1..1cf33501d6 100644
> --- a/gnu/packages/bioconductor.scm
> +++ b/gnu/packages/bioconductor.scm
> @@ -560,6 +560,46 @@ (define-public r-hdo-db
> https://github.com/DiseaseOntology/HumanDiseaseOntology/tree/main/src/ontology}.")
> (license license:artistic2.0)))

Looks like this was committed as
f7682c247504d252cf86b274ffe7b8f62670b497.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmR7INFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfn0hAAm9CuplO8nsk8pIecBHpXxArhbg+MTEzx
kNllnkb/mFGgYEIc6UBArfeNjJ4b3SXjl/Ik+9btfUGiK0JHzKikU5ocdG53RHmG
WRQ3uyzfN1JHpVQRxOXKX0pGMOg+m0KyAzEW3wPJ2QmVdb5MTgafxJ4xSOmLszNv
w9EbAl0IyBAeJShZCGOTSKwnoe+UFlKixOR+eDJRgweWtfNrlaxPboPFkKPXt/9C
eSvZw0WuOTegKGGiDvdmzAYh9Cgw5OMKyt+Kv7Q1Fen4s12O2TpCK88piW6Zi2Fk
JElK8iI7szJUNe/r7bF/IOJqDZeE2Y4j+bm37m6QA4zDQ59tqbXX8zryQXflU6k9
Ahjy7K25FrkLhx9MqFmeyFHCKiU3IlTRawobBT90ZWhLfCx6c6EApmW/+ALuJQ4W
cczPG25sh6GJa/1aatzgdat131hUCy+BnI+vA89bALGoUR601dWsFlL2ur90Hv4z
BE/M7zJLGjcHjsLxVIRKT2LV4sCTJQbT10WdLfQmjxB19jKAukvJtyjsn/amAshT
0ZLc6mRdBhDJTAEVE7Itz6xas0aOfYB3FDu+IZ/F7VkXIu8XnK4sZR7ir2tHSnV+
pFXbXiYHTEGB6/xrwMuI65YiKN+kbiJDjdaYx/Ke0s58NqSnY7d67jiVYAAvsvqR
pFTvk+D6q20=
=NAYv
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62098@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62098
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help