[PATCH 0/4] gnu: Add python-fluent-migrate.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 18:05
(address . guix-patches@gnu.org)
3cc416e3-d5a7-1731-d57b-337d38f2cb5a@disroot.org
From 3804eb92b073eacce1043875483687fbfea91cf8 Mon Sep 17 00:00:00 2001
Message-Id: <cover.1678381163.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:59:23 +0800
Subject: [PATCH 0/4] gnu: Add python-fluent-migrate.

This patch series is a part of my effort in packaging IceCat's bundled dependencies, so that they can be unbundled in the future.
Once IceCat's dependencies are all unbundled, it should make it be easier for people to modify GNU IceCat.

AwesomeAdam54321 (4):
gnu: Add python-fluent-syntax.
gnu: Add python-hglib.
gnu: Add python-compare-locales.
gnu: Add python-fluent-migrate.

gnu/packages/python-check.scm | 42 +++++++++++++++++++++++
gnu/packages/python-xyz.scm | 59 ++++++++++++++++++++++++++++++++
gnu/packages/version-control.scm | 18 ++++++++++
3 files changed, 119 insertions(+)


base-commit: 5befcff66edb4d72ab8e713c81836fb8519ce3e6
--
2.39.2
A
A
Adam Faiz wrote on 9 Mar 2023 18:07
[PATCH 1/4] gnu: Add python-fluent-syntax.
(address . 62083@debbugs.gnu.org)
0f5b29fa-20f5-5885-fc29-c2fb0dcd9929@disroot.org
From ca7555bdf0939dff37ea698fb918601cc6d59a49 Mon Sep 17 00:00:00 2001
Message-Id: <ca7555bdf0939dff37ea698fb918601cc6d59a49.1678381163.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678381163.git.adam.faiz@disroot.org>
References: <cover.1678381163.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 23:38:43 +0800
Subject: [PATCH 1/4] gnu: Add python-fluent-syntax.

* gnu/packages/python-xyz.scm (python-fluent-syntax): New variable.
---
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92ea561737..625c703aaf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27650,6 +27650,35 @@ (define-public python-lazr-config
validation.")
(license license:lgpl3)))
+(define-public python-fluent-syntax
+ (package
+ (name "python-fluent-syntax")
+ (version "0.18.1")
+ (source
+ (origin
+ ;; Tests not included in release.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/projectfluent/python-fluent")
+ (commit (string-append "fluent.syntax@" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06a88fyhqvmhpp1wf7ghcmpzg92s8wgpb1bbi4y09ixva5r9dgwg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-six))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'chdir
+ (lambda _
+ (chdir "fluent.syntax"))))))
+ (home-page "https://github.com/projectfluent/python-fluent")
+ (synopsis "Localization library for expressive translations")
+ (description "fluent.syntax provides the parser, serializer,
+and traversal utilities for the Fluent localization system.")
+ (license license:asl2.0)))
+
(define-public python-flufl-bounce
(package
(name "python-flufl-bounce")
--
2.39.2
A
A
Adam Faiz wrote on 9 Mar 2023 18:09
[PATCH 2/4] gnu: Add python-hglib.
(address . 62083@debbugs.gnu.org)
2ea5f895-0513-2e2f-a2e7-35872c957554@disroot.org
From bf2f8969a089e8039519c9d1fe895bb87d858085 Mon Sep 17 00:00:00 2001
Message-Id: <bf2f8969a089e8039519c9d1fe895bb87d858085.1678381163.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678381163.git.adam.faiz@disroot.org>
References: <cover.1678381163.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 23:57:41 +0800
Subject: [PATCH 2/4] gnu: Add python-hglib.

* gnu/packages/version-control.scm (python-hglib): New variable.
---
gnu/packages/version-control.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index aa89c8752b..3dd042e683 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1925,6 +1925,24 @@ (define-public python-hg-evolve
history. It implements the changeset evolution concept for Mercurial.")
(license license:gpl2)))
+(define-public python-hglib
+ (package
+ (name "python-hglib")
+ (version "2.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hglib" version))
+ (sha256
+ (base32
+ "17jky5dvfa1w4jqm5c5dn23i92hcdgfh6051xn7fwjik3a53lziz"))))
+ (build-system python-build-system)
+ (home-page "https://bitbucket.org/515k4/hglib/")
+ (synopsis "Mercurial Python library")
+ (description
+ "python-hglib is a Python library for interfacing with
+Mercurial's CommandServer.")
+ (license license:expat)))
+
(define-public hg-commitsigs
;; Latest tag is 11 years old.
(let ((changeset "b53eb6862bff")
--
2.39.2
A
A
Adam Faiz wrote on 9 Mar 2023 18:18
[PATCH 3/4] gnu: Add python-compare-locales.
(address . 62083@debbugs.gnu.org)
6d159a1a-d9ab-c218-be39-33c5e0c188ce@disroot.org
From 4a3c42b3b8756a561a084d1f4265c71a6751dae5 Mon Sep 17 00:00:00 2001
Message-Id: <4a3c42b3b8756a561a084d1f4265c71a6751dae5.1678382249.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678382249.git.adam.faiz@disroot.org>
References: <cover.1678382249.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:11:38 +0800
Subject: [PATCH 3/4] gnu: Add python-compare-locales.

* gnu/packages/python-check.scm (python-compare-locales): New variable.
---
gnu/packages/python-check.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 41a6997190..dca5d07a54 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1715,6 +1715,29 @@ (define-public python-codacy-coverage
analysing code quality.")
(license license:expat)))
+(define-public python-compare-locales
+ (package
+ (name "python-compare-locales")
+ (version "8.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "compare-locales" version))
+ (sha256
+ (base32
+ "0m6qhf06qrhggsh5y325xbpssl5plwlhzmx3v93y3y38dkcm03a7"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-mock))
+ (propagated-inputs
+ (list python-fluent-syntax python-pytoml python-six))
+ (home-page "https://pypi.org/project/compare-locales/")
+ (synopsis "Lint Mozilla localizations")
+ (description
+ "Compare-locales finds missing strings, obsolete strings,
+errors on runtime errors without false positives, and warns
+on possible runtime errors. It also includes l10n-merge functionality.")
+ (license license:mpl2.0)))
+
(define-public python-httmock
(package
(name "python-httmock")
--
2.39.2
A
A
Adam Faiz wrote on 9 Mar 2023 18:20
[PATCH 4/4] gnu: Add python-fluent-migrate.
(address . 62083@debbugs.gnu.org)
a0562483-8a5e-87b0-9f1f-9047fd618fec@disroot.org
From 7be6e59c5231bb825c69c9ce48976bc49d2810ed Mon Sep 17 00:00:00 2001
Message-Id: <7be6e59c5231bb825c69c9ce48976bc49d2810ed.1678382249.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678382249.git.adam.faiz@disroot.org>
References: <cover.1678382249.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:19:27 +0800
Subject: [PATCH 4/4] gnu: Add python-fluent-migrate.

* gnu/packages/python-xyz.scm (python-fluent-migrate): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 625c703aaf..5f695da802 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27650,6 +27650,36 @@ (define-public python-lazr-config
validation.")
(license license:lgpl3)))
+(define-public python-fluent-migrate
+ (package
+ (name "python-fluent-migrate")
+ (version "0.11")
+ (source
+ (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://hg.mozilla.org/l10n/fluent-migration/")
+ (changeset "fabfe61d6b73a7a0a7333a80f9eb066fee39588c")))
+ (file-name (hg-file-name name version))
+ (sha256
+ (base32
+ "18pxa40afgpmpf9r919scqdyf6xvnapxm7qzlhcls2ah3xx4y451"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list mercurial
+ python-hglib
+ python-mock))
+ (propagated-inputs
+ (list python-compare-locales
+ python-fluent-syntax
+ python-six))
+ (home-page "https://hg.mozilla.org/l10n/fluent-migration/")
+ (synopsis "Toolchain to migrate legacy translation to Fluent")
+ (description "@code{fluent.migrate} is a toolchain to migrate legacy translation
+to Fluent. It can programmatically create Fluent files from existing content
+in both legacy and Fluent formats.")
+ (license license:asl2.0)))
+
(define-public python-fluent-syntax
(package
(name "python-fluent-syntax")
--
2.39.2
?