[PATCH] gnu: Add python-json-e.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 17:52
(address . guix-patches@gnu.org)
dda64fba-c0e9-b808-3f84-6c775d6d797d@disroot.org
From e737a1a084085a211ad96dcb1033a566c06dd878 Mon Sep 17 00:00:00 2001
Message-Id: <e737a1a084085a211ad96dcb1033a566c06dd878.1678379862.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 23:14:22 +0800
Subject: [PATCH] gnu: Add python-json-e.

* gnu/packages/python-xyz.scm (python-json-e): New variable.
---
gnu/packages/python-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b4173da3fd..92ea561737 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26491,6 +26491,45 @@ (define-public python-xattr
associated with file system objects (files, directories, symlinks, etc).")
(license license:expat)))
+(define-public python-json-e
+ (package
+ (name "python-json-e")
+ (version "4.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/json-e/json-e")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0m3rsl2wvcn1i781d7l4xp0vx58sn89y0fhsvmrczlvkbpywzb3a"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-dateutil
+ python-freezegun
+ python-hypothesis
+ python-nose
+ python-pep8
+ python-pyyaml))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'cd-to-py-dir
+ (lambda _
+ (chdir "py")))
+ (replace 'check
+ (lambda _
+ (invoke "nosetests"))))))
+ (home-page "https://json-e.js.org")
+ (synopsis
+ "Data-structure parameterizer for embedding context in JSON objects")
+ (description
+ "This package provides a data-structure parameterization system written for
+embedding context in JSON objects.")
+ (license license:mpl2.0)))
+
(define-public python-json-logger
(package
(name "python-json-logger")
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 62082@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62082
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch