[PATCH] gnu: Add python-glean-parser.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 17:50
(address . guix-patches@gnu.org)
0b8eb4b0-8c7d-d96d-e0ce-eec868d51b8d@disroot.org
From 545997a268891952bc87934f67c721224c9df7a8 Mon Sep 17 00:00:00 2001
Message-Id: <545997a268891952bc87934f67c721224c9df7a8.1678379861.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 22:53:13 +0800
Subject: [PATCH] gnu: Add python-glean-parser.

* gnu/packages/python-xyz.scm (python-glean-parser): New variable.
---
gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37cd6fb0af..b4173da3fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22996,6 +22996,43 @@ (define-public python-globber
path components.")
(license license:asl2.0)))
+(define-public python-glean-parser
+ (package
+ (name "python-glean-parser")
+ (version "7.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "glean_parser" version))
+ (sha256
+ (base32
+ "1mfclj0vx65pr2wyk675cp66c1yi5vwry8p1aipm1p60dzfn12f4"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (substitute* "setup.py"
+ ((".*setuptools-scm>=7.*") ""))))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest
+ python-pytest-runner))
+ (propagated-inputs
+ (list python-appdirs
+ python-click
+ python-diskcache
+ python-iso8601
+ python-jinja2
+ python-jsonschema
+ python-markupsafe
+ python-pyyaml
+ python-yamllint))
+ (home-page "https://github.com/mozilla/glean_parser")
+ (synopsis "Parser tools for Mozilla's Glean telemetry")
+ (description
+ "Glean Parser contains various utilities for handling metrics.yaml
+and pings.yaml for the Glean SDKs. This includes producing generated code
+for various integrations, linting and coverage testing.")
+ (license license:mpl2.0)))
+
(define-public python-git-hammer
(package
(name "python-git-hammer")
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 62081@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62081
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch