[PATCH] gnu: Add python-mozilla-version.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 17:49
(address . guix-patches@gnu.org)
55f675a4-9250-a725-6928-0571a8b7d63e@disroot.org
From db5ef591064fa34751e6ef7ff53eba3fcd2d578f Mon Sep 17 00:00:00 2001
Message-Id: <db5ef591064fa34751e6ef7ff53eba3fcd2d578f.1678379861.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 22:13:06 +0800
Subject: [PATCH] gnu: Add python-mozilla-version.

* gnu/packages/python-xyz.scm (python-mozilla-version): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a5732fdad..37cd6fb0af 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3639,6 +3639,31 @@ (define-public python-mozilla-repo-urls
The intent is to centralize URLs parsing.")
(license license:mpl2.0)))
+(define-public python-mozilla-version
+ (package
+ (name "python-mozilla-version")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mozilla-version" version))
+ (sha256
+ (base32
+ "1dl08bpk97rcjhd1zg8ahw1kbc3ingkpmflmdx4z476a349w82xk"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-attrs
+ python-future))
+ (home-page "https://github.com/mozilla-releng/mozilla-version")
+ (synopsis
+ "Library for processing Firefox versions numbers")
+ (description
+ "This package processes Firefox versions numbers.
+ It tells whether they are valid or not, whether they are nightlies or regular
+releases, whether this version precedes that other.")
+ (license license:mpl2.0)))
+
(define-public python-py
(package
(name "python-py")
--
2.39.2
?