[PATCH] gnu: Add python-mozilla-repo-urls.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 17:48
(address . guix-patches@gnu.org)
be124580-2d6f-d655-e646-26283988fd9b@disroot.org
From 9b78a69c98646b5e5d0efef029522b81b71e5be6 Mon Sep 17 00:00:00 2001
Message-Id: <9b78a69c98646b5e5d0efef029522b81b71e5be6.1678379861.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 22:02:39 +0800
Subject: [PATCH] gnu: Add python-mozilla-repo-urls.

* gnu/packages/python-xyz.scm (python-mozilla-repo-urls): New variable.
---
gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d4f0a83a5d..2a5732fdad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3612,6 +3612,33 @@ (define-public python-redo
retry to any Python callable.")
(license license:mpl2.0)))
+(define-public python-mozilla-repo-urls
+ (package
+ (name "python-mozilla-repo-urls")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch) ;version.txt not in pypi release
+ (uri (git-reference
+ (url "https://github.com/mozilla-releng/mozilla-repo-urls")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13fzkw59yhphyc5n8w286i4rbh9j93wh015b1b3lc4pbcy1wxnkj"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs
+ (list python-giturlparse))
+ (home-page "https://github.com/mozilla-releng/mozilla-repo-urls")
+ (synopsis
+ "Process Mozilla's repository URLs")
+ (description
+ "This package processes Mozilla's repository URLs.
+ The intent is to centralize URLs parsing.")
+ (license license:mpl2.0)))
+
(define-public python-py
(package
(name "python-py")
--
2.39.2
?