[PATCH] gnu: Add python-redo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Adam Faiz
  • jgart
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 9 Mar 2023 17:47
(address . guix-patches@gnu.org)
e311e1ad-1dcf-2ef1-8086-6706045a78d1@disroot.org
From f22e04ade259930dc3c3e282d044b7b8b6b1f774 Mon Sep 17 00:00:00 2001
Message-Id: <f22e04ade259930dc3c3e282d044b7b8b6b1f774.1678379861.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:59:48 +0800
Subject: [PATCH] gnu: Add python-redo.

* gnu/packages/python-xyz.scm (python-redo): New variable.
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4bacd86432..d4f0a83a5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3595,6 +3595,23 @@ (define-public python-miniupnpc
(home-page "http://miniupnp.free.fr")
(license license:bsd-3)))
+(define-public python-redo
+ (package
+ (name "python-redo")
+ (version "2.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "redo" version))
+ (sha256
+ (base32
+ "0hx0yyl2mz13v513vyjc3h9lbkkxhyh6bswich73p18w0ianj1l1"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/mozilla-releng/redo")
+ (synopsis "Utilities to retry Python callables")
+ (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+ (license license:mpl2.0)))
+
(define-public python-py
(package
(name "python-py")
--
2.39.2
J
J
jgart wrote on 2 Jun 2023 14:48
d93dfce192aba7b3105161a759536f5d@dismail.de
Hi Adam,

Thanks for the patch!

Could you send an updated patch (v2) enabling the tests on python-redo and adding any test inputs that are required for that?

This current patch also does not apply cleanly to master:

error: corrupt patch at line 33
Patch failed at 0001 gnu: Add python-redo.

all best,

jgart
A
A
Adam Faiz wrote on 3 Jun 2023 06:02
Re: [PATCH v2] gnu: Add python-redo.
855dc5d7-657c-f9db-b819-792ee1b0a430@disroot.org
From 971c628998b36dc32bafd30364f635bafc8ff7cd Mon Sep 17 00:00:00 2001
Message-Id: <971c628998b36dc32bafd30364f635bafc8ff7cd.1685764335.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:59:48 +0800
Subject: [PATCH v2] gnu: Add python-redo.

* gnu/packages/python-xyz.scm (python-redo): New variable.
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19f4ec97ff..2e2387a14a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29988,6 +29988,41 @@ (define-public python-recommonmark
lets you write CommonMark inside of Docutils & Sphinx projects.")
(license license:expat)))
+(define-public python-redo
+ ; The latest release isn't tagged:
+ ; https://github.com/mozilla-releng/redo/issues/76
+ (let ((commit "50cfe8e3656f253f9e51df3a998530351d2d9a8c")
+ (revision "0"))
+ (package
+ (name "python-redo")
+ (version (git-version "2.0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/mozilla-releng/redo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xpylx97qr4ikdhsr208ri41007mpp57a4n8mmlmlqmdljmsdpdb"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-mock
+ python-pytest))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The project uses tox to run the tests via pytest.
+ (invoke "pytest")))))))
+ (home-page "https://github.com/mozilla-releng/redo")
+ (synopsis "Utilities to retry Python callables")
+ (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+ (license license:mpl2.0))))
+
(define-public python-pyhull
(package
(name "python-pyhull")

base-commit: 12e6a5923812abf180f03bea9e07dd99244a3fcd
--
2.40.1
J
J
jgart wrote on 4 Jun 2023 15:14
299af6a1f3d1d59bc17b549b8d50b812@dismail.de
Hi Adam,

Thanks for sending an update.

How did you take this patch? I'm trying to debug why this patch is not applying cleanly on my end.

I get the following error:

warning: Patch sent with format=flowed; space at the end of lines might be lost.
Applying: gnu: Add python-redo.
error: corrupt patch at line 51
Patch failed at 0001 gnu: Add python-redo.

all best,

jgart
J
(address . control@debbugs.gnu.org)
70969d7ddb3b57e83db65b0278724322@dismail.de
tags 62078 moreinfo
A
A
Adam Faiz wrote on 24 Jun 2023 01:47
6a9e1e37-7a22-c760-dfb8-da59b398ba77@disroot.org
On 6/4/23 21:14, jgart wrote:
Toggle quote (12 lines)
> Hi Adam,
>
> Thanks for sending an update.
>
> How did you take this patch? I'm trying to debug why this patch is not applying cleanly on my end.
>
> I get the following error:
>
> warning: Patch sent with format=flowed; space at the end of lines might be lost.
> Applying: gnu: Add python-redo.
> error: corrupt patch at line 51
> Patch failed at 0001 gnu: Add python-redo.Sorry for the late reply, the patch doesn't apply cleanly because my email client sent the email with format=flowed.
Attached is a rebased patch on top of master.
Toggle quote (3 lines)
> all best,
>
> jgart
From 280f9812dbd0330e5656b19c3f818a811b1e7637 Mon Sep 17 00:00:00 2001
Message-Id: <280f9812dbd0330e5656b19c3f818a811b1e7637.1687562979.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:59:48 +0800
Subject: [PATCH v2] gnu: Add python-redo.

* gnu/packages/python-xyz.scm (python-redo): New variable.
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 799c5652b0..0b0403c0ce 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30280,6 +30280,41 @@ (define-public python-recommonmark
lets you write CommonMark inside of Docutils & Sphinx projects.")
(license license:expat)))
+(define-public python-redo
+ ; The latest release isn't tagged:
+ ; https://github.com/mozilla-releng/redo/issues/76
+ (let ((commit "50cfe8e3656f253f9e51df3a998530351d2d9a8c")
+ (revision "0"))
+ (package
+ (name "python-redo")
+ (version (git-version "2.0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/mozilla-releng/redo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xpylx97qr4ikdhsr208ri41007mpp57a4n8mmlmlqmdljmsdpdb"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-mock
+ python-pytest))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The project uses tox to run the tests via pytest.
+ (invoke "pytest")))))))
+ (home-page "https://github.com/mozilla-releng/redo")
+ (synopsis "Utilities to retry Python callables")
+ (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+ (license license:mpl2.0))))
+
(define-public python-pyhull
(package
(name "python-pyhull")

base-commit: f25529b08e356f89ca7cecc44295085531a8faba
--
2.40.1
J
[PATCH] gnu: Add python-redo.
(address . control@debbugs.gnu.org)
b9b48f09eca9bbff1f0def2ab447adfa@dismail.de
Hi Adam,

Thanks for the patch. APPLIED.

all best,

jgart
Closed
?