guix style looses comments
(name . bug-guix)(address . bug-guix@gnu.org)
Hello,
Consider this package:
Toggle snippet (28 lines)
(define-public ruby-webrick
(package
(name "ruby-webrick")
(version "1.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ruby/webrick")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1xb0mk3cghdir65nmj0mblprbf21blli7267b6yyvxclh307yp6s"))))
(build-system ruby-build-system)
(arguments (list #:phases #~(modify-phases %standard-phases
(add-after 'extract-gemspec 'delete-problematic-tests
(lambda _
;; The httresponse tests fail for
;; unknown reasons (see:
;; https://github.com/ruby/webrick/issues/112).
(delete-file "test/webrick/test_httpresponse.rb"))))))
(home-page "https://github.com/ruby/webrick")
(synopsis "HTTP server toolkit")
(description "WEBrick is an HTTP server toolkit that can be configured as an
HTTPS server, a proxy server, and a virtual-host server.")
(license license:bsd-2)))
After running ./pre-inst-env guix style ruby-webrick, it produces:
Toggle snippet (27 lines)
(define-public ruby-webrick
(package
(name "ruby-webrick")
(version "1.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ruby/webrick")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1xb0mk3cghdir65nmj0mblprbf21blli7267b6yyvxclh307yp6s"))))
(build-system ruby-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
(add-after 'extract-gemspec 'delete-problematic-tests
(lambda _
(delete-file "test/webrick/test_httpresponse.rb"))))))
(home-page "https://github.com/ruby/webrick")
(synopsis "HTTP server toolkit")
(description
"WEBrick is an HTTP server toolkit that can be configured as an
HTTPS server, a proxy server, and a virtual-host server.")
(license license:bsd-2)))
I.e., it lost the comment in the phase. It also causes the longest line
to be 82 chars, while it could have easily broken the line to make it
fit under 80.
--
Thanks,
Maxim